aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-05-22 04:39:56 +0800
committerpav <pav@FreeBSD.org>2006-05-22 04:39:56 +0800
commit145690ae55addda0944ca0a0f297f0a1652007bf (patch)
tree7e9a9f4d3b193620cbd13d1c006c2fc547f4a937
parentb2bb33de904a32957cce2d0d7319e5a538314149 (diff)
downloadfreebsd-ports-gnome-145690ae55addda0944ca0a0f297f0a1652007bf.tar.gz
freebsd-ports-gnome-145690ae55addda0944ca0a0f297f0a1652007bf.tar.zst
freebsd-ports-gnome-145690ae55addda0944ca0a0f297f0a1652007bf.zip
- Update to 2.5c2
PR: ports/96146 Submitted by: Bernd Luevelsmeyer <bdluevel@heitec.net> (maintainer)
-rw-r--r--www/xitami/Makefile47
-rw-r--r--www/xitami/distinfo6
-rw-r--r--www/xitami/files/default.html14
-rw-r--r--www/xitami/files/defaults.cfg.in44
-rw-r--r--www/xitami/files/defaults.cfg.tmpl7
-rw-r--r--www/xitami/files/dir.gsl24
-rw-r--r--www/xitami/files/patch-aa50
-rw-r--r--www/xitami/files/patch-ab20
-rw-r--r--www/xitami/files/patch-ac39
-rw-r--r--www/xitami/files/patch-ad18
-rw-r--r--www/xitami/files/patch-ae4
-rw-r--r--www/xitami/files/patch-gsl-makefile24
-rw-r--r--www/xitami/files/patch-sfl-makefile22
-rw-r--r--www/xitami/files/patch-smt-makefile20
-rw-r--r--www/xitami/files/patch-studio-makefile44
-rw-r--r--www/xitami/files/patch-xiadmin-makefile20
-rw-r--r--www/xitami/files/patch-xiopen-makefile8
-rw-r--r--www/xitami/files/xitami.8.in55
-rw-r--r--www/xitami/files/xitami.aut36
-rw-r--r--www/xitami/files/xitami.sh.in36
-rw-r--r--www/xitami/files/xitami.sh.tmpl27
-rw-r--r--www/xitami/pkg-deinstall19
-rw-r--r--www/xitami/pkg-plist62
23 files changed, 389 insertions, 257 deletions
diff --git a/www/xitami/Makefile b/www/xitami/Makefile
index 02ecff1f143d..a73d24b180c1 100644
--- a/www/xitami/Makefile
+++ b/www/xitami/Makefile
@@ -6,40 +6,45 @@
#
PORTNAME= xitami
-PORTVERSION= 2.4d7
-PORTREVISION= 1
+PORTVERSION= 2.5c2
CATEGORIES= www
-MASTER_SITES= http://users.skynet.be/sky37432/
-DISTNAME= suni24d7
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://www.xitami.com/
+DISTNAME= xiopen_2_5_src
MAINTAINER= bdluevel@heitec.net
COMMENT= A fast, portable multithreaded web server
NO_WRKSUBDIR= yes
+MAN8= xitami.8
+
+SUB_FILES= defaults.cfg \
+ xitami.8
+
+USE_RC_SUBR= xitami.sh
+
.include <bsd.port.pre.mk>
do-build:
- @${CHMOD} +x ${WRKSRC}/xibuild
- @${SETENV} TOPDIR=${WRKSRC} ${SH} ${WRKSRC}/xibuild
+ ${MAKE} -C ${WRKSRC}/sfl
+ ${MAKE} -C ${WRKSRC}/gsl
+ ${MAKE} -C ${WRKSRC}/smt
+ ${MAKE} -C ${WRKSRC}/studio
+ ${MAKE} -C ${WRKSRC}/xiadmin
+ ${MAKE} -C ${WRKSRC}/xiopen
do-install:
- @${MKDIR} ${PREFIX}/xitami/cgi-bin
- @${MKDIR} ${PREFIX}/xitami/webpages
- @${CAT} ${FILESDIR}/defaults.cfg.tmpl | ${SED} s:PREFIX:${PREFIX}: > ${WRKDIR}/defaults.cfg
- @${INSTALL_DATA} ${WRKDIR}/defaults.cfg ${PREFIX}/xitami/defaults.cfg.sample
- @${INSTALL_DATA} ${FILESDIR}/xitami.aut ${PREFIX}/xitami
- @${CHMOD} u+w ${PREFIX}/xitami/*
- @${INSTALL_DATA} ${WRKSRC}/src/smt/xitami.cfg ${PREFIX}/xitami
- @${INSTALL_PROGRAM} ${WRKSRC}/src/smt/xitami ${PREFIX}/xitami
- @${INSTALL_PROGRAM} ${WRKSRC}/cgi-src/testcgi ${PREFIX}/xitami/cgi-bin
- @${CAT} ${FILESDIR}/xitami.sh.tmpl | ${SED} s:PREFIX:${PREFIX}: > ${WRKDIR}/xitami.sh
- @${INSTALL_SCRIPT} ${WRKDIR}/xitami.sh ${PREFIX}/etc/rc.d/xitami.sh.sample
+ ${MKDIR} ${PREFIX}/etc/xitami
+ ${INSTALL_DATA} ${WRKDIR}/defaults.cfg ${PREFIX}/etc/xitami/defaults.cfg.sample
+ ${INSTALL_DATA} ${FILESDIR}/xitami.aut ${PREFIX}/etc/xitami
+ ${INSTALL_DATA} ${WRKSRC}/xiopen/xitami.cfg ${PREFIX}/etc/xitami
+ ${INSTALL_DATA} ${WRKSRC}/xiopen/pipedef.xml ${PREFIX}/etc/xitami
+ ${INSTALL_DATA} ${FILESDIR}/dir.gsl ${PREFIX}/etc/xitami
+ ${INSTALL_PROGRAM} ${WRKSRC}/xiopen/xitami ${PREFIX}/libexec
+ ${INSTALL_MAN} ${WRKSRC}/xitami.8 ${PREFIX}/man/man8
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/xitami/html
- @${INSTALL_MAN} ${WRKSRC}/webpages/xitami/* ${PREFIX}/share/doc/xitami/html
- @${INSTALL_MAN} ${FILESDIR}/default.html ${PREFIX}/xitami/webpages/default.html.sample
+ ${MKDIR} ${DOCSDIR}/html
+ ${INSTALL_MAN} ${WRKSRC}/xiopen/webpages/xitami/* ${DOCSDIR}/html
.endif
.include <bsd.port.post.mk>
diff --git a/www/xitami/distinfo b/www/xitami/distinfo
index 120567d98118..7d01f395db76 100644
--- a/www/xitami/distinfo
+++ b/www/xitami/distinfo
@@ -1,3 +1,3 @@
-MD5 (suni24d7.tgz) = 5240c334ebc993be8847c8af7c64e9fe
-SHA256 (suni24d7.tgz) = 65ed2a9c5b17b6464ec3c75a1944188f71450c8385a4382c6293b096f635d7e5
-SIZE (suni24d7.tgz) = 1056971
+MD5 (xiopen_2_5_src.tar.gz) = 458d624324a7d68840f1c54fee5c7772
+SHA256 (xiopen_2_5_src.tar.gz) = 369165694117631c66d0f42c478d2e869f809994ea862dd96f26a106260d7014
+SIZE (xiopen_2_5_src.tar.gz) = 1858927
diff --git a/www/xitami/files/default.html b/www/xitami/files/default.html
deleted file mode 100644
index d942a189101a..000000000000
--- a/www/xitami/files/default.html
+++ /dev/null
@@ -1,14 +0,0 @@
-<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
-
-<HTML>
-
-<HEAD>
-<TITLE>Redirecting to Xitami documentation...</TITLE>
-<META HTTP-EQUIV="REFRESH" CONTENT="0; URL= /xitami/index.htm">
-</HEAD>
-
-<BODY BACKGROUND="" BGCOLOR="#ffffff" TEXT="#000000" LINK="#0000ff" VLINK="#800080" ALINK="#ff0000">
-
-</BODY>
-
-</HTML>
diff --git a/www/xitami/files/defaults.cfg.in b/www/xitami/files/defaults.cfg.in
new file mode 100644
index 000000000000..2931f2439451
--- /dev/null
+++ b/www/xitami/files/defaults.cfg.in
@@ -0,0 +1,44 @@
+[Server]
+ webpages=%%PREFIX%%/share/doc/xitami/html
+ dir-script=dir.gsl
+ default1=index.html
+ default2=-
+
+ error-header=<html><title>HTTP Error</title><body><strong>HTTP Error</strong><p>
+ text-400=400 (Bad request)
+ text-401=401 (Unauthorized)
+ text-402=402 (Payment required)
+ text-403=403 (Forbidden)
+ text-404=404 (Not found)
+ text-412=412 (Precondition failed)
+ text-413=413 (Request entity too large)
+ text-500=500 (Internal error)
+ text-501=501 (Not implemented)
+ text-502=502 (Service temporarily overloaded)
+ error-footer=</body></html>
+
+[CGI]
+ enabled=0
+
+[Security]
+ admin=0
+ superuser=""
+ safepaths=0
+ setuid=1
+ setuid-user=www
+ setuid-group=www
+
+[ServerLog]
+ enabled=0
+
+[AccessLog]
+ enabled=0
+
+[ErrorLog]
+ enabled=0
+
+[Ftp]
+ enabled=0
+
+[Lrwp]
+ enabled=0
diff --git a/www/xitami/files/defaults.cfg.tmpl b/www/xitami/files/defaults.cfg.tmpl
deleted file mode 100644
index da7ed9c13c48..000000000000
--- a/www/xitami/files/defaults.cfg.tmpl
+++ /dev/null
@@ -1,7 +0,0 @@
-#*END
-
-[Alias]
- Xitami=PREFIX/share/doc/xitami/html
-
-[Ftp]
- Enabled=0
diff --git a/www/xitami/files/dir.gsl b/www/xitami/files/dir.gsl
new file mode 100644
index 000000000000..8de078babaeb
--- /dev/null
+++ b/www/xitami/files/dir.gsl
@@ -0,0 +1,24 @@
+.output "$(tempfile?httpdir.lst)"
+<html><title>Directory listing of $(urlbase:)</title>
+<body>
+<strong>$(urlbase:)</strong><hr>
+<table border=0>
+<tr><th align=left>Name</th><th align=center>Size</th><th align=left>Modified</th></tr>
+.if defined (urlparent)
+ <tr><td><a href="$(urlparent:)"><tt>../</tt></a></td><td></td><td></td>
+.endif
+.for file
+. if defined (directory)
+ <tr><td><a href="$(urlbase:)$(nameurl:)"><tt>$(name:)/</tt></a></td>
+. else
+ <tr><td><a href="$(urlbase:)$(nameurl:)"><tt>$(name:)</tt></a></td>
+. endif
+. if defined (directory)
+ <td></td>
+. else
+ <td align=right><tt>$(size) $(units:)</tt></td>
+. endif
+ <td align=left><tt>$(date) $(time)</tt></td></tr>
+.endfor
+</table>
+</body></html>
diff --git a/www/xitami/files/patch-aa b/www/xitami/files/patch-aa
deleted file mode 100644
index 149314d7652f..000000000000
--- a/www/xitami/files/patch-aa
+++ /dev/null
@@ -1,50 +0,0 @@
---- xibuild.original Tue Nov 7 09:32:29 2000
-+++ xibuild Tue Nov 7 09:39:53 2000
-@@ -8,7 +8,6 @@
- # This script builds the SFL and SMT packages, then installs XITAMI ready
- # for use. XITAMI is installed in the current directory.
-
--TOPDIR=$PWD
- SRCDIR=$TOPDIR/src
- SFLDIR=$TOPDIR/src/sfl
- SMTDIR=$TOPDIR/src/smt
-@@ -53,17 +52,12 @@
- echo "Welcome to the Xitami web server, copyright (c) 1991-99 iMatix."
- echo "This script will compile and link XITAMI, ready for use on this"
- echo "$SYSTEM system. Nothing is installed in any system directories."
--echo "Please confirm this information:"
- echo " System . . . . . .: $SYSTEM"
- echo " ANSI C compiler. .: $COMPILE"
- echo ""
--echo "If the ANSI C compile command is wrong, you will have to modify the"
--echo "'c' scripts in these directories:"
--echo " $SFLDIR, $SMTDIR"
--echo ""
--echo "If this information looks okay, press [Enter] to build Xitami."
-+echo " SFL Source Path...: $SFLDIR"
-+echo " SMT Source Path...: $SMTDIR"
- echo "--------------------------------------------------------------------"
--read pause
-
- # Now, rebuild the SFL package
-
-@@ -103,18 +97,4 @@
- fi
- cd $TOPDIR
-
--# Install XITAMI in its own directory
--echo xibuild: Installing XITAMI files...
--test ! -d $CGIBIN && mkdir $CGIBIN
--cp $SMTDIR/xitami .
--cp $CGISRC/testcgi $CGIBIN
--cp $CGISRC/testcgi? $CGIBIN
--
--chmod +x xiconfig
--test ! -f defaults.cfg && ./xiconfig
--
--echo ""
--echo "xibuild completed. Please see 'readme' file for info on using"
--echo "Xitami. The Xitami web pages are the main source of information."
--echo "You can run Xitami now by typing 'xitami' or 'xitami -b 5000'."
--echo "browser and the URL http://hostname or http://hostname:5080."
-+echo "xibuild completed."
diff --git a/www/xitami/files/patch-ab b/www/xitami/files/patch-ab
deleted file mode 100644
index 123e0a469c52..000000000000
--- a/www/xitami/files/patch-ab
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/smt/.vimbk/xitami.c.vimbk Sat Apr 1 18:11:39 2000
-+++ src/smt/xitami.c Tue Nov 7 10:01:40 2000
-@@ -168,7 +168,7 @@
- fclose (stdout); /* Kill standard output */
- fclose (stderr); /* and standard error */
- }
-- else
-+ else if (*background == '0')
- puts (COPYRIGHT);
-
- if (*background == '1')
-@@ -177,7 +177,7 @@
- *background_args [] = { "-s", NULL };
-
- puts ("Moving into the background");
-- if (process_server (NULL, NULL, argc, argv, background_args) != 0)
-+ if (process_server (NULL, "/var/run/xitami.pid", argc, argv, background_args) != 0)
- {
- puts ("Backgrounding failed. Giving up.");
- exit (EXIT_FAILURE);
diff --git a/www/xitami/files/patch-ac b/www/xitami/files/patch-ac
deleted file mode 100644
index cf30ef326524..000000000000
--- a/www/xitami/files/patch-ac
+++ /dev/null
@@ -1,39 +0,0 @@
---- src/sfl/.vimbk/sflproc.c.vimbk Sat Apr 1 18:11:24 2000
-+++ src/sfl/sflproc.c Tue Nov 7 11:29:34 2000
-@@ -1711,8 +1711,6 @@
- file_handle;
- char
- pid_buffer [10];
-- struct flock
-- lock_file; /* flock() argument block */
- #endif
- int
- argi = 0, /* Input arguments iterator */
-@@ -1787,17 +1785,21 @@
-
- if (lockfile && strused (lockfile))
- {
-- file_handle = open (lockfile, O_RDWR | O_CREAT, 0640);
-- if (file_handle < 0)
-+ if ((file_handle = (open (lockfile, O_RDONLY | O_CREAT, 0640))) == -1)
- return (-1); /* We could not open lock file */
-- else
-+ if (flock(file_handle, LOCK_EX | LOCK_NB) == -1 && errno == EWOULDBLOCK)
- {
-- lock_file.l_type = F_WRLCK;
-- if (fcntl (file_handle, F_SETLK, &lock_file))
-- return (-1); /* We could not obtain a lock */
-+ close (file_handle);
-+ return (-1); /* The file is already locked */
- }
-+ close (file_handle);
-+
-+ if ((file_handle = (open (lockfile, O_RDWR | O_TRUNC, 0640))) == -1)
-+ return (-1); /* We could not open lock file */
-+ if (flock(file_handle, LOCK_EX | LOCK_NB) == -1)
-+ return (-1); /* We could not obtain a lock */
- /* We record the server's process id in the lock file */
-- sprintf (pid_buffer, "%6d\n", getpid ());
-+ sprintf (pid_buffer, "%ld\n", (long)getpid ());
- write (file_handle, pid_buffer, strlen (pid_buffer));
- }
diff --git a/www/xitami/files/patch-ad b/www/xitami/files/patch-ad
deleted file mode 100644
index 4d434c13d372..000000000000
--- a/www/xitami/files/patch-ad
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/sfl/.vimbk/prelude.h.vimbk Sat Apr 1 18:11:21 2000
-+++ src/sfl/prelude.h Tue Nov 7 11:33:15 2000
-@@ -532,12 +532,15 @@
- # endif
-
- #elif (defined (__UTYPE_BSDOS))
-+# undef TIMEZONE
- # define TIMEZONE 0 /* timezone is not available */
-
- #elif (defined (__UTYPE_FREEBSD))
-+# undef TIMEZONE
- # define TIMEZONE 0 /* timezone is not available */
-
- #elif (defined (__UTYPE_NETBSD))
-+# undef TIMEZONE
- # define TIMEZONE 0 /* timezone is not available */
-
- #elif (defined (__VMS__))
diff --git a/www/xitami/files/patch-ae b/www/xitami/files/patch-ae
index 5d6b7ae7c97d..cace88653147 100644
--- a/www/xitami/files/patch-ae
+++ b/www/xitami/files/patch-ae
@@ -1,5 +1,5 @@
---- src/sfl/prelude.h.orig Fri Jul 11 23:10:08 2003
-+++ src/sfl/prelude.h Tue Jul 20 15:21:33 2004
+--- sfl/prelude.h.orig Fri Jul 11 23:10:08 2003
++++ sfl/prelude.h Tue Jul 20 15:21:33 2004
@@ -175,6 +175,10 @@
#elif (defined (FreeBSD) || defined (__FreeBSD__))
# define __UTYPE_FREEBSD
diff --git a/www/xitami/files/patch-gsl-makefile b/www/xitami/files/patch-gsl-makefile
new file mode 100644
index 000000000000..5fa8efc3407d
--- /dev/null
+++ b/www/xitami/files/patch-gsl-makefile
@@ -0,0 +1,24 @@
+--- gsl/makefile.orig Thu Jul 22 16:51:49 2004
++++ gsl/makefile Wed Apr 19 10:27:25 2006
+@@ -22,7 +22,7 @@
+ # with the iMatix c script without any arguments.
+ #
+ .c$(OBJ):
+- c -q $<
++ $(CC) $(CFLAGS) -I../sfl -c $<
+ # And .c files _do_not_ depend on .l files (.l files are Libero files,
+ # not lex input files as the default rules think).
+ #
+@@ -39,10 +39,10 @@
+ # Dependencies
+ #
+ libgsl$(LIB): ggcode$(OBJ) ggcomm$(OBJ) ggeval$(OBJ) ggfile$(OBJ) ggfunc$(OBJ) ggobjt$(OBJ) ggstrn$(OBJ) ggpars$(OBJ)
+- c -q -r libgsl$(LIB) ggcode$(OBJ) ggcomm$(OBJ) ggeval$(OBJ) ggfile$(OBJ) ggfunc$(OBJ) ggobjt$(OBJ) ggstrn$(OBJ) ggpars$(OBJ)
++ $(AR) -r libgsl$(LIB) ggcode$(OBJ) ggcomm$(OBJ) ggeval$(OBJ) ggfile$(OBJ) ggfunc$(OBJ) ggobjt$(OBJ) ggstrn$(OBJ) ggpars$(OBJ)
+ gslgen$(OBJ): gslgen.c #!mkdep
+ gslgen$(EXE): gslgen$(OBJ) libgsl$(LIB)
+- c -q -L gslgen
++ $(CC) $(CFLAGS) -o $@ $> -L../sfl -lsfl -lm
+ ggcode$(OBJ): ggcode.c #!mkdep
+ ggcomm$(OBJ): ggcomm.c #!mkdep
+ ggeval$(OBJ): ggeval.c #!mkdep
diff --git a/www/xitami/files/patch-sfl-makefile b/www/xitami/files/patch-sfl-makefile
new file mode 100644
index 000000000000..9a09518044de
--- /dev/null
+++ b/www/xitami/files/patch-sfl-makefile
@@ -0,0 +1,22 @@
+--- sfl/makefile.orig Thu Jul 22 16:51:48 2004
++++ sfl/makefile Sun May 21 22:23:17 2006
+@@ -21,8 +21,8 @@
+ # Objects depend on source files with the same name; and are compiled
+ # with the iMatix c script without any arguments.
+ #
+-.c$(OBJ):
+- c -q $<
++#.c$(OBJ):
++# c -q $<
+ # And .c files _do_not_ depend on .l files (.l files are Libero files,
+ # not lex input files as the default rules think).
+ #
+@@ -39,7 +39,7 @@
+ # Dependencies
+ #
+ libsfl$(LIB): sflbits$(OBJ) sflcomp$(OBJ) sflcons$(OBJ) sflconv$(OBJ) sflcryp$(OBJ) sflcvbs$(OBJ) sflcvdp$(OBJ) sflcvds$(OBJ) sflcvns$(OBJ) sflcvsb$(OBJ) sflcvsd$(OBJ) sflcvsn$(OBJ) sflcvst$(OBJ) sflcvtp$(OBJ) sflcvts$(OBJ) sfldate$(OBJ) sfldbio$(OBJ) sfldir$(OBJ) sflenv$(OBJ) sflexdr$(OBJ) sflfile$(OBJ) sflfind$(OBJ) sflfort$(OBJ) sflhttp$(OBJ) sflini$(OBJ) sfllang$(OBJ) sfllbuf$(OBJ) sfllist$(OBJ) sflmail$(OBJ) sflmath$(OBJ) sflmem$(OBJ) sflmesg$(OBJ) sflmime$(OBJ) sflmysql$(OBJ) sflnode$(OBJ) sflprint$(OBJ) sflproc$(OBJ) sflslot$(OBJ) sflsock$(OBJ) sflstr$(OBJ) sflsymb$(OBJ) sflsyst$(OBJ) sfltok$(OBJ) sfltree$(OBJ) sfltron$(OBJ) sfluid$(OBJ) sflxml$(OBJ) sflxmll$(OBJ)
+- c -q -r libsfl$(LIB) sflbits$(OBJ) sflcomp$(OBJ) sflcons$(OBJ) sflconv$(OBJ) sflcryp$(OBJ) sflcvbs$(OBJ) sflcvdp$(OBJ) sflcvds$(OBJ) sflcvns$(OBJ) sflcvsb$(OBJ) sflcvsd$(OBJ) sflcvsn$(OBJ) sflcvst$(OBJ) sflcvtp$(OBJ) sflcvts$(OBJ) sfldate$(OBJ) sfldbio$(OBJ) sfldir$(OBJ) sflenv$(OBJ) sflexdr$(OBJ) sflfile$(OBJ) sflfind$(OBJ) sflfort$(OBJ) sflhttp$(OBJ) sflini$(OBJ) sfllang$(OBJ) sfllbuf$(OBJ) sfllist$(OBJ) sflmail$(OBJ) sflmath$(OBJ) sflmem$(OBJ) sflmesg$(OBJ) sflmime$(OBJ) sflmysql$(OBJ) sflnode$(OBJ) sflprint$(OBJ) sflproc$(OBJ) sflslot$(OBJ) sflsock$(OBJ) sflstr$(OBJ) sflsymb$(OBJ) sflsyst$(OBJ) sfltok$(OBJ) sfltree$(OBJ) sfltron$(OBJ) sfluid$(OBJ) sflxml$(OBJ) sflxmll$(OBJ)
++ $(AR) -r libsfl$(LIB) sflbits$(OBJ) sflcomp$(OBJ) sflcons$(OBJ) sflconv$(OBJ) sflcryp$(OBJ) sflcvbs$(OBJ) sflcvdp$(OBJ) sflcvds$(OBJ) sflcvns$(OBJ) sflcvsb$(OBJ) sflcvsd$(OBJ) sflcvsn$(OBJ) sflcvst$(OBJ) sflcvtp$(OBJ) sflcvts$(OBJ) sfldate$(OBJ) sfldbio$(OBJ) sfldir$(OBJ) sflenv$(OBJ) sflexdr$(OBJ) sflfile$(OBJ) sflfind$(OBJ) sflfort$(OBJ) sflhttp$(OBJ) sflini$(OBJ) sfllang$(OBJ) sfllbuf$(OBJ) sfllist$(OBJ) sflmail$(OBJ) sflmath$(OBJ) sflmem$(OBJ) sflmesg$(OBJ) sflmime$(OBJ) sflmysql$(OBJ) sflnode$(OBJ) sflprint$(OBJ) sflproc$(OBJ) sflslot$(OBJ) sflsock$(OBJ) sflstr$(OBJ) sflsymb$(OBJ) sflsyst$(OBJ) sfltok$(OBJ) sfltree$(OBJ) sfltron$(OBJ) sfluid$(OBJ) sflxml$(OBJ) sflxmll$(OBJ)
+ sflbits$(OBJ): sflbits.c #!mkdep
+ sflcomp$(OBJ): sflcomp.c #!mkdep
+ sflcons$(OBJ): sflcons.c #!mkdep
diff --git a/www/xitami/files/patch-smt-makefile b/www/xitami/files/patch-smt-makefile
new file mode 100644
index 000000000000..e0a89944562f
--- /dev/null
+++ b/www/xitami/files/patch-smt-makefile
@@ -0,0 +1,20 @@
+--- smt/makefile.orig Thu Jul 22 16:51:50 2004
++++ smt/makefile Wed Apr 19 09:11:22 2006
+@@ -22,7 +22,7 @@
+ # with the iMatix c script without any arguments.
+ #
+ .c$(OBJ):
+- c -q $<
++ $(CC) $(CFLAGS) -I../sfl -I../gsl -c $<
+ # And .c files _do_not_ depend on .l files (.l files are Libero files,
+ # not lex input files as the default rules think).
+ #
+@@ -39,7 +39,7 @@
+ # Dependencies
+ #
+ libsmt$(LIB): smtecho$(OBJ) smtftpc$(OBJ) smtftpd$(OBJ) smtftpl$(OBJ) smthlog$(OBJ) smthttp$(OBJ) smthttpl$(OBJ) smtlib$(OBJ) smtlog$(OBJ) smtoper$(OBJ) smtpipe$(OBJ) smtrdns$(OBJ) smtrdnsl$(OBJ) smtsimu$(OBJ) smtslot$(OBJ) smtsock$(OBJ) smttime$(OBJ) smttran$(OBJ) smttst1$(OBJ) smttst2$(OBJ) smttst3$(OBJ) smtupmc$(OBJ) smtupmd$(OBJ) xiddns$(OBJ) xierror$(OBJ) xiredir$(OBJ) xiimap$(OBJ) xilrwp$(OBJ) xisuper$(OBJ) xixlog$(OBJ) xixssi$(OBJ) xixxml$(OBJ) smtmsg$(OBJ) smtsslm$(OBJ) xixlogm$(OBJ)
+- c -q -r libsmt$(LIB) smtecho$(OBJ) smtftpc$(OBJ) smtftpd$(OBJ) smtftpl$(OBJ) smthlog$(OBJ) smthttp$(OBJ) smthttpl$(OBJ) smtlib$(OBJ) smtlog$(OBJ) smtoper$(OBJ) smtpipe$(OBJ) smtrdns$(OBJ) smtrdnsl$(OBJ) smtsimu$(OBJ) smtslot$(OBJ) smtsock$(OBJ) smttime$(OBJ) smttran$(OBJ) smttst1$(OBJ) smttst2$(OBJ) smttst3$(OBJ) smtupmc$(OBJ) smtupmd$(OBJ) xiddns$(OBJ) xierror$(OBJ) xiredir$(OBJ) xiimap$(OBJ) xilrwp$(OBJ) xisuper$(OBJ) xixlog$(OBJ) xixssi$(OBJ) xixxml$(OBJ) smtmsg$(OBJ) smtsslm$(OBJ) xixlogm$(OBJ)
++ $(AR) -r libsmt$(LIB) smtecho$(OBJ) smtftpc$(OBJ) smtftpd$(OBJ) smtftpl$(OBJ) smthlog$(OBJ) smthttp$(OBJ) smthttpl$(OBJ) smtlib$(OBJ) smtlog$(OBJ) smtoper$(OBJ) smtpipe$(OBJ) smtrdns$(OBJ) smtrdnsl$(OBJ) smtsimu$(OBJ) smtslot$(OBJ) smtsock$(OBJ) smttime$(OBJ) smttran$(OBJ) smttst1$(OBJ) smttst2$(OBJ) smttst3$(OBJ) smtupmc$(OBJ) smtupmd$(OBJ) xiddns$(OBJ) xierror$(OBJ) xiredir$(OBJ) xiimap$(OBJ) xilrwp$(OBJ) xisuper$(OBJ) xixlog$(OBJ) xixssi$(OBJ) xixxml$(OBJ) smtmsg$(OBJ) smtsslm$(OBJ) xixlogm$(OBJ)
+ smtmsg.h: smtmsg.xml
+ gsl -q smtmsg.xml
+ smtsslm.h: smtsslm.xml
diff --git a/www/xitami/files/patch-studio-makefile b/www/xitami/files/patch-studio-makefile
new file mode 100644
index 000000000000..10f30a755382
--- /dev/null
+++ b/www/xitami/files/patch-studio-makefile
@@ -0,0 +1,44 @@
+--- studio/makefile.orig Thu Jul 22 16:51:52 2004
++++ studio/makefile Wed Apr 19 10:12:34 2006
+@@ -22,7 +22,7 @@
+ # with the iMatix c script without any arguments.
+ #
+ .c$(OBJ):
+- c -q $<
++ $(CC) $(CFLAGS) -I../sfl -I../smt -c $<
+ # And .c files _do_not_ depend on .l files (.l files are Libero files,
+ # not lex input files as the default rules think).
+ #
+@@ -39,7 +39,7 @@
+ # Dependencies
+ #
+ libstu$(LIB): ctxman$(OBJ) wtplib$(OBJ) formio$(OBJ) wtpman$(OBJ) browtp$(OBJ) brocgi$(OBJ) fxtest1$(OBJ) fxtest2$(OBJ) fxtest3$(OBJ) wtpmsg$(OBJ)
+- c -q -r libstu$(LIB) ctxman$(OBJ) wtplib$(OBJ) formio$(OBJ) wtpman$(OBJ) browtp$(OBJ) brocgi$(OBJ) fxtest1$(OBJ) fxtest2$(OBJ) fxtest3$(OBJ) wtpmsg$(OBJ)
++ $(AR) -r libstu$(LIB) ctxman$(OBJ) wtplib$(OBJ) formio$(OBJ) wtpman$(OBJ) browtp$(OBJ) brocgi$(OBJ) fxtest1$(OBJ) fxtest2$(OBJ) fxtest3$(OBJ) wtpmsg$(OBJ)
+ ctxman$(OBJ): ctxman.c #!mkdep
+ wtplib$(OBJ): wtplib.c #!mkdep
+ formio$(OBJ): formio.c #!mkdep
+@@ -50,19 +50,19 @@
+ gsl -q wtpmsg.xml
+ testbro$(OBJ): testbro.c #!mkdep
+ testbro$(EXE): testbro$(OBJ) libstu$(LIB)
+- c -q -L testbro
++ $(CC) $(CFLAGS) -o $@ $> -L../sfl -lsfl
+ fxtest1$(OBJ): fxtest1.c #!mkdep
+ fxtest2$(OBJ): fxtest2.c #!mkdep
+ fxtest3$(OBJ): fxtest3.c #!mkdep
+ fxdemo$(OBJ): fxdemo.c #!mkdep
+ fxdemo$(EXE): fxdemo$(OBJ) libstu$(LIB)
+- c -q -L fxdemo
++ $(CC) $(CFLAGS) -o $@ $> -L../sfl -lsfl
+ fxdemo2$(OBJ): fxdemo2.c #!mkdep
+ fxdemo2$(EXE): fxdemo2$(OBJ) libstu$(LIB)
+- c -q -L fxdemo2
++ $(CC) $(CFLAGS) -o $@ $> -L../sfl -lsfl
+ fxdemo3$(OBJ): fxdemo3.c #!mkdep
+ fxdemo3$(EXE): fxdemo3$(OBJ) libstu$(LIB)
+- c -q -L fxdemo3
++ $(CC) $(CFLAGS) -o $@ $> -L../sfl -lsfl
+ wtpman.i: wtpman.l
+ lr wtpman.l
+ wtpman.d: wtpman.l
diff --git a/www/xitami/files/patch-xiadmin-makefile b/www/xitami/files/patch-xiadmin-makefile
new file mode 100644
index 000000000000..739bbf1a0d47
--- /dev/null
+++ b/www/xitami/files/patch-xiadmin-makefile
@@ -0,0 +1,20 @@
+--- xiadmin/makefile.orig Thu Jul 22 16:51:53 2004
++++ xiadmin/makefile Wed Apr 19 09:51:47 2006
+@@ -22,7 +22,7 @@
+ # with the iMatix c script without any arguments.
+ #
+ .c$(OBJ):
+- c -q $<
++ $(CC) $(CFLAGS) -c -I../smt -I../sfl -I../studio $<
+ # And .c files _do_not_ depend on .l files (.l files are Libero files,
+ # not lex input files as the default rules think).
+ #
+@@ -39,7 +39,7 @@
+ # Dependencies
+ #
+ libxac$(LIB): xiadmin$(OBJ)
+- c -q -r libxac$(LIB) xiadmin$(OBJ)
++ $(AR) -r libxac$(LIB) xiadmin$(OBJ)
+ xiadmin$(OBJ): xiadmin.c #!mkdep
+ xiadmin.i: xiadmin.l
+ lr xiadmin.l
diff --git a/www/xitami/files/patch-xiopen-makefile b/www/xitami/files/patch-xiopen-makefile
new file mode 100644
index 000000000000..feca528aef60
--- /dev/null
+++ b/www/xitami/files/patch-xiopen-makefile
@@ -0,0 +1,8 @@
+--- xiopen/makefile.orig Wed Apr 19 10:28:13 2006
++++ xiopen/makefile Wed Apr 19 10:36:37 2006
+@@ -0,0 +1,5 @@
++
++all : xitami
++
++xitami : xitami.c
++ $(CC) $(CFLAGS) -o $@ -I../smt -I../sfl $< -L../smt -lsmt -L../xiadmin -lxac -L../gsl -lgsl -L../studio -lstu -L../sfl -lsfl -lm
diff --git a/www/xitami/files/xitami.8.in b/www/xitami/files/xitami.8.in
new file mode 100644
index 000000000000..932b06303f52
--- /dev/null
+++ b/www/xitami/files/xitami.8.in
@@ -0,0 +1,55 @@
+.\" Copyright (c) 2006 bdluevel@heitec.net
+.\" All rights reserved.
+.\"
+.\" Redistribution and use in source and binary forms, with or without
+.\" modification, are permitted provided that the following conditions
+.\" are met:
+.\" 1. Redistributions of source code must retain the above copyright
+.\" notice, this list of conditions and the following disclaimer.
+.\" 2. Redistributions in binary form must reproduce the above copyright
+.\" notice, this list of conditions and the following disclaimer in the
+.\" documentation and/or other materials provided with the distribution.
+.\"
+.\" THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+.\" ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+.\" IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+.\" ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
+.\" FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+.\" DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+.\" OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+.\" HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+.\" LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+.\" OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+.\" SUCH DAMAGE.
+.Dd April 20, 2006
+.Dt XITAMI 8
+.Os
+.Sh NAME
+.Nm xitami
+.Nd "an HTTP server"
+.Sh DESCRIPTION
+The
+.Nm
+daemon ist started and stopped by its rc.d script. Set
+``xitami_enable=YES'' in
+.Pa /etc/rc.conf
+to enable starting and stopping.
+.Pp
+Refer to
+.Pa http://www.imatix.com/html/xitami/index.htm
+or the installed HTML pages for information about the configuration
+options.
+.Sh FILES
+.Bl -tag -width indent
+.It Pa %%PREFIX%%/etc/xitami/xitami.cfg
+Default values for and documentation of the configuration options.
+.It Pa %%PREFIX%%/etc/xitami/defaults.cfg
+Configuration file you have to write.
+.It Pa %%DOCSDIR%%/html/*
+Installed documentation.
+.It Pa %%PREFIX%%/etc/rc.d/xitami
+Script to start/stop the daemon.
+.El
+.Sh DIAGNOSTICS
+Diagnostic messages are written to log files; the location of these
+files and the verbosity of the logging depends on the configuration.
diff --git a/www/xitami/files/xitami.aut b/www/xitami/files/xitami.aut
index b421d43c160d..a58ca9b3212a 100644
--- a/www/xitami/files/xitami.aut
+++ b/www/xitami/files/xitami.aut
@@ -1,9 +1,31 @@
-# Authorization file for XITAMI
-# Each [Entry] defines a protected subdirectory
-# The directory name is followed by user=password pairs
+# This section defines the password for the browser-based administration
+# screens. When you install Xitami, the initial password is '-', meaning
+# 'no access'. We don't like default passwords. You should change both
+# the user name and password to something safe.
#
-# A sample entry to control access to the admin pages
-# follows. CHANGE IT AS SOON AS POSSIBLE!
+# Special entries:
+# webmask include/exclude specific IP addresses
+# realm realm for authentication
+# http-put allow HTTP PUT method
+# http-delete allow HTTP DELETE method
+# all=* allow access to all users
+#*END
+[/admin]
+ Admin=- # By default, admin access is disabled
+# Admin=LinPopTea
+# Webmask=local # <== when 'local', remote access is not allowed
#
-[admin]
-admin=letmein
+#[Private]
+# Jacky=robusta
+# Jonas=realtime
+# Sarah=arabica
+#
+#[Documention]
+# all=*
+# webmask=local
+#
+#[Stats]
+# Admin=QzeCat96
+# Root=PakYupTon
+# http-put=1
+# http-delete=1
diff --git a/www/xitami/files/xitami.sh.in b/www/xitami/files/xitami.sh.in
new file mode 100644
index 000000000000..1873e3e4f56b
--- /dev/null
+++ b/www/xitami/files/xitami.sh.in
@@ -0,0 +1,36 @@
+#!/bin/sh
+
+# PROVIDE: httpd
+# REQUIRE: DAEMON
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# xitami_enable (bool): Set to NO by default.
+# Set it to YES to enable xitami.
+# xitami_config (path): Set to %%PREFIX%%/etc/xitami
+# by default.
+#
+
+. %%RC_SUBR%%
+
+name="xitami"
+start_cmd=xitami_start
+rcvar=xitami_enable
+
+command=%%PREFIX%%/libexec/xitami
+
+: ${xitami_enable="NO"}
+: ${xitami_config="%%PREFIX%%/etc/xitami"}
+
+
+xitami_start()
+{
+ echo "Starting xitami."
+ cd ${xitami_config}
+ ${command} -s >/dev/null
+}
+
+
+load_rc_config $name
+run_rc_command "$1"
diff --git a/www/xitami/files/xitami.sh.tmpl b/www/xitami/files/xitami.sh.tmpl
deleted file mode 100644
index b1f53c1f5b0e..000000000000
--- a/www/xitami/files/xitami.sh.tmpl
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/bin/sh
-#
-
-case "$1" in
-
-start)
- if [ -x PREFIX/xitami/xitami ]
- then
- cd PREFIX/xitami
- ./xitami -s && echo -n " xitami"
- fi
- ;;
-
-stop)
- if [ -r /var/run/xitami.pid ]
- then
- kill `cat /var/run/xitami.pid` && echo -n " xitami"
- fi
- ;;
-
-*)
- echo "usage: $0 {start|stop}" 1>&2
- exit 64
- ;;
-
-esac
-
diff --git a/www/xitami/pkg-deinstall b/www/xitami/pkg-deinstall
deleted file mode 100644
index 656f60f04b3f..000000000000
--- a/www/xitami/pkg-deinstall
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/bin/sh
-#
-
-if [ -f /var/run/xitami.pid ]
-then
- ${PKG_PREFIX}/etc/rc.d/xitami.sh stop > /dev/null
- rm /var/run/xitami.pid
-fi
-
-if [ x$2 != xDEINSTALL ]; then
- exit
-fi
-
-echo "When pkg_delete has completed, you should examine ${PKG_PREFIX}/xitami"
-echo "and it's subdirectories for content that you may wish to keep. Once you"
-echo "have determined that it is safe to do so, you may nuke the entire tree"
-echo "with \"rm -R ${PKG_PREFIX}/xitami\"."
-
-exit 0
diff --git a/www/xitami/pkg-plist b/www/xitami/pkg-plist
index e7021f96ceae..e8e2dad0d3e8 100644
--- a/www/xitami/pkg-plist
+++ b/www/xitami/pkg-plist
@@ -1,30 +1,32 @@
-etc/rc.d/xitami.sh.sample
-share/doc/xitami/html/index.htm
-share/doc/xitami/html/index1.htm
-share/doc/xitami/html/index10.htm
-share/doc/xitami/html/index11.htm
-share/doc/xitami/html/index12.htm
-share/doc/xitami/html/index13.htm
-share/doc/xitami/html/index14.htm
-share/doc/xitami/html/index15.htm
-share/doc/xitami/html/index16.htm
-share/doc/xitami/html/index2.htm
-share/doc/xitami/html/index3.htm
-share/doc/xitami/html/index4.htm
-share/doc/xitami/html/index5.htm
-share/doc/xitami/html/index6.htm
-share/doc/xitami/html/index7.htm
-share/doc/xitami/html/index8.htm
-share/doc/xitami/html/index9.htm
-share/doc/xitami/html/license.htm
-xitami/cgi-bin/testcgi
-xitami/defaults.cfg.sample
-xitami/webpages/default.html.sample
-xitami/xitami
-xitami/xitami.aut
-xitami/xitami.cfg
-@dirrm share/doc/xitami/html
-@dirrm share/doc/xitami
-@dirrmtry xitami/webpages
-@dirrmtry xitami/cgi-bin
-@dirrmtry xitami
+etc/xitami/defaults.cfg.sample
+etc/xitami/dir.gsl
+etc/xitami/pipedef.xml
+etc/xitami/xitami.aut
+etc/xitami/xitami.cfg
+libexec/xitami
+@dirrm etc/xitami
+%%PORTDOCS%%%%DOCSDIR%%/html/index.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index1.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index10.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index11.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index12.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index13.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index14.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index15.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index16.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index17.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index18.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index19.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index2.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index20.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index21.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index3.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index4.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index5.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index6.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index7.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index8.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/index9.htm
+%%PORTDOCS%%%%DOCSDIR%%/html/license.htm
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%