aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-02-16 15:56:47 +0800
committerjbeich <jbeich@FreeBSD.org>2015-02-16 15:56:47 +0800
commit147e9032bc5749c91a7a46df4139af27780c186f (patch)
tree03dbc3fa1db477f4cf289690bf684704952e87bb
parentaa791e943e6a1e5715e589b14c6f9da68dadb260 (diff)
downloadfreebsd-ports-gnome-147e9032bc5749c91a7a46df4139af27780c186f.tar.gz
freebsd-ports-gnome-147e9032bc5749c91a7a46df4139af27780c186f.tar.zst
freebsd-ports-gnome-147e9032bc5749c91a7a46df4139af27780c186f.zip
Don't use the default backup suffix
Rename backup file in order to avoid conflict with default suffix as used by REINPLACE_CMD in post-patch. This facilitates reviewing changes done by each step after the build. PR: 197502 Exp-run by: antoine Approved by: autotools (tijl, maintainer) Approved by: portmgr (antoine) Approved by: mentors (implicit)
-rw-r--r--Mk/Uses/libtool.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/Uses/libtool.mk b/Mk/Uses/libtool.mk
index c73be3400e9f..d90126bdf45e 100644
--- a/Mk/Uses/libtool.mk
+++ b/Mk/Uses/libtool.mk
@@ -27,7 +27,7 @@ _INCLUDE_USES_LIBTOOL_POST_MK= yes
patch-libtool:
@${FIND} ${WRKDIR} \( -name configure -or -name ltconfig \) \
- -type f | while read i; do ${SED} -i.bak \
+ -type f | while read i; do ${SED} -i.libtool.bak \
-e '/dragonfly\*/!s/^ *freebsd\*[ )]/dragonfly* | &/' \
-e '/gcc_dir=\\`/s/gcc /$$CC /' \
-e '/gcc_ver=\\`/s/gcc /$$CC /' \
@@ -44,7 +44,7 @@ patch-libtool:
\$$libname\$$release\$$shared_ext\$$major \
\$$libname\$$shared_ext' \
soname_spec='\$$libname\$$release\$$shared_ext\$$major'/; \
- }" $${i} && ${TOUCH} -mr $${i}.bak $${i}; done
+ }" $${i} && ${TOUCH} -mr $${i}.libtool.bak $${i}; done
@${FIND} ${WRKDIR} -type f -name ltmain.sh | \
${XARGS} ${REINPLACE_CMD} \