aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2017-05-09 22:04:18 +0800
committertobik <tobik@FreeBSD.org>2017-05-09 22:04:18 +0800
commit14b1ee7c91bb0c0f0e95b89fcb040036e812becb (patch)
treed091a25aae0fd5667db3b72ac0e985410e83d12d
parent88f32602ad5c0da3384f78355b7e512b6ee90e4c (diff)
downloadfreebsd-ports-gnome-14b1ee7c91bb0c0f0e95b89fcb040036e812becb.tar.gz
freebsd-ports-gnome-14b1ee7c91bb0c0f0e95b89fcb040036e812becb.tar.zst
freebsd-ports-gnome-14b1ee7c91bb0c0f0e95b89fcb040036e812becb.zip
Fix audio output
Let GStreamer decide which audio sink to use and do not force use the ALSA sink. Approved by: lme (mentor) Differential Revision: https://reviews.freebsd.org/D10657
-rw-r--r--games/monkeybubble/Makefile2
-rw-r--r--games/monkeybubble/files/patch-src_audio_sound-manager.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/games/monkeybubble/Makefile b/games/monkeybubble/Makefile
index e298c194dc7e..3a0e97ea4ac1 100644
--- a/games/monkeybubble/Makefile
+++ b/games/monkeybubble/Makefile
@@ -3,7 +3,7 @@
PORTNAME= monkeybubble
PORTVERSION= 0.4.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= games gnome
MASTER_SITES= http://home.gna.org/monkeybubble/downloads/
DISTNAME= monkey-bubble-${PORTVERSION}
diff --git a/games/monkeybubble/files/patch-src_audio_sound-manager.c b/games/monkeybubble/files/patch-src_audio_sound-manager.c
new file mode 100644
index 000000000000..e284a1c7e71a
--- /dev/null
+++ b/games/monkeybubble/files/patch-src_audio_sound-manager.c
@@ -0,0 +1,11 @@
+--- src/audio/sound-manager.c.orig 2017-05-09 13:02:38 UTC
++++ src/audio/sound-manager.c
+@@ -223,7 +223,7 @@ start_play(SoundManager *m, gchar * path)
+ PRIVATE(m)->vorbis_dec = gst_element_factory_make("vorbisdec","vorbisdec");
+ PRIVATE(m)->audioconvert = gst_element_factory_make("audioconvert","audioconvert");
+ PRIVATE(m)->audioscale = gst_element_factory_make("audioscale", "audioscale");
+- PRIVATE(m)->output = gst_element_factory_make("alsasink", "alsa-output");
++ PRIVATE(m)->output = gst_element_factory_make("autoaudiosink", "autoaudiosink");
+
+ PRIVATE(m)->current_music_path = g_strdup(path);
+