aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-24 18:07:59 +0800
committerbapt <bapt@FreeBSD.org>2013-09-24 18:07:59 +0800
commit14cc8cdca649b6c108f806d3d64d885dee7832f6 (patch)
treeccca8bc31585171cf703bb4f6ca052ddcdc5d5ed
parent4869e8c830affdbe3b4a818fee8fd46790514343 (diff)
downloadfreebsd-ports-gnome-14cc8cdca649b6c108f806d3d64d885dee7832f6.tar.gz
freebsd-ports-gnome-14cc8cdca649b6c108f806d3d64d885dee7832f6.tar.zst
freebsd-ports-gnome-14cc8cdca649b6c108f806d3d64d885dee7832f6.zip
In case the port is supporting staging, initialize the PLIST with
@owner root @group wheel to force all the content to in the end being installed with root owner even if packaged with a non root credential
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a21b3075b0a0..225a9659b4df 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -5717,7 +5717,11 @@ generate-plist:
@${ECHO_MSG} "===> Generating temporary packing list"
@${MKDIR} `${DIRNAME} ${TMPPLIST}`
@if [ ! -f ${DESCR} ]; then ${ECHO_MSG} "** Missing pkg-descr for ${PKGNAME}."; exit 1; fi
+.if defined(NO_STAGE)
@>${TMPPLIST}
+.else
+ @${ECHO_CMD} -e "@owner root\n@group wheel" >${TMPPLIST}
+.fi
@for file in ${PLIST_FILES}; do \
${ECHO_CMD} $${file} | ${SED} ${PLIST_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} >> ${TMPPLIST}; \
done