aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2006-04-14 01:53:11 +0800
committerehaupt <ehaupt@FreeBSD.org>2006-04-14 01:53:11 +0800
commit150c67955d5df7bbe44047bedf9c4d46f8cd94f3 (patch)
treeb5c996fab75d33ab2bc4ac08043bf9e4f244dfd2
parente7b7d7900704d01feb457c92fac0f8236ebd3f54 (diff)
downloadfreebsd-ports-gnome-150c67955d5df7bbe44047bedf9c4d46f8cd94f3.tar.gz
freebsd-ports-gnome-150c67955d5df7bbe44047bedf9c4d46f8cd94f3.tar.zst
freebsd-ports-gnome-150c67955d5df7bbe44047bedf9c4d46f8cd94f3.zip
This port now respects FFLAGS.
PR: 95521 Submitted by: Pedro F. Giffuni <giffunip@asme.org>
-rw-r--r--math/blas/Makefile5
-rw-r--r--math/blas/files/makefile.lib4
2 files changed, 6 insertions, 3 deletions
diff --git a/math/blas/Makefile b/math/blas/Makefile
index e06aa86d5367..7a6890043c78 100644
--- a/math/blas/Makefile
+++ b/math/blas/Makefile
@@ -20,7 +20,8 @@ COMMENT= Basic Linear Algebra, level 1, 2, and 3
INSTALLS_SHLIB= yes
NO_WRKSUBDIR= yes
-pre-build:
- ${CP} ${FILESDIR}/makefile.lib ${WRKSRC}/Makefile
+do-configure:
+ @${INSTALL_DATA} ${FILESDIR}/makefile.lib ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's+@FFLAGS@+${FFLAGS}+g' ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/math/blas/files/makefile.lib b/math/blas/files/makefile.lib
index c50b4fc8d889..001cdf3f08b0 100644
--- a/math/blas/files/makefile.lib
+++ b/math/blas/files/makefile.lib
@@ -1,6 +1,8 @@
# @(#)Makefile 5.7 (Berkeley) 6/27/91
+FFLAGS= @FFLAGS@
+
LIBDIR= ${PREFIX}/lib
-NOPROFILE= no
+NO_PROFILE= no
SHLIB_MAJOR= 1