aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2010-10-31 07:27:31 +0800
committerjohans <johans@FreeBSD.org>2010-10-31 07:27:31 +0800
commit153c35c8a76d525c140d070635a40538e3ed419b (patch)
tree986c66d2e0c517fd1eeece6ee3971ff4592ef0ea
parent82ef6913bb784789d84a8ae5d3e7b45a5d3e85a7 (diff)
downloadfreebsd-ports-gnome-153c35c8a76d525c140d070635a40538e3ed419b.tar.gz
freebsd-ports-gnome-153c35c8a76d525c140d070635a40538e3ed419b.tar.zst
freebsd-ports-gnome-153c35c8a76d525c140d070635a40538e3ed419b.zip
Add a new port net/liboauth:
OAuth is an open protocol to allow secure API authorization in a simple and standard method from desktop and web applications. liboauth is a collection of POSIX-c functions implementing the OAuth Core RFC 5849 standard. liboauth provides functions to escape and encode parameters according to OAuth specification and offers high-level functionality to sign requests or verify OAuth signatures as well as perform HTTP requests. WWW: http://liboauth.sourceforge.net/
-rw-r--r--net/Makefile1
-rw-r--r--net/liboauth/Makefile30
-rw-r--r--net/liboauth/distinfo2
-rw-r--r--net/liboauth/pkg-descr10
-rw-r--r--net/liboauth/pkg-plist6
5 files changed, 49 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index bd2280c0c16d..f3580ebabd06 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -328,6 +328,7 @@
SUBDIR += libnetdude
SUBDIR += libnids
SUBDIR += libnss-mysql
+ SUBDIR += liboauth
SUBDIR += libopennet
SUBDIR += liboping
SUBDIR += libosip
diff --git a/net/liboauth/Makefile b/net/liboauth/Makefile
new file mode 100644
index 000000000000..80be077870b2
--- /dev/null
+++ b/net/liboauth/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: liboauth
+# Date created: 30 October 2010
+# Whom: johans
+#
+# $FreeBSD$
+#
+
+PORTNAME= liboauth
+PORTVERSION= 0.9.1
+CATEGORIES= net
+MASTER_SITES= http://liboauth.sourceforge.net/pool/
+
+MAINTAINER= johans@FreeBSD.org
+COMMENT= C library implementing the OAuth Core standard
+
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
+
+GNU_CONFIGURE= yes
+MAKE_ARGS= pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+
+USE_OPENSSL= yes
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+
+MAN3= oauth.3
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^if test/s/ == / = /' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/net/liboauth/distinfo b/net/liboauth/distinfo
new file mode 100644
index 000000000000..d8b3837dff74
--- /dev/null
+++ b/net/liboauth/distinfo
@@ -0,0 +1,2 @@
+SHA256 (liboauth-0.9.1.tar.gz) = 7e2eb08cfb0771e5fb79b458ac749a2f7a87d3d7d732bff7548ad8834aee013b
+SIZE (liboauth-0.9.1.tar.gz) = 395025
diff --git a/net/liboauth/pkg-descr b/net/liboauth/pkg-descr
new file mode 100644
index 000000000000..3379e8109065
--- /dev/null
+++ b/net/liboauth/pkg-descr
@@ -0,0 +1,10 @@
+OAuth is an open protocol to allow secure API authorization in
+a simple and standard method from desktop and web applications.
+
+liboauth is a collection of POSIX-c functions implementing the OAuth
+Core RFC 5849 standard. liboauth provides functions to escape and
+encode parameters according to OAuth specification and offers
+high-level functionality to sign requests or verify OAuth signatures
+as well as perform HTTP requests.
+
+WWW: http://liboauth.sourceforge.net/
diff --git a/net/liboauth/pkg-plist b/net/liboauth/pkg-plist
new file mode 100644
index 000000000000..5db67160f674
--- /dev/null
+++ b/net/liboauth/pkg-plist
@@ -0,0 +1,6 @@
+include/oauth.h
+lib/liboauth.so.8
+lib/liboauth.so
+lib/liboauth.la
+lib/liboauth.a
+libdata/pkgconfig/oauth.pc