aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-02-05 22:27:21 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2017-02-05 22:27:21 +0800
commit154d216d1db4b38b562fcf09d0a31bdaf1336e40 (patch)
tree3fe4562efa579988588b657403843aac1a5cee19
parentb5f6848d66e447c98a0d4b60f347b906440b7602 (diff)
downloadfreebsd-ports-gnome-154d216d1db4b38b562fcf09d0a31bdaf1336e40.tar.gz
freebsd-ports-gnome-154d216d1db4b38b562fcf09d0a31bdaf1336e40.tar.zst
freebsd-ports-gnome-154d216d1db4b38b562fcf09d0a31bdaf1336e40.zip
- Add py-flake8-docstrings, py3-flake8-docstrings
Extension for flake8 which uses pydocstyle to check docstrings WWW: https://pypi.python.org/pypi/flake8-docstrings
-rw-r--r--devel/Makefile2
-rw-r--r--devel/py-flake8-docstrings/Makefile24
-rw-r--r--devel/py-flake8-docstrings/distinfo3
-rw-r--r--devel/py-flake8-docstrings/pkg-descr3
-rw-r--r--devel/py3-flake8-docstrings/Makefile12
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d131769eee82..2334b7804af8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4243,6 +4243,7 @@
SUBDIR += py-five.localsitemanager
SUBDIR += py-flake8
SUBDIR += py-flake8-builtins
+ SUBDIR += py-flake8-docstrings
SUBDIR += py-flake8-import-order
SUBDIR += py-flake8-polyfill
SUBDIR += py-flake8-quotes
@@ -4873,6 +4874,7 @@
SUBDIR += py3-dbus
SUBDIR += py3-flake8
SUBDIR += py3-flake8-builtins
+ SUBDIR += py3-flake8-docstrings
SUBDIR += py3-flake8-import-order
SUBDIR += py3-flake8-polyfill
SUBDIR += py3-flake8-quotes
diff --git a/devel/py-flake8-docstrings/Makefile b/devel/py-flake8-docstrings/Makefile
new file mode 100644
index 000000000000..50457c0f1eca
--- /dev/null
+++ b/devel/py-flake8-docstrings/Makefile
@@ -0,0 +1,24 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= flake8-docstrings
+PORTVERSION= 1.0.3
+CATEGORIES= devel
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Extension for flake8 which uses pydocstyle to check docstrings
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}flake8>=0:devel/py-flake8 \
+ ${PYTHON_PKGNAMEPREFIX}flake8-polyfill>=0:devel/py-flake8-polyfill \
+ ${PYTHON_PKGNAMEPREFIX}pydocstyle>=0:devel/py-pydocstyle
+
+USES?= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-flake8-docstrings/distinfo b/devel/py-flake8-docstrings/distinfo
new file mode 100644
index 000000000000..893e5333a89e
--- /dev/null
+++ b/devel/py-flake8-docstrings/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1486303498
+SHA256 (flake8-docstrings-1.0.3.tar.gz) = 5783a90476e4521b2f9815b5ce734adfd1046071e0238d1df2670354ae3153ae
+SIZE (flake8-docstrings-1.0.3.tar.gz) = 4532
diff --git a/devel/py-flake8-docstrings/pkg-descr b/devel/py-flake8-docstrings/pkg-descr
new file mode 100644
index 000000000000..0fd95472437e
--- /dev/null
+++ b/devel/py-flake8-docstrings/pkg-descr
@@ -0,0 +1,3 @@
+Extension for flake8 which uses pydocstyle to check docstrings
+
+WWW: https://pypi.python.org/pypi/flake8-docstrings
diff --git a/devel/py3-flake8-docstrings/Makefile b/devel/py3-flake8-docstrings/Makefile
new file mode 100644
index 000000000000..48dc59621635
--- /dev/null
+++ b/devel/py3-flake8-docstrings/Makefile
@@ -0,0 +1,12 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-flake8-docstrings
+
+RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}flake8>=0:devel/py3-flake8 \
+ ${PYTHON_PKGNAMEPREFIX}flake8-polyfill>=0:devel/py3-flake8-polyfill \
+ ${PYTHON_PKGNAMEPREFIX}pydocstyle>=0:devel/py3-pydocstyle
+
+USES= python:3
+
+.include "${MASTERDIR}/Makefile"