aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2015-01-14 04:23:58 +0800
committerthierry <thierry@FreeBSD.org>2015-01-14 04:23:58 +0800
commit158ca9fbbaa44c75559925f781fd6e4f029a4331 (patch)
treee7fcc64998397fc2734ab8da309edff28162bd18
parent9346c2bf99d89ebb8eba03fd54a249c6281dd715 (diff)
downloadfreebsd-ports-gnome-158ca9fbbaa44c75559925f781fd6e4f029a4331.tar.gz
freebsd-ports-gnome-158ca9fbbaa44c75559925f781fd6e4f029a4331.tar.zst
freebsd-ports-gnome-158ca9fbbaa44c75559925f781fd6e4f029a4331.zip
Patch to use blaslapack framework.
Includes some cleanups but no functional change. PR: ports/196648 Submitted by: pfg (maintainer)
-rw-r--r--math/ipopt/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/math/ipopt/Makefile b/math/ipopt/Makefile
index 6da029b31460..e448dd016b7c 100644
--- a/math/ipopt/Makefile
+++ b/math/ipopt/Makefile
@@ -17,16 +17,14 @@ COMMENT= Software package for large-scale nonlinear optimization
LICENSE= EPL
-LIB_DEPENDS= liblapack.so:${PORTSDIR}/math/lapack
-
-USES= fortran libtool pkgconfig tar:tgz
+USES= blaslapack fortran libtool pkgconfig tar:tgz
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
CONFIGURE_ENV+= PKG_CONFIG_PATH=${STAGEDIR}${PREFIX}/libdata/pkgconfig
-CONFIGURE_ARGS= --with-lapack-lib="-llapack -L/${LOCALBASE}/lib" \
- --with-lapack-incdir=${LOCALBASE}/include/lapack
+CONFIGURE_ARGS= --with-lapack-lib="${LAPACKLIB} -L${LOCALBASE}/lib" \
+ --with-blas-lib="${BLASLIB} -L${LOCALBASE}/lib"
CXXFLAGS+= -ffast-math