aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-04-17 01:43:11 +0800
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-04-17 01:43:11 +0800
commit163a58aafc11bc1c4faae55118d23d51444a0b73 (patch)
tree30d8ad2c90a46da0c0d75511fbe147da16bcda42
parent0faa68afa05bbd4de6cef739f8b65664deec302b (diff)
downloadfreebsd-ports-gnome-163a58aafc11bc1c4faae55118d23d51444a0b73.tar.gz
freebsd-ports-gnome-163a58aafc11bc1c4faae55118d23d51444a0b73.tar.zst
freebsd-ports-gnome-163a58aafc11bc1c4faae55118d23d51444a0b73.zip
New port: archivers/py-borgbackup.
BorgBackup (short: Borg) is a deduplicating backup program. Optionally, it supports compression and authenticated encryption. The main goal of Borg is to provide an efficient and secure way to backup data. The data deduplication technique used makes Borg suitable for daily backups since only changes are stored. The authenticated encryption technique makes it suitable for backups to not fully trusted targets. WWW: https://pypi.python.org/pypi/borgbackup Note: NO_PACKAGE=yes had to be set because this port only works with Python 3 and depends on other Python ports which are currently only built with Python 2.7 by default. Discussed in the freebsd-python mailing list: https://lists.freebsd.org/pipermail/freebsd-python/2016-April/010144.html PR: 207715 Submitted by: José García Juanino <jjuanino@gmail.com>
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-borgbackup/Makefile44
-rw-r--r--archivers/py-borgbackup/distinfo2
-rw-r--r--archivers/py-borgbackup/pkg-descr11
4 files changed, 58 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index b9c0fafe17b1..dde678b5db76 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -162,6 +162,7 @@
SUBDIR += ppunpack
SUBDIR += pxz
SUBDIR += py-attic
+ SUBDIR += py-borgbackup
SUBDIR += py-bz2file
SUBDIR += py-libarchive-c
SUBDIR += py-librtfcomp
diff --git a/archivers/py-borgbackup/Makefile b/archivers/py-borgbackup/Makefile
new file mode 100644
index 000000000000..486f227454db
--- /dev/null
+++ b/archivers/py-borgbackup/Makefile
@@ -0,0 +1,44 @@
+# Created by: José García Juanino <jjuanino@gmail.com>
+# $FreeBSD$
+
+PORTNAME= borgbackup
+PORTVERSION= 1.0.1
+CATEGORIES= archivers python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jjuanino@gmail.com
+COMMENT= Deduplicating backup program
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.7:${PORTSDIR}/devel/py-setuptools_scm
+LIB_DEPENDS= liblz4.so:${PORTSDIR}/archivers/liblz4
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack-python>=0.4.6:${PORTSDIR}/devel/py-msgpack-python
+
+OPTIONS_DEFINE= FUSE
+FUSE_DESC= Support to mount locally borg backup files
+OPTIONS_DEFAULT=
+
+FUSE_RUN_DEPENDS= ${PYTHONPREFIX_SITELIBDIR}/llfuse.so:${PORTSDIR}/devel/py-llfuse
+
+USES= python:3.4+
+USE_PYTHON= autoplist distutils
+USE_OPENSSL= yes
+
+# Leave py3 only ports as manual port builds.
+# See https://lists.freebsd.org/pipermail/freebsd-python/2016-April/010151.html
+NO_PACKAGE= yes
+
+.include <bsd.port.pre.mk>
+
+# borg requires openssl>=1.0.0
+.if ${OSVERSION} < 1000015
+WITH_OPENSSL_PORT=yes
+.endif
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/borg/*.so
+
+.include <bsd.port.post.mk>
diff --git a/archivers/py-borgbackup/distinfo b/archivers/py-borgbackup/distinfo
new file mode 100644
index 000000000000..6b2dafd3f726
--- /dev/null
+++ b/archivers/py-borgbackup/distinfo
@@ -0,0 +1,2 @@
+SHA256 (borgbackup-1.0.1.tar.gz) = 58a2c2e649207c8e15223f6380d238124b0f1b45fd83990a40df5b678cd41fba
+SIZE (borgbackup-1.0.1.tar.gz) = 413316
diff --git a/archivers/py-borgbackup/pkg-descr b/archivers/py-borgbackup/pkg-descr
new file mode 100644
index 000000000000..8426561bc2bb
--- /dev/null
+++ b/archivers/py-borgbackup/pkg-descr
@@ -0,0 +1,11 @@
+[excerpt from borgbackup web site]
+
+BorgBackup (short: Borg) is a deduplicating backup program. Optionally, it
+supports compression and authenticated encryption.
+
+The main goal of Borg is to provide an efficient and secure way to backup data.
+The data deduplication technique used makes Borg suitable for daily backups
+since only changes are stored. The authenticated encryption technique makes it
+suitable for backups to not fully trusted targets.
+
+WWW: https://pypi.python.org/pypi/borgbackup