aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2008-01-29 00:42:40 +0800
committerdinoex <dinoex@FreeBSD.org>2008-01-29 00:42:40 +0800
commit16a83e0b2fd2115dff77709c77eb1a0a93eb8577 (patch)
tree8ff67fc0a86cdd2b78ccc85decbbd5d5480c008b
parentf9ffe06920da63f42ffe4d1b61029b0d68f3beb2 (diff)
downloadfreebsd-ports-gnome-16a83e0b2fd2115dff77709c77eb1a0a93eb8577.tar.gz
freebsd-ports-gnome-16a83e0b2fd2115dff77709c77eb1a0a93eb8577.tar.zst
freebsd-ports-gnome-16a83e0b2fd2115dff77709c77eb1a0a93eb8577.zip
- create default config when build by port
package not changed, it does create default config
-rw-r--r--net-mgmt/hobbit-client/Makefile7
-rw-r--r--net-mgmt/xymon-client/Makefile7
2 files changed, 14 insertions, 0 deletions
diff --git a/net-mgmt/hobbit-client/Makefile b/net-mgmt/hobbit-client/Makefile
index 8432be3d2205..104b772864d2 100644
--- a/net-mgmt/hobbit-client/Makefile
+++ b/net-mgmt/hobbit-client/Makefile
@@ -25,6 +25,7 @@ MAKE_ENV+= BBUSER="${BBUSER}"
MAKE_ENV+= BBHOSTIP="${BBHOSTIP}"
USE_RC_SUBR= hobbit-client.sh
PLIST_SUB+= BBUSER="${BBUSER}"
+CONFIG_FILES= clientlaunch.cfg hobbitclient.cfg localclient.cfg
# Configure script is interactive
do-configure:
@@ -35,4 +36,10 @@ pre-install:
if ! pw usershow ${BBUSER}; then pw useradd ${BBUSER} -g ${BBUSER} -u 280 \
-h - -d ${NONEXISTENT} -s /usr/sbin/nologin -c "Hobbit Monitor"; fi
+post-install:
+.for i in ${CONFIG_FILES}
+ ${CP} -np ${WWWDIR}/client/etc/${i}-dist \
+ ${WWWDIR}/client/etc/${i}
+.endfor
+
.include <bsd.port.mk>
diff --git a/net-mgmt/xymon-client/Makefile b/net-mgmt/xymon-client/Makefile
index 8432be3d2205..104b772864d2 100644
--- a/net-mgmt/xymon-client/Makefile
+++ b/net-mgmt/xymon-client/Makefile
@@ -25,6 +25,7 @@ MAKE_ENV+= BBUSER="${BBUSER}"
MAKE_ENV+= BBHOSTIP="${BBHOSTIP}"
USE_RC_SUBR= hobbit-client.sh
PLIST_SUB+= BBUSER="${BBUSER}"
+CONFIG_FILES= clientlaunch.cfg hobbitclient.cfg localclient.cfg
# Configure script is interactive
do-configure:
@@ -35,4 +36,10 @@ pre-install:
if ! pw usershow ${BBUSER}; then pw useradd ${BBUSER} -g ${BBUSER} -u 280 \
-h - -d ${NONEXISTENT} -s /usr/sbin/nologin -c "Hobbit Monitor"; fi
+post-install:
+.for i in ${CONFIG_FILES}
+ ${CP} -np ${WWWDIR}/client/etc/${i}-dist \
+ ${WWWDIR}/client/etc/${i}
+.endfor
+
.include <bsd.port.mk>