aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2005-04-20 16:17:07 +0800
committerclsung <clsung@FreeBSD.org>2005-04-20 16:17:07 +0800
commit16b031d1c4fb53eeef29e78408b60cd3a2688454 (patch)
treea7c3bf1504b8bd2c7bc8503b6bab709068f6b012
parent782be1df078b5e8f8e99935c8cb375f13f4410b2 (diff)
downloadfreebsd-ports-gnome-16b031d1c4fb53eeef29e78408b60cd3a2688454.tar.gz
freebsd-ports-gnome-16b031d1c4fb53eeef29e78408b60cd3a2688454.tar.zst
freebsd-ports-gnome-16b031d1c4fb53eeef29e78408b60cd3a2688454.zip
- respect PTHREAD_LIBS
Noted by: kris
-rw-r--r--security/clamsmtp/Makefile3
-rw-r--r--security/clamsmtp/files/patch-configure2
2 files changed, 4 insertions, 1 deletions
diff --git a/security/clamsmtp/Makefile b/security/clamsmtp/Makefile
index 108acb896acb..7784080a5603 100644
--- a/security/clamsmtp/Makefile
+++ b/security/clamsmtp/Makefile
@@ -44,4 +44,7 @@ post-install:
.endif
@${SED} -e "s,%%PREFIX%%,${PREFIX},g" ${PKGMESSAGE}
+post-patch:
+ @${REINPLACE_CMD} -e "s,%%PTHREAD_LIBS%%,${PTHREAD_LIBS}," ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/security/clamsmtp/files/patch-configure b/security/clamsmtp/files/patch-configure
index 4d22f6a8e7fd..5d025d1c5658 100644
--- a/security/clamsmtp/files/patch-configure
+++ b/security/clamsmtp/files/patch-configure
@@ -5,7 +5,7 @@
# which is a program returning the flags for the Pth emulation library.
-acx_pthread_flags="pthreads none -Kthread -kthread lthread -pthread -pthreads -mthreads pthread --thread-safe -mt pthread-config"
-+acx_pthread_flags="pthreads none -Kthread -kthread -pthread -pthreads lthread -mthreads pthread --thread-safe -mt pthread-config"
++acx_pthread_flags="pthreads none -Kthread -kthread %%PTHREAD_LIBS%% -pthreads lthread -mthreads pthread --thread-safe -mt pthread-config"
# The ordering *is* (sometimes) important. Some notes on the
# individual items follow: