aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsperber <sperber@FreeBSD.org>2012-12-01 07:52:21 +0800
committersperber <sperber@FreeBSD.org>2012-12-01 07:52:21 +0800
commit16df4eb388a6528bf31fc71eabd903547c33f176 (patch)
tree14c3cb1d01dc53417238f884d56979a5e3eb485a
parentb28e67ffb8e7f18b624e2cba7281c33afab7f4e9 (diff)
downloadfreebsd-ports-gnome-16df4eb388a6528bf31fc71eabd903547c33f176.tar.gz
freebsd-ports-gnome-16df4eb388a6528bf31fc71eabd903547c33f176.tar.zst
freebsd-ports-gnome-16df4eb388a6528bf31fc71eabd903547c33f176.zip
- Update to version 6.1.6
- Trim Makefile header PR: ports/171978 Submitted by: KATO Tsuguru <tkato432 _at_ yahoo.com> Approved by: beat (mentor) Feature safe: yes
-rw-r--r--devel/ace/Makefile19
-rw-r--r--devel/ace/distinfo4
-rw-r--r--devel/ace/pkg-plist17
3 files changed, 25 insertions, 15 deletions
diff --git a/devel/ace/Makefile b/devel/ace/Makefile
index 1f4f4a662569..e008a526ee1c 100644
--- a/devel/ace/Makefile
+++ b/devel/ace/Makefile
@@ -1,25 +1,20 @@
-# Ports collection makefile for: ace
-# Date created: 5 January 2004
-# Whom: Sergey Matveychuk <sem@ciam.ru>
-#
+# Created by: Sergey Matveychuk <sem@ciam.ru>
# $FreeBSD$
-#
PORTNAME= ace
-PORTVERSION= 6.1.2
+PORTVERSION= 6.1.6
CATEGORIES= devel
MASTER_SITES= ftp://download.dre.vanderbilt.edu/previous_versions/ \
http://download.dre.vanderbilt.edu/previous_versions/
-DISTNAME= ACE-${PORTVERSION}
+DISTNAME= ${PORTNAME:U}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= The Adaptive Communication Environment for C++
OPTIONS_DEFINE= SSL TRIO X11 FLTK TK QT4
OPTIONS_DEFAULT=SSL
-TRIO_DESC= Enable trio support
-FLTK_DESC= Enable FLTK support
-TK_DESC= Enable Tcl/Tk support
+TRIO_DESC= Trio portable string functions
+FLTK_DESC= FLTK GUI toolkit
CONFLICTS= ace+tao-5*
@@ -27,12 +22,12 @@ WRKSRC= ${WRKDIR}/ACE_wrappers
USE_BZIP2= yes
USE_PERL5_BUILD=yes
+USE_PKGCONFIG= build
USE_GMAKE= yes
MAKE_ENV= LD_LIBRARY_PATH="${WRKSRC}/lib" ACE_ROOT="${WRKSRC}" \
CROSS-COMPILE=1
MAKEFILE= GNUmakefile
USE_LDCONFIG= yes
-USE_PKGCONFIG= yes
MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -101,7 +96,7 @@ post-patch:
's|/$$libdir/pkgconfig|/libdata/pkgconfig|g' ${WRKSRC}/bin/ace_install_pkgconfig.pl
@${REINPLACE_CMD} -e \
's|bin/moc)|bin/moc-qt4)|g ; \
- s|bin/moc,|bin/moc-qt4,|'g ${WRKSRC}/ace/QtReactor/GNUmakefile.ACE_Qt4Reactor_moc
+ s|bin/moc,|bin/moc-qt4,|g' ${WRKSRC}/ace/QtReactor/GNUmakefile.ACE_Qt4Reactor_moc
do-configure:
@cd ${WRKSRC}/ace \
diff --git a/devel/ace/distinfo b/devel/ace/distinfo
index 1db3d12baf41..a7c50f1486b5 100644
--- a/devel/ace/distinfo
+++ b/devel/ace/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ACE-6.1.2.tar.bz2) = 6e2af99acdbb1b769bed1e5a6d2e21a0165597097739aed77a4382de0f9257e8
-SIZE (ACE-6.1.2.tar.bz2) = 7911861
+SHA256 (ACE-6.1.6.tar.bz2) = 47019709a8992ddb0bb65bc3e29998a3eec3fd64ac63b1383c2b23f5200a5e00
+SIZE (ACE-6.1.6.tar.bz2) = 8021953
diff --git a/devel/ace/pkg-plist b/devel/ace/pkg-plist
index 3298509fac14..fcbc05b80ad4 100644
--- a/devel/ace/pkg-plist
+++ b/devel/ace/pkg-plist
@@ -73,7 +73,6 @@ include/Kokyu/DSRT_Sched_Queue_T.cpp
include/Kokyu/DSRT_Sched_Queue_T.h
include/Kokyu/Default_Dispatcher_Impl.h
include/Kokyu/Default_Dispatcher_Impl.inl
-include/Kokyu/Dispatch_Deferrer.h
include/Kokyu/Dispatcher_Impl.h
include/Kokyu/Dispatcher_Impl.inl
include/Kokyu/Dispatcher_Task.h
@@ -146,6 +145,7 @@ include/ace/Atomic_Op_Sparc.h
include/ace/Atomic_Op_T.cpp
include/ace/Atomic_Op_T.h
include/ace/Atomic_Op_T.inl
+include/ace/Auto_Event.cpp
include/ace/Auto_Event.h
include/ace/Auto_Event.inl
include/ace/Auto_Functor.cpp
@@ -204,6 +204,8 @@ include/ace/Compression/Compressor.h
include/ace/Compression/Compressor.inl
include/ace/Compression/rle/ACE_RLECompression_export.h
include/ace/Compression/rle/RLECompressor.h
+include/ace/Condition_Attributes.h
+include/ace/Condition_Attributes.inl
include/ace/Condition_Recursive_Thread_Mutex.h
include/ace/Condition_T.cpp
include/ace/Condition_T.h
@@ -269,8 +271,11 @@ include/ace/Encoding_Converter_Factory.h
include/ace/Env_Value_T.cpp
include/ace/Env_Value_T.h
include/ace/Env_Value_T.inl
+include/ace/Event.cpp
include/ace/Event.h
include/ace/Event.inl
+include/ace/Event_Base.h
+include/ace/Event_Base.inl
include/ace/Event_Handler.h
include/ace/Event_Handler.inl
include/ace/Event_Handler_Handle_Timeout_Upcall.h
@@ -533,6 +538,7 @@ include/ace/Malloc_T.inl
include/ace/Managed_Object.cpp
include/ace/Managed_Object.h
include/ace/Managed_Object.inl
+include/ace/Manual_Event.cpp
include/ace/Manual_Event.h
include/ace/Manual_Event.inl
include/ace/Map_Manager.cpp
@@ -596,6 +602,8 @@ include/ace/Monitor_Control_Action.h
include/ace/Monitor_Control_Types.h
include/ace/Monitor_Point_Registry.h
include/ace/Monitor_Size.h
+include/ace/Monotonic_Time_Policy.h
+include/ace/Monotonic_Time_Policy.inl
include/ace/Msg_WFMO_Reactor.h
include/ace/Msg_WFMO_Reactor.inl
include/ace/Multihomed_INET_Addr.h
@@ -980,6 +988,9 @@ include/ace/Time_Policy_T.h
include/ace/Time_Policy_T.inl
include/ace/Time_Value.h
include/ace/Time_Value.inl
+include/ace/Time_Value_T.cpp
+include/ace/Time_Value_T.h
+include/ace/Time_Value_T.inl
include/ace/Timeprobe.h
include/ace/Timeprobe.inl
include/ace/Timeprobe_T.cpp
@@ -1089,6 +1100,7 @@ include/ace/config-macosx-iOS-hardware.h
include/ace/config-macosx-iOS-simulator.h
include/ace/config-macosx-leopard.h
include/ace/config-macosx-lion.h
+include/ace/config-macosx-mountain-lion.h
include/ace/config-macosx-panther.h
include/ace/config-macosx-snowleopard.h
include/ace/config-macosx-tiger.h
@@ -1353,6 +1365,7 @@ libdata/pkgconfig/Kokyu.pc
%%DATADIR%%/bin/MakeProjectCreator/config/ace_tkreactor.mpb
%%DATADIR%%/bin/MakeProjectCreator/config/ace_unicode.mpb
%%DATADIR%%/bin/MakeProjectCreator/config/ace_x11.mpb
+%%DATADIR%%/bin/MakeProjectCreator/config/ace_xml_utils.mpb
%%DATADIR%%/bin/MakeProjectCreator/config/ace_xt.mpb
%%DATADIR%%/bin/MakeProjectCreator/config/ace_xtreactor.mpb
%%DATADIR%%/bin/MakeProjectCreator/config/ace_zlib.mpb
@@ -1439,6 +1452,7 @@ libdata/pkgconfig/Kokyu.pc
%%DATADIR%%/docs/ACE-development-process.html
%%DATADIR%%/docs/ACE-guidelines.html
%%DATADIR%%/docs/ACE-lessons.html
+%%DATADIR%%/docs/ACE-monotonic-timer.html
%%DATADIR%%/docs/ACE-porting.html
%%DATADIR%%/docs/ACE-subsets.html
%%DATADIR%%/docs/CE-status.txt
@@ -1486,6 +1500,7 @@ libdata/pkgconfig/Kokyu.pc
%%DATADIR%%/include/makeinclude/platform_macosx_icc.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_leopard.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_lion.GNU
+%%DATADIR%%/include/makeinclude/platform_macosx_mountain_lion.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_panther.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_snowleopard.GNU
%%DATADIR%%/include/makeinclude/platform_macosx_tiger.GNU