aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-07-06 03:20:21 +0800
committerTobias C. Berner <tcberner@FreeBSD.org>2020-07-06 03:20:21 +0800
commit17728457b2531976a449cb16094227ee8bcd599a (patch)
tree2d9945e5f280b94ff36a642e15be3c3ecd726be6
parente277e1c63ac54ec425d885c90b6a528bd6a8125a (diff)
downloadfreebsd-ports-gnome-17728457b2531976a449cb16094227ee8bcd599a.tar.gz
freebsd-ports-gnome-17728457b2531976a449cb16094227ee8bcd599a.tar.zst
freebsd-ports-gnome-17728457b2531976a449cb16094227ee8bcd599a.zip
Switch to using CMAKE_ON/CMAKE_OFF instead of more clunky CMAKE_ARGS
-rw-r--r--databases/kexi/Makefile6
-rw-r--r--devel/injeqt/Makefile4
-rw-r--r--textproc/libkolabxml/Makefile14
-rw-r--r--x11/sddm/Makefile2
4 files changed, 13 insertions, 13 deletions
diff --git a/databases/kexi/Makefile b/databases/kexi/Makefile
index 2aa92cdc3638..2fc346d08d12 100644
--- a/databases/kexi/Makefile
+++ b/databases/kexi/Makefile
@@ -27,8 +27,8 @@ USE_QT= concurrent core dbus declarative gui network printsupport webkit widge
CONFLICTS_INSTALL= calligra-2*
-CMAKE_ARGS= -DBUILD_TESTING:BOOL=OFF \
- -DKEXI_QTGUI_RUNTIME_AVAILABLE:BOOL=TRUE \
- -DKEXI_ENABLE_QTGUI_FOR_TESTS:BOOL=FALSE
+CMAKE_OFF= BUILD_TESTING \
+ KEXI_ENABLE_QTGUI_FOR_TESTS
+CMAKE_ON= KEXI_QTGUI_RUNTIME_AVAILABLE
.include <bsd.port.mk>
diff --git a/devel/injeqt/Makefile b/devel/injeqt/Makefile
index eef43a750bd0..29644a4fd63a 100644
--- a/devel/injeqt/Makefile
+++ b/devel/injeqt/Makefile
@@ -19,8 +19,8 @@ USES= cmake compiler:c++11-lib pathfix qt:5
USE_QT= core buildtools_build qmake_build testlib_build
USE_LDCONFIG= yes
-CMAKE_ARGS= -DDISABLE_EXAMPLES:BOOL=ON \
- -DDISABLE_COVERAGE:BOOL=ON
+CMAKE_ON= DISABLE_EXAMPLES \
+ DISABLE_COVERAGE
PLIST_SUB= VERSION=${PORTVERSION:R}
diff --git a/textproc/libkolabxml/Makefile b/textproc/libkolabxml/Makefile
index 77a8b6799b32..f7100559e39e 100644
--- a/textproc/libkolabxml/Makefile
+++ b/textproc/libkolabxml/Makefile
@@ -20,13 +20,13 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libxerces-c.so.3:textproc/xerces-c3
# TODO: Conditionally enable the bindings based on OPTIONs.
-CMAKE_ARGS= -DBUILD_TESTS:BOOL=OFF \
- -DBUILD_UTILS:BOOL=OFF \
- -DCSHARP_BINDINGS:BOOL=OFF \
- -DDIST_ONLY:BOOL=OFF \
- -DJAVA_BINDINGS:BOOL=OFF \
- -DPHP_BINDINGS:BOOL=OFF \
- -DPYTHON_BINDINGS:BOOL=OFF
+CMAKE_OFF= BUILD_TESTS \
+ BUILD_UTILS \
+ CSHARP_BINDINGS \
+ DIST_ONLY \
+ JAVA_BINDINGS \
+ PHP_BINDINGS \
+ PYTHON_BINDINGS
USES= cmake
USE_LDCONFIG= yes
diff --git a/x11/sddm/Makefile b/x11/sddm/Makefile
index fabf7a136886..e6456c37be6f 100644
--- a/x11/sddm/Makefile
+++ b/x11/sddm/Makefile
@@ -28,10 +28,10 @@ USE_QT= core declarative dbus gui network \
buildtools_build linguisttools_build qmake_build
USE_XORG= xcb
+CMAKE_ON= BUILD_MAN_PAGES
CMAKE_ARGS= -DUID_MIN=1000 \
-DUID_MAX=65000 \
-DCMAKE_INSTALL_SYSCONFDIR:PATH=${LOCALBASE}/etc \
- -DBUILD_MAN_PAGES=ON \
-DRST2MAN_EXECUTABLE=${LOCALBASE}/bin/rst2man.py-${PYTHON_VER}
USE_RC_SUBR= sddm