aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2013-12-29 23:06:27 +0800
committerjohans <johans@FreeBSD.org>2013-12-29 23:06:27 +0800
commit1818835c10bc7285b25a7d853ebc16f200a64d74 (patch)
treef32129011d67df58815f9fe495d61b1e674952ed
parent526075ed87ca6dfd2ac985e153bedc443d4b7fac (diff)
downloadfreebsd-ports-gnome-1818835c10bc7285b25a7d853ebc16f200a64d74.tar.gz
freebsd-ports-gnome-1818835c10bc7285b25a7d853ebc16f200a64d74.tar.zst
freebsd-ports-gnome-1818835c10bc7285b25a7d853ebc16f200a64d74.zip
- Enable STAGE support
- Fix build issue with modern freetype - Fix bash path and add run-time dependency - Strip installed binaries - Bump PORTREVISION
-rw-r--r--graphics/xpaint/Makefile11
-rw-r--r--graphics/xpaint/files/patch-util_Makefile24
-rw-r--r--graphics/xpaint/pkg-plist3
3 files changed, 20 insertions, 18 deletions
diff --git a/graphics/xpaint/Makefile b/graphics/xpaint/Makefile
index 32f22b62dc5a..0740896b515f 100644
--- a/graphics/xpaint/Makefile
+++ b/graphics/xpaint/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xpaint
PORTVERSION= 2.9.9.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= SF/sf-${PORTNAME}/sf-${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
@@ -19,27 +19,26 @@ LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libjbig.so:${PORTSDIR}/graphics/jbigkit \
libXaw3dxft.so:${PORTSDIR}/x11-toolkits/libxaw3dxft
-RUN_DEPENDS= psselect:${PORTSDIR}/print/psutils
+RUN_DEPENDS= psselect:${PORTSDIR}/print/psutils \
+ bash:${PORTSDIR}/shells/bash
USE_BZIP2= yes
USE_XORG= xft xmu xpm
USE_AUTOTOOLS= libtool
USE_GHOSTSCRIPT_RUN=yes
GNU_CONFIGURE= yes
+USES= shebangfix
+SHEBANG_FILES= share/bin/imgmerge share/bin/xpaint_ocr
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV+= RM="${RM} -f"
-MAN1= xpaint.1 pdfconcat.1 imgmerge.1
-
-NO_STAGE= yes
post-extract:
@${RM} -f ${WRKSRC}/XPaint.ad
post-patch:
@${REINPLACE_CMD} -e 's/-ldl //' \
- -e 's|freetype/||g' \
${WRKSRC}/configure ${WRKSRC}/rw/configure
@${REINPLACE_CMD} -e '/^LIBTOOL/d' \
-e '/^install-exec-am:/s/install-libLTLIBRARIES//' \
diff --git a/graphics/xpaint/files/patch-util_Makefile b/graphics/xpaint/files/patch-util_Makefile
index b9c07d54c3a9..58dbb8d2074c 100644
--- a/graphics/xpaint/files/patch-util_Makefile
+++ b/graphics/xpaint/files/patch-util_Makefile
@@ -32,26 +32,26 @@
- mkdir -p $(DESTDIR)/usr/share/man/man1 ; \
- install -c -m 644 pdfconcat.1 $(DESTDIR)/usr/share/man/man1 ; \
- echo "install -c pdfconcat.1 $(DESTDIR)/usr/share/man/man1" ; fi
-+ mkdir -p $(PREFIX)/bin ; \
-+ install -c pdfconcat $(PREFIX)/bin ; \
-+ echo "install -c pdfconcat $(PREFIX)/bin" ; \
-+ mkdir -p $(PREFIX)/man/man1 ; \
-+ install -c -m 644 pdfconcat.1 $(PREFIX)/man/man1 ; \
-+ echo "install -c pdfconcat.1 $(PREFIX)/man/man1" ; fi
++ mkdir -p $(DESTDIR)$(PREFIX)/bin ; \
++ install -c pdfconcat $(DESTDIR)$(PREFIX)/bin ; \
++ echo "install -c pdfconcat $(DESTDIR)$(PREFIX)/bin" ; \
++ mkdir -p $(DESTDIR)$(PREFIX)/man/man1 ; \
++ install -c -m 644 pdfconcat.1 $(DESTDIR)$(PREFIX)/man/man1 ; \
++ echo "install -c pdfconcat.1 $(DESTDIR)$(PREFIX)/man/man1" ; fi
@if [ -x ppmtops ] ; then \
- mkdir -p $(DESTDIR)/usr/bin ; \
- install -c ppmtops $(DESTDIR)/usr/bin ; \
- echo "install -c ppmtops $(DESTDIR)/usr/bin" ; fi
-+ mkdir -p $(PREFIX)/bin ; \
-+ install -c ppmtops $(PREFIX)/bin ; \
-+ echo "install -c ppmtops $(PREFIX)/bin" ; fi
++ mkdir -p $(DESTDIR)$(PREFIX)/bin ; \
++ install -c -s ppmtops $(DESTDIR)$(PREFIX)/bin ; \
++ echo "install -c ppmtops $(DESTDIR)$(PREFIX)/bin" ; fi
@if [ -x pgf2pnm ] ; then \
- mkdir -p $(DESTDIR)/usr/bin ; \
- install -c pgf2pnm $(DESTDIR)/usr/bin ; \
- echo "install -c pgf2pnm $(DESTDIR)/usr/bin" ; fi
-+ mkdir -p $(PREFIX)/bin ; \
-+ install -c pgf2pnm $(PREFIX)/bin ; \
-+ echo "install -c pgf2pnm $(PREFIX)/bin" ; fi
++ mkdir -p $(DESTDIR)$(PREFIX)/bin ; \
++ install -c pgf2pnm $(DESTDIR)$(PREFIX)/bin ; \
++ echo "install -c pgf2pnm $(DESTDIR)$(PREFIX)/bin" ; fi
clean:
rm -f core *~ *.o pdfconcat ppmtops pgf2pnm
diff --git a/graphics/xpaint/pkg-plist b/graphics/xpaint/pkg-plist
index 5c6166b8adfe..51b49b3f2a9d 100644
--- a/graphics/xpaint/pkg-plist
+++ b/graphics/xpaint/pkg-plist
@@ -5,6 +5,9 @@ bin/xpaint
lib/X11/app-defaults/XPaint
lib/X11/app-defaults/XPaint_es
lib/X11/app-defaults/XPaint_fr
+man/man1/imgmerge.1.gz
+man/man1/pdfconcat.1.gz
+man/man1/xpaint.1.gz
%%DATADIR%%/XPaintIcon.xpm
%%DATADIR%%/bin/xpaint_ocr
%%DATADIR%%/bitmaps/brushbox.cfg