aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2006-01-12 02:20:59 +0800
committerbrooks <brooks@FreeBSD.org>2006-01-12 02:20:59 +0800
commit18555eeb9c991681351fad3585affc9f904d1011 (patch)
tree3f7818ba1a504fbba08984be2a28a6b64859d31b
parent7219cff58c394813c39d92ed623c419a5ae64ec5 (diff)
downloadfreebsd-ports-gnome-18555eeb9c991681351fad3585affc9f904d1011.tar.gz
freebsd-ports-gnome-18555eeb9c991681351fad3585affc9f904d1011.tar.zst
freebsd-ports-gnome-18555eeb9c991681351fad3585affc9f904d1011.zip
Add MASTER_SITE_LOCAL to the list of MASTER_SITES. Get rid of debugging
in the rc.d script. Make the script actually avoid rewiping the disk once it's been labled.
-rw-r--r--sysutils/diskprep/Makefile6
-rw-r--r--sysutils/diskprep/files/diskprep.in4
2 files changed, 5 insertions, 5 deletions
diff --git a/sysutils/diskprep/Makefile b/sysutils/diskprep/Makefile
index 25118aa3f801..38b0867facee 100644
--- a/sysutils/diskprep/Makefile
+++ b/sysutils/diskprep/Makefile
@@ -7,9 +7,11 @@
PORTNAME= diskprep
PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
-MASTER_SITES= http://people.freebsd.org/~brooks/diskprep/
+MASTER_SITES= http://people.freebsd.org/~brooks/diskprep/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
MAINTAINER= brooks@FreeBSD.org
COMMENT= A program to prepare disks for use based on a config file
diff --git a/sysutils/diskprep/files/diskprep.in b/sysutils/diskprep/files/diskprep.in
index 8c16c8ef0db4..d4419c0df00c 100644
--- a/sysutils/diskprep/files/diskprep.in
+++ b/sysutils/diskprep/files/diskprep.in
@@ -6,8 +6,6 @@
# BEFORE: fsck localswap
# KEYWORD: nojail
-rc_debug=YES
-
. /etc/rc.subr
name="diskprep"
@@ -20,7 +18,7 @@ diskprep_prestart()
{
if [ -n "${diskprep_label}" ]; then
# If our label exists, we're done.
- if [ -c /dev/label/${curlabel} ]; then
+ if [ -c /dev/label/${diskprep_label} ]; then
return 0
fi
command_args="$command_args -l $diskprep_label"