aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2015-03-18 23:14:38 +0800
committerume <ume@FreeBSD.org>2015-03-18 23:14:38 +0800
commit1884a311e1623af49ba3876da2dbb1ac823de0e7 (patch)
treecaa09b2fe63107f9183672af99407da1622246cb
parente94ef69a6452bdb77f3a300f6f0bb20d32479604 (diff)
downloadfreebsd-ports-gnome-1884a311e1623af49ba3876da2dbb1ac823de0e7.tar.gz
freebsd-ports-gnome-1884a311e1623af49ba3876da2dbb1ac823de0e7.tar.zst
freebsd-ports-gnome-1884a311e1623af49ba3876da2dbb1ac823de0e7.zip
Make it buildable with both HTTP and SQLITE enabled.
Spotted by: Paul Dekkers <paul.dekkers__at__surfnet.nl>
-rw-r--r--mail/cyrus-imapd25/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/mail/cyrus-imapd25/Makefile b/mail/cyrus-imapd25/Makefile
index a41aeea0caed..42b64422076c 100644
--- a/mail/cyrus-imapd25/Makefile
+++ b/mail/cyrus-imapd25/Makefile
@@ -62,7 +62,7 @@ HTTP_DESC= Enable HTTP (beta quality)
HTTP_CONFIGURE_ENABLE= http
HTTP_LIB_DEPENDS= libjansson.so:${PORTSDIR}/devel/jansson \
libical.so:${PORTSDIR}/devel/libical
-HTTP_USE= GNOME=libxml2,glib20 SQLITE=yes
+HTTP_USE= GNOME=libxml2,glib20
IDLED_DESC= Enable IMAP idled support
IDLED_CONFIGURE_ENABLE= idled
LDAP_DESC= Enable LDAP support (experimental)
@@ -87,7 +87,6 @@ REPLICATION_CONFIGURE_ENABLE=replication
SNMP_LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
SNMP_CONFIGURE_ON= --with-snmp=${LOCALBASE}
SNMP_CONFIGURE_OFF= --with-snmp=no
-SQLITE_USE= SQLITE=yes
SQLITE_CONFIGURE_ON= --with-sqlite=${LOCALBASE}
.include <bsd.port.pre.mk>
@@ -111,6 +110,10 @@ IGNORE= DRAC is not available
# USE_AUTOTOOLS= autoconf autoheader
.endif
+.if ${PORT_OPTIONS:MHTTP} || ${PORT_OPTIONS:MSQLITE}
+USE_SQLITE=yes
+.endif
+
.if ${OSVERSION} >= 900022
PLIST_SUB+= MANCONF=""
.else