aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-04-16 21:45:10 +0800
committerswills <swills@FreeBSD.org>2014-04-16 21:45:10 +0800
commit18f5bc8736a20590604072759c8edc102d6cdc18 (patch)
treee590e97e8fe749c2c26f1012d8fdea4f1f989af9
parent27b732e50dd1ed1765d1e31a6f7786c70cb9bd70 (diff)
downloadfreebsd-ports-gnome-18f5bc8736a20590604072759c8edc102d6cdc18.tar.gz
freebsd-ports-gnome-18f5bc8736a20590604072759c8edc102d6cdc18.tar.zst
freebsd-ports-gnome-18f5bc8736a20590604072759c8edc102d6cdc18.zip
- Fix warning in pkg provider
PR: ports/184005 [1] PR: ports/188675 [2] Submitted by: Tristan Smith <tsmith@palantir.com> [1] Submitted by: Mathieu Arnold <mat@freebsd.org> [2]
-rw-r--r--sysutils/puppet/Makefile1
-rw-r--r--sysutils/puppet/files/optpatch-package_origin4
2 files changed, 3 insertions, 2 deletions
diff --git a/sysutils/puppet/Makefile b/sysutils/puppet/Makefile
index 6c1baecda5b5..b789157890fb 100644
--- a/sysutils/puppet/Makefile
+++ b/sysutils/puppet/Makefile
@@ -3,6 +3,7 @@
PORTNAME= puppet
PORTVERSION= 3.4.3
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://downloads.puppetlabs.com/puppet/
diff --git a/sysutils/puppet/files/optpatch-package_origin b/sysutils/puppet/files/optpatch-package_origin
index 0f6cb3aa6e31..c087c85d7960 100644
--- a/sysutils/puppet/files/optpatch-package_origin
+++ b/sysutils/puppet/files/optpatch-package_origin
@@ -30,8 +30,8 @@
- def self.listcmd
- command(:pkginfo)
-+ @@lock = Mutex.new
-+ @@ports_index = nil
++ class_variable_set(:@@lock, Mutex.new)
++ class_variable_set(:@@ports_index, nil)
+
+ # fix bug in URI::FTP merge method that tries to set typecode
+ # even when other is a string.