aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2018-10-14 01:57:27 +0800
committervd <vd@FreeBSD.org>2018-10-14 01:57:27 +0800
commit190988491060f9fcc5a348de359e1bc074962ae5 (patch)
treebd3cd429d205ab151109a0590c626a3dc97fe8bc
parentafbe27791d783dc7e7e3513f414ad8e8aa0fb146 (diff)
downloadfreebsd-ports-gnome-190988491060f9fcc5a348de359e1bc074962ae5.tar.gz
freebsd-ports-gnome-190988491060f9fcc5a348de359e1bc074962ae5.tar.zst
freebsd-ports-gnome-190988491060f9fcc5a348de359e1bc074962ae5.zip
net-p2p/monero-cli: fix compilation on FreeBSD < 12
-DMANUAL_SUBMODULES:BOOL=ON was mistakenly provided only on 12.x, should be used always. While I am here, pet portlint.
-rw-r--r--net-p2p/monero-cli/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-p2p/monero-cli/Makefile b/net-p2p/monero-cli/Makefile
index 2851512f0961..478c318a0c84 100644
--- a/net-p2p/monero-cli/Makefile
+++ b/net-p2p/monero-cli/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= monero-cli
-# To build from an arbitrary git commit comment the following two lines
+# To build from an arbitrary git commit comment PORTVERSION and PORTREVISION (if present)
PORTVERSION= 0.13.0.2
-PORTREVISION= 0
DISTVERSIONPREFIX= v
# and uncomment the following two lines
#PORTVERSION= 0
@@ -42,6 +41,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/rapidjson/document.h:devel/rapidjson \
USES= cmake compiler:c++11-lib pkgconfig readline ssl
USE_GITHUB= yes
+
GH_ACCOUNT= monero-project
GH_PROJECT= monero
.if defined(PKGNAMESUFFIX)
@@ -62,7 +62,6 @@ DOXYGEN_CMAKE_BOOL= BUILD_DOCUMENTATION
# See Bug 226996 - net-p2p/monero-cli: fails to link with lld as the system linker
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=226996
.if ${OSVERSION} >= 1200000
-ONLY_FOR_ARCHS= aarch64 amd64 i386 powerpc powerpc64
.if ${ARCH} == aarch64
LD_EMULATION= aarch64elf
@@ -76,10 +75,12 @@ LD_EMULATION= elf32ppc
LD_EMULATION= elf64ppc
.endif
-CMAKE_ARGS+= -DLD_RAW_FLAGS:STRING=-m${LD_EMULATION} \
- -DMANUAL_SUBMODULES:BOOL=ON
+CMAKE_ARGS+= -DLD_RAW_FLAGS:STRING=-m${LD_EMULATION}
+
.endif
+CMAKE_ARGS+= -DMANUAL_SUBMODULES:BOOL=ON
+
USE_RC_SUBR= monerod
USERS= monero