aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2010-03-12 06:46:20 +0800
committerdanfe <danfe@FreeBSD.org>2010-03-12 06:46:20 +0800
commit1932ff8c7e44fb2c09250b6db8328f9cb9ba4406 (patch)
treeaaebae9afd5548e67eaae898ee499f1487c522d3
parentcf6953fa3cdcd3d9169c5b2b177ccd872aa231b6 (diff)
downloadfreebsd-ports-gnome-1932ff8c7e44fb2c09250b6db8328f9cb9ba4406.tar.gz
freebsd-ports-gnome-1932ff8c7e44fb2c09250b6db8328f9cb9ba4406.tar.zst
freebsd-ports-gnome-1932ff8c7e44fb2c09250b6db8328f9cb9ba4406.zip
Darktable is a virtual lighttable and darkroom for photographers: it manages
your digital negatives in a database and lets you view them through a zoomable lighttable. It also enables you to develop raw images and enhance them. WWW: http://darktable.sourceforge.net/
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/darktable/Makefile41
-rw-r--r--graphics/darktable/distinfo3
-rw-r--r--graphics/darktable/pkg-descr20
-rw-r--r--graphics/darktable/pkg-plist85
5 files changed, 150 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 94f04a40ccb0..8d414bc1e87c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -89,6 +89,7 @@
SUBDIR += cuttlefish
SUBDIR += danpei
SUBDIR += darknock
+ SUBDIR += darktable
SUBDIR += dataplot
SUBDIR += dc20ctrl
SUBDIR += dc20pack
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
new file mode 100644
index 000000000000..0dde86975599
--- /dev/null
+++ b/graphics/darktable/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: darktable
+# Date created: 11 March 2010
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= darktable
+PORTVERSION= 0.4
+CATEGORIES= graphics
+MASTER_SITES= SF
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= A virtual lighttable and darkroom for photographers
+
+LIB_DEPENDS= gegl-0.0.22:${PORTSDIR}/graphics/gegl \
+ exiv2.7:${PORTSDIR}/graphics/exiv2 \
+ lensfun.0:${PORTSDIR}/graphics/lensfun \
+ lcms.1:${PORTSDIR}/graphics/lcms
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gconf2 libglade2
+GCONF_SCHEMAS= ${PORTNAME}.schemas
+USE_SQLITE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+# Bandaid for log2f(3), which FreeBSD lacks
+ @${REINPLACE_CMD} -E 's,log2f\(([^)]*),logf(\1)/logf(2.0f,' \
+ ${WRKSRC}/src/iop/exposure.c \
+ ${WRKSRC}/src/iop/equalizer.c
+# Better respect for CFLAGS
+ @${REINPLACE_CMD} -e 's,-Werror -g,@CFLAGS@,' \
+ ${WRKSRC}/src/iop/Makefile.in \
+ ${WRKSRC}/src/views/Makefile.in \
+ ${WRKSRC}/src/libs/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/graphics/darktable/distinfo b/graphics/darktable/distinfo
new file mode 100644
index 000000000000..8d2b1654dff6
--- /dev/null
+++ b/graphics/darktable/distinfo
@@ -0,0 +1,3 @@
+MD5 (darktable-0.4.tar.bz2) = 23ef3c77925fc579457c2e6bc3e557c9
+SHA256 (darktable-0.4.tar.bz2) = ab167d42870fb1254d94b584d702910f40b4c64dd38ab5558be2af4fc67153e6
+SIZE (darktable-0.4.tar.bz2) = 698809
diff --git a/graphics/darktable/pkg-descr b/graphics/darktable/pkg-descr
new file mode 100644
index 000000000000..4bd7df818032
--- /dev/null
+++ b/graphics/darktable/pkg-descr
@@ -0,0 +1,20 @@
+Darktable is a virtual lighttable and darkroom for photographers: it manages
+your digital negatives in a database and lets you view them through a
+zoomable lighttable. It also enables you to develop raw images and enhance
+them.
+
+This project tries to fill the gap between the many excellent existing free
+raw converters and image management tools (such as UFRaw or F-Spot). The
+user interface is built around efficient caching of image metadata and
+mipmaps, all stored in a database. The user will always be able to interact,
+even if the full resolution image is not yet loaded.
+
+All editing is fully non-destructive and only operates on cached image
+buffers for display. The full image is only converted during export. The
+frontend is written in Gtk+/Cairo, the database uses SQLite3, raw image
+loading is done using libraw, HDR, EXR, and low dynamic range are supported
+through ImageMagick (MagickCore). The core operates completely on floating
+point values, so darktable can not only be used for photography but also for
+scientifically acquired images or output of renderers (high dynamic range).
+
+WWW: http://darktable.sourceforge.net/
diff --git a/graphics/darktable/pkg-plist b/graphics/darktable/pkg-plist
new file mode 100644
index 000000000000..6e099a85dde0
--- /dev/null
+++ b/graphics/darktable/pkg-plist
@@ -0,0 +1,85 @@
+bin/darktable
+share/applications/darktable.desktop
+share/locale/ru/LC_MESSAGES/darktable.mo
+share/locale/sv/LC_MESSAGES/darktable.mo
+share/pixmaps/darktable.png
+%%DATADIR%%/darktable.glade
+%%DATADIR%%/darktable.gtkrc
+%%DATADIR%%/pixmaps/darktable-16.png
+%%DATADIR%%/pixmaps/darktable-32.png
+%%DATADIR%%/pixmaps/darktable-48.png
+%%DATADIR%%/pixmaps/darktable.png
+%%DATADIR%%/pixmaps/off.png
+%%DATADIR%%/pixmaps/plugins/darkroom/clipping.png
+%%DATADIR%%/pixmaps/plugins/darkroom/colorcorrection.png
+%%DATADIR%%/pixmaps/plugins/darkroom/colorin.png
+%%DATADIR%%/pixmaps/plugins/darkroom/colorout.png
+%%DATADIR%%/pixmaps/plugins/darkroom/equalizer.png
+%%DATADIR%%/pixmaps/plugins/darkroom/exposure.png
+%%DATADIR%%/pixmaps/plugins/darkroom/gamma.png
+%%DATADIR%%/pixmaps/plugins/darkroom/lens.png
+%%DATADIR%%/pixmaps/plugins/darkroom/monochrome.png
+%%DATADIR%%/pixmaps/plugins/darkroom/rawimport.png
+%%DATADIR%%/pixmaps/plugins/darkroom/sharpen.png
+%%DATADIR%%/pixmaps/plugins/darkroom/temperature.png
+%%DATADIR%%/pixmaps/plugins/darkroom/template.png
+%%DATADIR%%/pixmaps/plugins/darkroom/tonecurve.png
+%%DATADIR%%/plugins/libclipping.a
+%%DATADIR%%/plugins/libclipping.la
+%%DATADIR%%/plugins/libclipping.so
+%%DATADIR%%/plugins/libcolorcorrection.a
+%%DATADIR%%/plugins/libcolorcorrection.la
+%%DATADIR%%/plugins/libcolorcorrection.so
+%%DATADIR%%/plugins/libcolorin.a
+%%DATADIR%%/plugins/libcolorin.la
+%%DATADIR%%/plugins/libcolorin.so
+%%DATADIR%%/plugins/libcolorout.a
+%%DATADIR%%/plugins/libcolorout.la
+%%DATADIR%%/plugins/libcolorout.so
+%%DATADIR%%/plugins/libequalizer.a
+%%DATADIR%%/plugins/libequalizer.la
+%%DATADIR%%/plugins/libequalizer.so
+%%DATADIR%%/plugins/libexposure.a
+%%DATADIR%%/plugins/libexposure.la
+%%DATADIR%%/plugins/libexposure.so
+%%DATADIR%%/plugins/libgamma.a
+%%DATADIR%%/plugins/libgamma.la
+%%DATADIR%%/plugins/libgamma.so
+%%DATADIR%%/plugins/liblens.a
+%%DATADIR%%/plugins/liblens.la
+%%DATADIR%%/plugins/liblens.so
+%%DATADIR%%/plugins/libmonochrome.a
+%%DATADIR%%/plugins/libmonochrome.la
+%%DATADIR%%/plugins/libmonochrome.so
+%%DATADIR%%/plugins/librawimport.a
+%%DATADIR%%/plugins/librawimport.la
+%%DATADIR%%/plugins/librawimport.so
+%%DATADIR%%/plugins/libsharpen.a
+%%DATADIR%%/plugins/libsharpen.la
+%%DATADIR%%/plugins/libsharpen.so
+%%DATADIR%%/plugins/libtemperature.a
+%%DATADIR%%/plugins/libtemperature.la
+%%DATADIR%%/plugins/libtemperature.so
+%%DATADIR%%/plugins/libtonecurve.a
+%%DATADIR%%/plugins/libtonecurve.la
+%%DATADIR%%/plugins/libtonecurve.so
+%%DATADIR%%/plugins/lighttable/libcopy_history.a
+%%DATADIR%%/plugins/lighttable/libcopy_history.la
+%%DATADIR%%/plugins/lighttable/libcopy_history.so
+%%DATADIR%%/plugins/lighttable/libexport.a
+%%DATADIR%%/plugins/lighttable/libexport.la
+%%DATADIR%%/plugins/lighttable/libexport.so
+%%DATADIR%%/views/libdarkroom.a
+%%DATADIR%%/views/libdarkroom.la
+%%DATADIR%%/views/libdarkroom.so
+%%DATADIR%%/views/liblighttable.a
+%%DATADIR%%/views/liblighttable.la
+%%DATADIR%%/views/liblighttable.so
+@dirrm %%DATADIR%%/views
+@dirrm %%DATADIR%%/plugins/lighttable
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%/pixmaps/plugins/darkroom
+@dirrm %%DATADIR%%/pixmaps/plugins
+@dirrm %%DATADIR%%/pixmaps
+@dirrm %%DATADIR%%
+@dirrmtry share/applications