aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-12-27 21:17:17 +0800
committerantoine <antoine@FreeBSD.org>2017-12-27 21:17:17 +0800
commit1943ba57ebbf6cfb63f14c95b5baab1696c46e3f (patch)
tree6fdb7c5a1bc6ffad97750d4beb808c26e1fc23e7
parent588cd67c24051c368409196befe34d417fdfb3c3 (diff)
downloadfreebsd-ports-gnome-1943ba57ebbf6cfb63f14c95b5baab1696c46e3f.tar.gz
freebsd-ports-gnome-1943ba57ebbf6cfb63f14c95b5baab1696c46e3f.tar.zst
freebsd-ports-gnome-1943ba57ebbf6cfb63f14c95b5baab1696c46e3f.zip
New port: archivers/py-acefile
acefile is an implementation of the ACE archive format. It is intended to be used as a library, but also provides a stand-alone unace utility. As mostly pure-python implementation, it is significantly slower than native implementations, but more robust against vulnerabilities. This implementation supports up to version 2.0 of the ACE archive format, including the EXE, DELTA, PIC and SOUND modes of ACE 2.0, password protected archives and multi-volume archives. It does not support writing to archives. It is an implementation from scratch, based on the 1998 document titled "Technical information of the archiver ACE v1.2" by Marcel Lemke, using unace 2.5 and WinAce 2.69 by Marcel Lemke as reference implementations. WWW: https://www.roe.ch/acefile
-rw-r--r--archivers/Makefile1
-rw-r--r--archivers/py-acefile/Makefile18
-rw-r--r--archivers/py-acefile/distinfo3
-rw-r--r--archivers/py-acefile/pkg-descr13
4 files changed, 35 insertions, 0 deletions
diff --git a/archivers/Makefile b/archivers/Makefile
index ec2f0c32216d..82107340a6d4 100644
--- a/archivers/Makefile
+++ b/archivers/Makefile
@@ -170,6 +170,7 @@
SUBDIR += ppmd-7z
SUBDIR += ppunpack
SUBDIR += pxz
+ SUBDIR += py-acefile
SUBDIR += py-attic
SUBDIR += py-backports.lzma
SUBDIR += py-borgbackup
diff --git a/archivers/py-acefile/Makefile b/archivers/py-acefile/Makefile
new file mode 100644
index 000000000000..7a4cc30a0394
--- /dev/null
+++ b/archivers/py-acefile/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= acefile
+PORTVERSION= 0.6.7
+CATEGORIES= archivers python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Read/test/extract ACE 1.0 and 2.0 archives in pure python
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USES= python:3.4+
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/archivers/py-acefile/distinfo b/archivers/py-acefile/distinfo
new file mode 100644
index 000000000000..dc9d5d0a4e8c
--- /dev/null
+++ b/archivers/py-acefile/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1514244111
+SHA256 (acefile-0.6.7.tar.gz) = 08ab5069a0a1fb50317a962b45b109d5a29dfbfeeea992434809be5cb4f85efa
+SIZE (acefile-0.6.7.tar.gz) = 47628
diff --git a/archivers/py-acefile/pkg-descr b/archivers/py-acefile/pkg-descr
new file mode 100644
index 000000000000..606aa699d77e
--- /dev/null
+++ b/archivers/py-acefile/pkg-descr
@@ -0,0 +1,13 @@
+acefile is an implementation of the ACE archive format. It is intended to be
+used as a library, but also provides a stand-alone unace utility. As mostly
+pure-python implementation, it is significantly slower than native
+implementations, but more robust against vulnerabilities.
+
+This implementation supports up to version 2.0 of the ACE archive format,
+including the EXE, DELTA, PIC and SOUND modes of ACE 2.0, password protected
+archives and multi-volume archives. It does not support writing to archives.
+It is an implementation from scratch, based on the 1998 document titled
+"Technical information of the archiver ACE v1.2" by Marcel Lemke, using unace
+2.5 and WinAce 2.69 by Marcel Lemke as reference implementations.
+
+WWW: https://www.roe.ch/acefile