aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-04-09 23:12:36 +0800
committerpav <pav@FreeBSD.org>2005-04-09 23:12:36 +0800
commit199f4177bd8addfae45de5d70ff3e128a54d5250 (patch)
tree423cbe99006d08f62efaadf5123dfa8bc25da7f7
parent3b2c856898ca07a1ffa6ebac7ab3e92f0bdff260 (diff)
downloadfreebsd-ports-gnome-199f4177bd8addfae45de5d70ff3e128a54d5250.tar.gz
freebsd-ports-gnome-199f4177bd8addfae45de5d70ff3e128a54d5250.tar.zst
freebsd-ports-gnome-199f4177bd8addfae45de5d70ff3e128a54d5250.zip
- Create some empty directories for extensions
PR: ports/79620 (based on) Submitted by: Sam Lawrance <boris@brooknet.com.au> Approved by: Erik Greenwald <erik@smluc.org> (maintainer)
-rw-r--r--lang/gauche/Makefile10
-rw-r--r--lang/gauche/pkg-plist8
2 files changed, 15 insertions, 3 deletions
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
index a25ad6a0c47b..8f2224b27029 100644
--- a/lang/gauche/Makefile
+++ b/lang/gauche/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gauche
PORTVERSION= 0.8.3 # Keep databases/gauche-gdbm in sync with this
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang scheme
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -55,9 +55,15 @@ post-build:
post-install:
${STRIP_CMD} ${PREFIX}/bin/gosh
${RM} -f ${PREFIX}/share/gauche/${PORTVERSION}/lib/slibcat
- ${TOUCH} ${PREFIX}/share/gauche/site/lib/.keepme
+ ${MKDIR} ${PREFIX}/share/gauche/site/lib/.packages
+ ${TOUCH} ${PREFIX}/share/gauche/site/lib/.packages/.keepme
${TOUCH} ${PREFIX}/lib/gauche/site/${PORTVERSION}/${CONFIGURE_TARGET}/.keepme
${MKDIR} ${PREFIX}/share/gauche/${PORTVERSION}/lib/.packages
+ ${TOUCH} ${PREFIX}/share/gauche/${PORTVERSION}/lib/.packages/.keepme
+ ${MKDIR} ${DOCSDIR}
+ ${TOUCH} ${DOCSDIR}/.keepme
+ ${MKDIR} ${EXAMPLESDIR}
+ ${TOUCH} ${EXAMPLESDIR}/.keepme
.if !defined(NOPORTDOCS)
${INSTALL_MAN} ${WRKSRC}/doc/*.1 ${MANPREFIX}/man/man1/
diff --git a/lang/gauche/pkg-plist b/lang/gauche/pkg-plist
index 61de441cbde0..b9e854393c76 100644
--- a/lang/gauche/pkg-plist
+++ b/lang/gauche/pkg-plist
@@ -209,7 +209,11 @@ share/gauche/%%VERSION%%/lib/util/toposort.scm
share/gauche/%%VERSION%%/lib/util/tree.scm
share/gauche/%%VERSION%%/lib/www/cgi-test.scm
share/gauche/%%VERSION%%/lib/www/cgi.scm
-share/gauche/site/lib/.keepme
+share/gauche/%%VERSION%%/lib/.packages/.keepme
+share/gauche/site/lib/.packages/.keepme
+%%DOCSDIR%%/.keepme
+%%EXAMPLESDIR%%/.keepme
+@dirrm share/gauche/site/lib/.packages
@dirrm share/gauche/site/lib
@dirrm share/gauche/site
@dirrm share/gauche/%%VERSION%%/lib/www
@@ -244,3 +248,5 @@ share/gauche/site/lib/.keepme
@dirrm lib/gauche/%%VERSION%%/%%TARGET%%
@dirrm lib/gauche/%%VERSION%%
@dirrm lib/gauche
+@dirrm %%DOCSDIR%%
+@dirrm %%EXAMPLESDIR%%