aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-09-21 19:41:43 +0800
committermiwi <miwi@FreeBSD.org>2009-09-21 19:41:43 +0800
commit199fe7ffc33bb31c7da90b495a078e50f61ef653 (patch)
treef8e634f4f8a89e9c03e2151cdf391d0d378b0828
parentc68672de37cedcf2e835af03ddd985e5e569f4b7 (diff)
downloadfreebsd-ports-gnome-199fe7ffc33bb31c7da90b495a078e50f61ef653.tar.gz
freebsd-ports-gnome-199fe7ffc33bb31c7da90b495a078e50f61ef653.tar.zst
freebsd-ports-gnome-199fe7ffc33bb31c7da90b495a078e50f61ef653.zip
- Update to 2.0
PR: 138787 Submitted by: Charlie Kester <corky1951@comcast.net> (maintainer) Feature safe: yes
-rw-r--r--security/nettle2/Makefile26
-rw-r--r--security/nettle2/distinfo6
-rw-r--r--security/nettle2/files/patch-Makefile.in31
-rw-r--r--security/nettle2/files/patch-configure11
-rw-r--r--security/nettle2/files/patch-examples_nettle-openssl.c13
-rw-r--r--security/nettle2/files/patch-nettle2.info11
-rw-r--r--security/nettle2/pkg-plist126
7 files changed, 121 insertions, 103 deletions
diff --git a/security/nettle2/Makefile b/security/nettle2/Makefile
index d92a6a72ca2f..3f7bbbf9ee1d 100644
--- a/security/nettle2/Makefile
+++ b/security/nettle2/Makefile
@@ -1,17 +1,17 @@
# ex:ts=8
-# New ports collection makefile for: nettle
-# Date created: Dec 6, 2001
-# Whom: ijliao
+# New ports collection makefile for: nettle2
+# Date created: 13 Sep 2009
+# Whom: corky1951@comcast.net
#
# $FreeBSD$
#
-PORTNAME= nettle
-PORTVERSION= 1.15
-PORTREVISION= 2
+PORTNAME= nettle2
+PORTVERSION= 2.0
CATEGORIES= security
MASTER_SITES= http://www.lysator.liu.se/~nisse/archive/ \
ftp://ftp.lysator.liu.se/pub/security/lsh/
+DISTNAME= ${PORTNAME:S/2$//}-${PORTVERSION}
MAINTAINER= corky1951@comcast.net
COMMENT= A low-level cryptographic library
@@ -22,21 +22,27 @@ USE_GMAKE= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
-CONFIGURE_ARGS= --enable-shared
+CONFIGURE_ARGS= --enable-shared \
+ --includedir=${PREFIX}/include/${DISTNAME} \
+ --bindir=${PREFIX}/bin/${DISTNAME} \
+ --libdir=${PREFIX}/lib/${DISTNAME}
+
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-DOCS= NEWS README TODO nettle.html
+DOCS= NEWS README TODO nettle.html nettle.pdf
EXAMPLES= examples/*.c examples/*.h
-INFO= nettle
+INFO= nettle2
post-extract:
- @${RM} -f ${WRKSRC}/nettle.info*
+ @${MV} ${WRKSRC}/nettle.info ${WRKSRC}/nettle2.info
post-install:
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
+.endif
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
diff --git a/security/nettle2/distinfo b/security/nettle2/distinfo
index f67158cfbbd7..5dbc8e58ff04 100644
--- a/security/nettle2/distinfo
+++ b/security/nettle2/distinfo
@@ -1,3 +1,3 @@
-MD5 (nettle-1.15.tar.gz) = 6b0fd004359660b65ff3eca77b3d5fa6
-SHA256 (nettle-1.15.tar.gz) = d6e540bf4acc857a3b09580e7f61822d352ee83c119579bf7333f0a785f7d9ac
-SIZE (nettle-1.15.tar.gz) = 829862
+MD5 (nettle-2.0.tar.gz) = d813bc76b1042d76100efbc6a955d7df
+SHA256 (nettle-2.0.tar.gz) = 65b9e230b953bfb075f10473917e216df9b825fc325b88f69cdf756ffa17cbd6
+SIZE (nettle-2.0.tar.gz) = 883732
diff --git a/security/nettle2/files/patch-Makefile.in b/security/nettle2/files/patch-Makefile.in
index a46bc2fb063b..4beadec89ad5 100644
--- a/security/nettle2/files/patch-Makefile.in
+++ b/security/nettle2/files/patch-Makefile.in
@@ -1,10 +1,23 @@
---- Makefile.in.orig Tue Nov 1 09:34:09 2005
-+++ Makefile.in Tue Nov 1 09:34:24 2005
-@@ -221,7 +221,6 @@
- $(INSTALL_PROGRAM) $(SHLIBFORLINK) $(DESTDIR)$(libdir)/$(SHLIBFILE)
- [ -z "$(SHLIBSONAME)" ] \
- || (cd $(DESTDIR)$(libdir) \
-- && ln -sf $(SHLIBFILE) $(SHLIBSONAME) \
- && ln -sf $(SHLIBFILE) $(SHLIBFORLINK) )
+--- Makefile.in.orig 2009-09-12 23:27:08.000000000 -0700
++++ Makefile.in 2009-09-12 23:29:42.000000000 -0700
+@@ -26,7 +26,7 @@
+ TARGETS = aesdata$(EXEEXT) desdata$(EXEEXT) shadata$(EXEEXT) \
+ $(LIBTARGETS) @IF_SHARED@ $(SHLIBTARGETS)
- install-info: nettle.info
+-DOCTARGETS = nettle.info nettle.html nettle.pdf
++DOCTARGETS = nettle2.info nettle.html nettle.pdf
+
+ all check install uninstall:
+ $(MAKE) $@-here
+@@ -277,9 +277,9 @@
+ # installed. But it seems most make programs don't set $<, $^, $? and
+ # friends for ordinary explicit rules.
+
+-install-info: nettle.info
++install-info: nettle2.info
+ $(MKDIR_P) $(DESTDIR)$(infodir)
+- f=nettle.info ; \
++ f=nettle2.info ; \
+ [ -f $$f ] || f="$(srcdir)/$$f" ; \
+ $(INSTALL_DATA) "$$f" $(DESTDIR)$(infodir) ; \
+ if (install-info --version && \
diff --git a/security/nettle2/files/patch-configure b/security/nettle2/files/patch-configure
deleted file mode 100644
index dceae170135b..000000000000
--- a/security/nettle2/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Tue Nov 1 09:35:20 2005
-+++ configure Tue Nov 1 09:36:28 2005
-@@ -2990,7 +2990,7 @@
- *)
- SHLIBFORLINK=libnettle.so
- SHLIBSONAME='$(SHLIBFORLINK).$(SHLIBMAJOR)'
-- SHLIBFILE='$(SHLIBSONAME).$(SHLIBMINOR)'
-+ SHLIBFILE='$(SHLIBSONAME)'
- SHLIBLINK='$(CC) $(LDFLAGS) -shared -Wl,-soname=$(SHLIBSONAME)'
- # FIXME: It might make some sense to link with -lgmp
- SHLIBLIBS=''
diff --git a/security/nettle2/files/patch-examples_nettle-openssl.c b/security/nettle2/files/patch-examples_nettle-openssl.c
deleted file mode 100644
index 985dabbf146c..000000000000
--- a/security/nettle2/files/patch-examples_nettle-openssl.c
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- examples/nettle-openssl.c.orig
-+++ examples/nettle-openssl.c
-@@ -35,6 +35,7 @@
- #define NCOMPAT
- #define OPENSSL_DISABLE_OLD_DES_SUPPORT
-
-+#include <sys/types.h>
- #include <assert.h>
-
- #include <openssl/aes.h>
diff --git a/security/nettle2/files/patch-nettle2.info b/security/nettle2/files/patch-nettle2.info
new file mode 100644
index 000000000000..e36ad4a23fe8
--- /dev/null
+++ b/security/nettle2/files/patch-nettle2.info
@@ -0,0 +1,11 @@
+--- nettle2.info.orig 2009-06-08 11:27:11.000000000 -0700
++++ nettle2.info 2009-09-13 10:54:29.000000000 -0700
+@@ -12,7 +12,7 @@
+
+ INFO-DIR-SECTION Encryption
+ START-INFO-DIR-ENTRY
+-* Nettle: (nettle). A low-level cryptographic library.
++* Nettle2: (nettle2). A low-level cryptographic library.
+ END-INFO-DIR-ENTRY
+
+ 
diff --git a/security/nettle2/pkg-plist b/security/nettle2/pkg-plist
index af66fcaaa691..f8a6ac7e01dc 100644
--- a/security/nettle2/pkg-plist
+++ b/security/nettle2/pkg-plist
@@ -1,62 +1,74 @@
-bin/nettle-lfib-stream
-bin/pkcs1-conv
-bin/sexp-conv
-include/nettle/aes.h
-include/nettle/arcfour.h
-include/nettle/arctwo.h
-include/nettle/asn1.h
-include/nettle/base16.h
-include/nettle/base64.h
-include/nettle/bignum.h
-include/nettle/blowfish.h
-include/nettle/buffer.h
-include/nettle/cast128.h
-include/nettle/cbc.h
-include/nettle/ctr.h
-include/nettle/des-compat.h
-include/nettle/des.h
-include/nettle/dsa.h
-include/nettle/hmac.h
-include/nettle/knuth-lfib.h
-include/nettle/macros.h
-include/nettle/md2.h
-include/nettle/md4.h
-include/nettle/md5-compat.h
-include/nettle/md5.h
-include/nettle/memxor.h
-include/nettle/nettle-meta.h
-include/nettle/nettle-stdint.h
-include/nettle/nettle-types.h
-include/nettle/pgp.h
-include/nettle/pkcs1.h
-include/nettle/realloc.h
-include/nettle/rsa-compat.h
-include/nettle/rsa.h
-include/nettle/serpent.h
-include/nettle/sexp.h
-include/nettle/sha.h
-include/nettle/twofish.h
-include/nettle/yarrow.h
-@dirrm include/nettle
-lib/libnettle.a
-lib/libnettle.so
-lib/libnettle.so.2
+bin/nettle-2.0/nettle-lfib-stream
+bin/nettle-2.0/pkcs1-conv
+bin/nettle-2.0/sexp-conv
+include/nettle-2.0/nettle/aes.h
+include/nettle-2.0/nettle/arcfour.h
+include/nettle-2.0/nettle/arctwo.h
+include/nettle-2.0/nettle/asn1.h
+include/nettle-2.0/nettle/base16.h
+include/nettle-2.0/nettle/base64.h
+include/nettle-2.0/nettle/bignum.h
+include/nettle-2.0/nettle/blowfish.h
+include/nettle-2.0/nettle/buffer.h
+include/nettle-2.0/nettle/cast128.h
+include/nettle-2.0/nettle/cbc.h
+include/nettle-2.0/nettle/ctr.h
+include/nettle-2.0/nettle/des-compat.h
+include/nettle-2.0/nettle/des.h
+include/nettle-2.0/nettle/dsa.h
+include/nettle-2.0/nettle/hmac.h
+include/nettle-2.0/nettle/knuth-lfib.h
+include/nettle-2.0/nettle/macros.h
+include/nettle-2.0/nettle/md2.h
+include/nettle-2.0/nettle/md4.h
+include/nettle-2.0/nettle/md5-compat.h
+include/nettle-2.0/nettle/md5.h
+include/nettle-2.0/nettle/memxor.h
+include/nettle-2.0/nettle/nettle-meta.h
+include/nettle-2.0/nettle/nettle-stdint.h
+include/nettle-2.0/nettle/nettle-types.h
+include/nettle-2.0/nettle/pgp.h
+include/nettle-2.0/nettle/pkcs1.h
+include/nettle-2.0/nettle/realloc.h
+include/nettle-2.0/nettle/rsa-compat.h
+include/nettle-2.0/nettle/rsa.h
+include/nettle-2.0/nettle/serpent.h
+include/nettle-2.0/nettle/sexp.h
+include/nettle-2.0/nettle/sha.h
+include/nettle-2.0/nettle/twofish.h
+include/nettle-2.0/nettle/yarrow.h
+lib/nettle-2.0/libhogweed.a
+lib/nettle-2.0/libhogweed.so
+lib/nettle-2.0/libhogweed.so.1
+lib/nettle-2.0/libhogweed.so.1.0
+lib/nettle-2.0/libnettle.a
+lib/nettle-2.0/libnettle.so
+lib/nettle-2.0/libnettle.so.3
+lib/nettle-2.0/libnettle.so.3.0
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/nettle.html
+%%PORTDOCS%%%%DOCSDIR%%/nettle.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/eratosthenes.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getopt.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getopt.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getopt1.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/io.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/io.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nettle-benchmark.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nettle-openssl.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/next-prime.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/read_rsa_key.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-decrypt.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-encrypt.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-keygen.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-session.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-sign.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rsa-verify.c
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%EXAMPLESDIR%%/getopt.c
-%%EXAMPLESDIR%%/getopt.h
-%%EXAMPLESDIR%%/getopt1.c
-%%EXAMPLESDIR%%/io.c
-%%EXAMPLESDIR%%/io.h
-%%EXAMPLESDIR%%/nettle-benchmark.c
-%%EXAMPLESDIR%%/nettle-openssl.c
-%%EXAMPLESDIR%%/rsa-decrypt.c
-%%EXAMPLESDIR%%/rsa-encrypt.c
-%%EXAMPLESDIR%%/rsa-keygen.c
-%%EXAMPLESDIR%%/rsa-session.h
-%%EXAMPLESDIR%%/rsa-sign.c
-%%EXAMPLESDIR%%/rsa-verify.c
-@dirrm %%EXAMPLESDIR%%
+@dirrm lib/nettle-2.0
+@dirrm include/nettle-2.0/nettle
+@dirrm include/nettle-2.0
+@dirrm bin/nettle-2.0