aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2010-03-12 16:38:22 +0800
committergahr <gahr@FreeBSD.org>2010-03-12 16:38:22 +0800
commit19e8d9a5a2d17cac676b179ba280d97257c39b1a (patch)
treea02e57ecb78a3af2386d4907e92ff3b61fd8f96a
parent7ff9ec3e60302b27adf638b48cc58c99319cf399 (diff)
downloadfreebsd-ports-gnome-19e8d9a5a2d17cac676b179ba280d97257c39b1a.tar.gz
freebsd-ports-gnome-19e8d9a5a2d17cac676b179ba280d97257c39b1a.tar.zst
freebsd-ports-gnome-19e8d9a5a2d17cac676b179ba280d97257c39b1a.zip
- Use the new CMAKE_OUTSOURCE feature
- Move fltk-threads from BUILD_DEPENDS to LIB_DEPENDS
-rw-r--r--graphics/aqsis/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/graphics/aqsis/Makefile b/graphics/aqsis/Makefile
index bc6805c41d34..d6b26b58e207 100644
--- a/graphics/aqsis/Makefile
+++ b/graphics/aqsis/Makefile
@@ -18,33 +18,24 @@ COMMENT= A photorealistic rendering system
LIB_DEPENDS= IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
boost_filesystem.4:${PORTSDIR}/devel/boost-libs \
tiff.4:${PORTSDIR}/graphics/tiff \
+ fltk-threads>=0:${PORTSDIR}/x11-toolkits/fltk-threads
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
- xsltproc:${PORTSDIR}/textproc/libxslt \
- fltk-threads>=0:${PORTSDIR}/x11-toolkits/fltk-threads
+ xsltproc:${PORTSDIR}/textproc/libxslt
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
USE_CMAKE= yes
CMAKE_USE_PTHREAD= yes
+CMAKE_OUTSOURCE= yes
INSTALLS_ICONS= yes
-# Required for off-source building
-CMAKE_BUILD_PATH= ${WRKSRC}/build
-CMAKE_SOURCE_PATH= ${WRKSRC}/
-CONFIGURE_WRKSRC= ${CMAKE_BUILD_PATH}
-BUILD_WRKSRC= ${CMAKE_BUILD_PATH}
-INSTALL_WRKSRC= ${CMAKE_BUILD_PATH}
-
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 700000
BROKEN= does not compile on 6.X
.endif
-post-extract:
- ${MKDIR} ${CMAKE_BUILD_PATH}
-
.include <bsd.port.post.mk>