aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-09-04 01:40:21 +0800
committerswills <swills@FreeBSD.org>2012-09-04 01:40:21 +0800
commit1a02eb94658c20da0b9ab10c74de428cc32d7286 (patch)
tree537028858204a0e76868de5f2bfb19d29e992e27
parentffea458e112439611397ae15cc68dfc82d8ddff0 (diff)
downloadfreebsd-ports-gnome-1a02eb94658c20da0b9ab10c74de428cc32d7286.tar.gz
freebsd-ports-gnome-1a02eb94658c20da0b9ab10c74de428cc32d7286.tar.zst
freebsd-ports-gnome-1a02eb94658c20da0b9ab10c74de428cc32d7286.zip
- Fix another high CPU usage condition
-rw-r--r--net-p2p/bitcoin/Makefile2
-rw-r--r--net-p2p/bitcoin/files/patch-bitcoin.cpp20
2 files changed, 21 insertions, 1 deletions
diff --git a/net-p2p/bitcoin/Makefile b/net-p2p/bitcoin/Makefile
index 08500a34979b..ed680bf4fd5b 100644
--- a/net-p2p/bitcoin/Makefile
+++ b/net-p2p/bitcoin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bitcoin
PORTVERSION= 0.6.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-p2p finance
MAINTAINER= ports@FreeBSD.org
diff --git a/net-p2p/bitcoin/files/patch-bitcoin.cpp b/net-p2p/bitcoin/files/patch-bitcoin.cpp
new file mode 100644
index 000000000000..d42c22427af8
--- /dev/null
+++ b/net-p2p/bitcoin/files/patch-bitcoin.cpp
@@ -0,0 +1,20 @@
+--- src/qt/bitcoin.cpp.orig 2012-06-19 16:44:55.000000000 -0400
++++ src/qt/bitcoin.cpp 2012-09-03 13:30:43.641710746 -0400
+@@ -134,7 +134,7 @@
+ #ifndef BITCOIN_QT_TEST
+ int main(int argc, char *argv[])
+ {
+-#if !defined(MAC_OSX) && !defined(WIN32)
++#if !defined(MAC_OSX) && !defined(WIN32) && !defined(__FreeBSD__)
+ // TODO: implement qtipcserver.cpp for Mac and Windows
+
+ // Do this early as we don't want to bother initializing if we are just calling IPC
+@@ -261,7 +261,7 @@
+ // Place this here as guiref has to be defined if we dont want to lose URIs
+ ipcInit();
+
+-#if !defined(MAC_OSX) && !defined(WIN32)
++#if !defined(MAC_OSX) && !defined(WIN32) && !defined(__FreeBSD__)
+ // TODO: implement qtipcserver.cpp for Mac and Windows
+
+ // Check for URI in argv