aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2013-08-09 07:58:12 +0800
committerzi <zi@FreeBSD.org>2013-08-09 07:58:12 +0800
commit1a5a0f68055a005b1b024f5d8e1450b2a90b652c (patch)
treeab2124103df643c199fdaa0e03b1f992fcb9a230
parent51658f72777e8142ba1f297017a6a380fb1d2a1d (diff)
downloadfreebsd-ports-gnome-1a5a0f68055a005b1b024f5d8e1450b2a90b652c.tar.gz
freebsd-ports-gnome-1a5a0f68055a005b1b024f5d8e1450b2a90b652c.tar.zst
freebsd-ports-gnome-1a5a0f68055a005b1b024f5d8e1450b2a90b652c.zip
- Fix build under 10-CURRENT when using OpenSSL, chasing r254107 (OpenSSL bugfix for RT #2984)
- Add security/ca_root_nss as a dependency to fix GnuTLS build - Do not bump PORTREVISION Reported by: gnn@
-rw-r--r--security/openconnect/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/security/openconnect/Makefile b/security/openconnect/Makefile
index 08d5425638f3..219db3616485 100644
--- a/security/openconnect/Makefile
+++ b/security/openconnect/Makefile
@@ -18,14 +18,15 @@ RUN_DEPENDS= vpnc-script:${PORTSDIR}/sysutils/vpnc-scripts
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-nls --with-vpnc-script=${LOCALBASE}/sbin/vpnc-script \
- --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
-USE_AUTOTOOLS= aclocal autoconf libtool
-AUTOMAKE_ARGS= --add-missing
-USES= pathfix pkgconfig
+ --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
+ --without-openssl-version-check
+USE_AUTOTOOLS= aclocal autoconf automake libtool
+USES= pathfix pkgconfig
USE_GMAKE= yes
USE_OPENSSL= yes
MAKE_JOBS_SAFE= yes
ACLOCAL_ARGS= -I .
+AUTOMAKE_ARGS= --add-missing
USE_LDCONFIG= yes
PORTDOCS= *
@@ -40,7 +41,10 @@ GNUTLS_DESC= Use GnuTLS instead of OpenSSL(EXPERIMENTAL)
.if ${PORT_OPTIONS:MGNUTLS}
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
-CONFIGURE_ARGS+=--with-gnutls
+CONFIGURE_ARGS+=--with-gnutls \
+ --with-system-cafile=${LOCALBASE}/share/certs/ca-root-nss.crt
+RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+BUILD_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
.endif
.include <bsd.port.pre.mk>