aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2002-02-07 09:46:52 +0800
committerkuriyama <kuriyama@FreeBSD.org>2002-02-07 09:46:52 +0800
commit1a643a5ae4ad76d34b89870eb6ad595168bb6539 (patch)
tree1550f2950fac7ada86ffdcfec565a5ecb93fcccd
parent1910c60330b2ad6a6e5fd7bb4102457a2d7dad0c (diff)
downloadfreebsd-ports-gnome-1a643a5ae4ad76d34b89870eb6ad595168bb6539.tar.gz
freebsd-ports-gnome-1a643a5ae4ad76d34b89870eb6ad595168bb6539.tar.zst
freebsd-ports-gnome-1a643a5ae4ad76d34b89870eb6ad595168bb6539.zip
Add dtdinst 2001.12.03,
converts DTDs to XML instance, in a specific or RELAX NG format. PR: ports/34575 Submitted by: Kimura Fuyuki <fuyuki@mj.0038.net>
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/dtdinst/Makefile38
-rw-r--r--textproc/dtdinst/distinfo4
-rw-r--r--textproc/dtdinst/pkg-comment1
-rw-r--r--textproc/dtdinst/pkg-descr8
-rw-r--r--textproc/dtdinst/pkg-plist6
6 files changed, 58 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 33155001eedf..0dbcd53f2ce1 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -40,6 +40,7 @@
SUBDIR += dsssl-docbook-modular
SUBDIR += dtd-catalogs
SUBDIR += dtd2relax
+ SUBDIR += dtdinst
SUBDIR += dtdparse
SUBDIR += eruby
SUBDIR += expat
diff --git a/textproc/dtdinst/Makefile b/textproc/dtdinst/Makefile
new file mode 100644
index 000000000000..ac7a9c14cf89
--- /dev/null
+++ b/textproc/dtdinst/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: dtdinst
+# Date created: 3 February 2002
+# Whom: Kimura Fuyuki <fuyuki@mj.0038.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dtdinst
+PORTVERSION= 2001.12.03
+CATEGORIES= textproc
+MASTER_SITES= http://www.thaiopensource.com/dtdinst/
+DISTNAME= ${PORTNAME}
+DISTFILES= ${JAR} dtdinst2rng.xsl index.html copying.txt
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY=
+
+MAINTAINER= fuyuki@mj.0038.net
+
+RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
+
+NO_BUILD= yes
+
+JAR= ${DISTNAME}.jar
+JAVALIBDIR= ${PREFIX}/share/java/classes
+XMLDIR= ${PREFIX}/share/xml/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${JAVALIBDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${JAR} ${JAVALIBDIR}
+ ${MKDIR} ${XMLDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/*.xsl ${XMLDIR}
+
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/*.html ${DOCSDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/*.txt ${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/dtdinst/distinfo b/textproc/dtdinst/distinfo
new file mode 100644
index 000000000000..5bbda00959d0
--- /dev/null
+++ b/textproc/dtdinst/distinfo
@@ -0,0 +1,4 @@
+MD5 (dtdinst/dtdinst.jar) = 6db070bfa35ab6b9d7ead88a1241cce7
+MD5 (dtdinst/dtdinst2rng.xsl) = b06e045533c29c177f407cd4f79010fa
+MD5 (dtdinst/index.html) = 34ef5c943a2ea2a954510839490b8be9
+MD5 (dtdinst/copying.txt) = febb9f1c62da7a0b7838728442c2d44f
diff --git a/textproc/dtdinst/pkg-comment b/textproc/dtdinst/pkg-comment
new file mode 100644
index 000000000000..92dfcdaa7689
--- /dev/null
+++ b/textproc/dtdinst/pkg-comment
@@ -0,0 +1 @@
+Converts DTDs to XML instance, in a specific or RELAX NG format
diff --git a/textproc/dtdinst/pkg-descr b/textproc/dtdinst/pkg-descr
new file mode 100644
index 000000000000..c4ea96d7a7cc
--- /dev/null
+++ b/textproc/dtdinst/pkg-descr
@@ -0,0 +1,8 @@
+DTDinst is a program for converting XML DTDs into XML instance
+format. The XML instance can be in either a format specific to DTDinst
+or RELAX NG format.
+
+WWW: http://www.thaiopensource.com/dtdinst/
+
+- Kimura Fuyuki
+fuyuki@mj.0038.net
diff --git a/textproc/dtdinst/pkg-plist b/textproc/dtdinst/pkg-plist
new file mode 100644
index 000000000000..0733f4b4db9b
--- /dev/null
+++ b/textproc/dtdinst/pkg-plist
@@ -0,0 +1,6 @@
+share/java/classes/dtdinst.jar
+share/xml/dtdinst/dtdinst2rng.xsl
+@dirrm share/xml/dtdinst
+share/doc/dtdinst/copying.txt
+share/doc/dtdinst/index.html
+@dirrm share/doc/dtdinst