aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-15 09:41:12 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-15 09:41:12 +0800
commit1a8d281896d636272a26187daeea16cccd64573c (patch)
tree42c6e1333b9a5ecd61fa4cf730c9deeb6f592a78
parent940e850d406417a3ba5b99a9e84324fadbb5c5cb (diff)
downloadfreebsd-ports-gnome-1a8d281896d636272a26187daeea16cccd64573c.tar.gz
freebsd-ports-gnome-1a8d281896d636272a26187daeea16cccd64573c.tar.zst
freebsd-ports-gnome-1a8d281896d636272a26187daeea16cccd64573c.zip
devel/google{test,mock}: update to 1.8.0.11
Changes: https://github.com/google/googletest/compare/release-1.7.0...a2b8a8e
-rw-r--r--devel/googlemock/Makefile10
-rw-r--r--devel/googlemock/distinfo5
-rw-r--r--devel/googlemock/files/patch-Makefile.am16
-rw-r--r--devel/googlemock/files/patch-scripts_gmock__doctor.py41
-rw-r--r--devel/googlemock/pkg-plist3
-rw-r--r--devel/googletest/Makefile4
-rw-r--r--devel/googletest/distinfo5
-rw-r--r--devel/googletest/files/patch-Makefile.am16
-rw-r--r--devel/googletest/files/patch-bsd-defines139
-rw-r--r--devel/googletest/pkg-plist4
-rw-r--r--science/orthanc-dicomweb/Makefile1
-rw-r--r--science/orthanc-webviewer/Makefile1
-rw-r--r--science/orthanc/Makefile1
-rw-r--r--security/certificate-transparency/Makefile2
14 files changed, 125 insertions, 123 deletions
diff --git a/devel/googlemock/Makefile b/devel/googlemock/Makefile
index eda5e6b8a396..31d6876a2b02 100644
--- a/devel/googlemock/Makefile
+++ b/devel/googlemock/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= googlemock
-PORTVERSION= 1.7.0
DISTVERSIONPREFIX= release-
-PORTREVISION= 1
+DISTVERSION= 1.8.0-11
+DISTVERSIONSUFFIX= -ga2b8a8e
CATEGORIES= devel
MAINTAINER= jbeich@FreeBSD.org
@@ -14,13 +14,15 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/share/aclocal/ax_pthread.m4:devel/autoconf-archive \
- googletest>=1.7.0:devel/googletest
+ googletest>=1.8.0:devel/googletest
LIB_DEPENDS= libgtest.so:devel/googletest
USE_GITHUB= yes
GH_ACCOUNT= google
+GH_PROJECT= googletest
-USES= autoreconf libtool
+USES= autoreconf libtool localbase
+WRKSRC_SUBDIR= ${PORTNAME}
GNU_CONFIGURE= yes
# fused-src python tests are only useful for bundling. There's no point in
# running them before installing system-wide without source files.
diff --git a/devel/googlemock/distinfo b/devel/googlemock/distinfo
index 96af375d199f..0e55d069b829 100644
--- a/devel/googlemock/distinfo
+++ b/devel/googlemock/distinfo
@@ -1,2 +1,3 @@
-SHA256 (google-googlemock-release-1.7.0_GH0.tar.gz) = 3f20b6acb37e5a98e8c4518165711e3e35d47deb6cdb5a4dd4566563b5efd232
-SIZE (google-googlemock-release-1.7.0_GH0.tar.gz) = 296168
+TIMESTAMP = 1471419713
+SHA256 (google-googletest-release-1.8.0-11-ga2b8a8e_GH0.tar.gz) = 5e7cb72292eec51ca0ecb9c83d4769c667b7ead7daba83a89cbc20f7fbd2fd74
+SIZE (google-googletest-release-1.8.0-11-ga2b8a8e_GH0.tar.gz) = 1282276
diff --git a/devel/googlemock/files/patch-Makefile.am b/devel/googlemock/files/patch-Makefile.am
new file mode 100644
index 000000000000..73e3dedeaad8
--- /dev/null
+++ b/devel/googlemock/files/patch-Makefile.am
@@ -0,0 +1,16 @@
+Move custom headers into their own directory
+
+--- Makefile.am.orig 2016-11-03 20:36:28 UTC
++++ Makefile.am
+@@ -42,7 +42,10 @@ pkginclude_internaldir = $(pkgincludedir
+ pkginclude_internal_HEADERS = \
+ include/gmock/internal/gmock-generated-internal-utils.h \
+ include/gmock/internal/gmock-internal-utils.h \
+- include/gmock/internal/gmock-port.h \
++ include/gmock/internal/gmock-port.h
++
++pkginclude_internal_customdir = $(pkgincludedir)/internal/custom
++pkginclude_internal_custom_HEADERS = \
+ include/gmock/internal/custom/gmock-generated-actions.h \
+ include/gmock/internal/custom/gmock-matchers.h \
+ include/gmock/internal/custom/gmock-port.h
diff --git a/devel/googlemock/files/patch-scripts_gmock__doctor.py b/devel/googlemock/files/patch-scripts_gmock__doctor.py
deleted file mode 100644
index 608e635886ca..000000000000
--- a/devel/googlemock/files/patch-scripts_gmock__doctor.py
+++ /dev/null
@@ -1,41 +0,0 @@
-From ac830d6b197f8b8dad24782d7900c69cee0ab77e Mon Sep 17 00:00:00 2001
-From: Syl <srouquette@gmail.com>
-Date: Sun, 30 Aug 2015 08:57:48 +0200
-Subject: [PATCH] Fix gmock_doctor.py for Python3
-
---- scripts/gmock_doctor.py.orig 2013-09-19 00:32:04 UTC
-+++ scripts/gmock_doctor.py
-@@ -590,7 +590,7 @@ def main():
- print ('Please copy and paste the compiler errors here. Press c-D when '
- 'you are done:')
- else:
-- print 'Waiting for compiler errors on stdin . . .'
-+ print ('Waiting for compiler errors on stdin . . .')
-
- msg = sys.stdin.read().strip()
- diagnoses = Diagnose(msg)
-@@ -608,18 +608,18 @@ If you send your source code and the com
- %s, you can be helped and I can get smarter --
- win-win for us!""" % (msg, _EMAIL))
- else:
-- print '------------------------------------------------------------'
-- print 'Your code appears to have the following',
-+ print ('------------------------------------------------------------')
-+ print ('Your code appears to have the following',)
- if count > 1:
-- print '%s diseases:' % (count,)
-+ print ('%s diseases:' % (count,))
- else:
-- print 'disease:'
-+ print ('disease:')
- i = 0
- for d in diagnoses:
- i += 1
- if count > 1:
-- print '\n#%s:' % (i,)
-- print d
-+ print ('\n#%s:' % (i,))
-+ print (d)
- print ("""
- How did I do? If you think I'm wrong or unhelpful, please send your
- source code and the compiler's error messages to %s.
diff --git a/devel/googlemock/pkg-plist b/devel/googlemock/pkg-plist
index beed971d4166..caba3b153a6c 100644
--- a/devel/googlemock/pkg-plist
+++ b/devel/googlemock/pkg-plist
@@ -11,6 +11,9 @@ include/gmock/gmock-more-actions.h
include/gmock/gmock-more-matchers.h
include/gmock/gmock-spec-builders.h
include/gmock/gmock.h
+include/gmock/internal/custom/gmock-generated-actions.h
+include/gmock/internal/custom/gmock-matchers.h
+include/gmock/internal/custom/gmock-port.h
include/gmock/internal/gmock-generated-internal-utils.h
include/gmock/internal/gmock-internal-utils.h
include/gmock/internal/gmock-port.h
diff --git a/devel/googletest/Makefile b/devel/googletest/Makefile
index d7baf43e1853..abeb05522bc8 100644
--- a/devel/googletest/Makefile
+++ b/devel/googletest/Makefile
@@ -2,8 +2,9 @@
# $FreeBSD$
PORTNAME= googletest
-PORTVERSION= 1.7.0
DISTVERSIONPREFIX= release-
+DISTVERSION= 1.8.0-11
+DISTVERSIONSUFFIX= -ga2b8a8e
CATEGORIES= devel
MAINTAINER= jbeich@FreeBSD.org
@@ -16,6 +17,7 @@ USE_GITHUB= yes
GH_ACCOUNT= google
USES= autoreconf libtool
+WRKSRC_SUBDIR= ${PORTNAME}
GNU_CONFIGURE= yes
# fused-src python tests are only useful for bundling. There's no point in
# running them before installing system-wide without source files.
diff --git a/devel/googletest/distinfo b/devel/googletest/distinfo
index d667fd34e82e..0e55d069b829 100644
--- a/devel/googletest/distinfo
+++ b/devel/googletest/distinfo
@@ -1,2 +1,3 @@
-SHA256 (google-googletest-release-1.7.0_GH0.tar.gz) = f73a6546fdf9fce9ff93a5015e0333a8af3062a152a9ad6bcb772c96687016cc
-SIZE (google-googletest-release-1.7.0_GH0.tar.gz) = 468653
+TIMESTAMP = 1471419713
+SHA256 (google-googletest-release-1.8.0-11-ga2b8a8e_GH0.tar.gz) = 5e7cb72292eec51ca0ecb9c83d4769c667b7ead7daba83a89cbc20f7fbd2fd74
+SIZE (google-googletest-release-1.8.0-11-ga2b8a8e_GH0.tar.gz) = 1282276
diff --git a/devel/googletest/files/patch-Makefile.am b/devel/googletest/files/patch-Makefile.am
new file mode 100644
index 000000000000..139ad1ce2316
--- /dev/null
+++ b/devel/googletest/files/patch-Makefile.am
@@ -0,0 +1,16 @@
+Move custom headers into their own directory
+
+--- Makefile.am.orig 2016-11-03 20:36:28 UTC
++++ Makefile.am
+@@ -208,7 +208,10 @@ pkginclude_internal_HEADERS = \
+ include/gtest/internal/gtest-port-arch.h \
+ include/gtest/internal/gtest-string.h \
+ include/gtest/internal/gtest-tuple.h \
+- include/gtest/internal/gtest-type-util.h \
++ include/gtest/internal/gtest-type-util.h
++
++pkginclude_internal_customdir = $(pkgincludedir)/internal/custom
++pkginclude_internal_custom_HEADERS = \
+ include/gtest/internal/custom/gtest.h \
+ include/gtest/internal/custom/gtest-port.h \
+ include/gtest/internal/custom/gtest-printers.h
diff --git a/devel/googletest/files/patch-bsd-defines b/devel/googletest/files/patch-bsd-defines
index ccd8f801d700..c8ed2fcb5047 100644
--- a/devel/googletest/files/patch-bsd-defines
+++ b/devel/googletest/files/patch-bsd-defines
@@ -1,53 +1,65 @@
-Index: include/gtest/internal/gtest-port.h
-===================================================================
---- include/gtest/internal/gtest-port.h (revision 692)
-+++ include/gtest/internal/gtest-port.h (working copy)
-@@ -128,6 +128,10 @@
- // GTEST_OS_IOS - iOS
- // GTEST_OS_IOS_SIMULATOR - iOS simulator
- // GTEST_OS_NACL - Google Native Client (NaCl)
-+// GTEST_OS_GNU_KFREEBSD - GNU/kFreeBSD
-+// GTEST_OS_DRAGONFLY - DragonFly
-+// GTEST_OS_FREEBSD - FreeBSD
-+// GTEST_OS_NETBSD - NetBSD
- // GTEST_OS_OPENBSD - OpenBSD
- // GTEST_OS_QNX - QNX
- // GTEST_OS_SOLARIS - Sun Solaris
-@@ -341,6 +345,14 @@
+o Add DragonFly, NetBSD and GNU/kFreeBSD support
+o Implement GetThreadCount() for BSDs
+o Work around StreamingListenerTest with GCC 4.2
+
+--- include/gtest/internal/gtest-port-arch.h.orig 2016-11-03 20:36:28 UTC
++++ include/gtest/internal/gtest-port-arch.h
+@@ -67,6 +67,10 @@
+ # if TARGET_OS_IPHONE
+ # define GTEST_OS_IOS 1
+ # endif
++#elif defined __DragonFly__
++# define GTEST_OS_DRAGONFLY 1
++#elif defined(__GLIBC__) && defined(__FreeBSD_kernel__)
++# define GTEST_OS_GNU_KFREEBSD 1
+ #elif defined __FreeBSD__
+ # define GTEST_OS_FREEBSD 1
+ #elif defined __linux__
+@@ -84,6 +88,8 @@
# define GTEST_OS_HPUX 1
#elif defined __native_client__
# define GTEST_OS_NACL 1
-+#elif defined(__GLIBC__) && defined(__FreeBSD_kernel__)
-+# define GTEST_OS_GNU_KFREEBSD 1
-+#elif defined __DragonFly__
-+# define GTEST_OS_DRAGONFLY 1
-+#elif defined __FreeBSD__
-+# define GTEST_OS_FREEBSD 1
+#elif defined __NetBSD__
+# define GTEST_OS_NETBSD 1
#elif defined __OpenBSD__
# define GTEST_OS_OPENBSD 1
#elif defined __QNX__
-@@ -611,6 +623,8 @@ struct _RTL_CRITICAL_SECTION;
+--- include/gtest/internal/gtest-port.h.orig 2016-11-03 20:36:28 UTC
++++ include/gtest/internal/gtest-port.h
+@@ -121,13 +121,16 @@
+ //
+ // GTEST_OS_AIX - IBM AIX
+ // GTEST_OS_CYGWIN - Cygwin
++// GTEST_OS_DRAGONFLY - DragonFly
+ // GTEST_OS_FREEBSD - FreeBSD
++// GTEST_OS_GNU_KFREEBSD - GNU/kFreeBSD
+ // GTEST_OS_HPUX - HP-UX
+ // GTEST_OS_LINUX - Linux
+ // GTEST_OS_LINUX_ANDROID - Google Android
+ // GTEST_OS_MAC - Mac OS X
+ // GTEST_OS_IOS - iOS
+ // GTEST_OS_NACL - Google Native Client (NaCl)
++// GTEST_OS_NETBSD - NetBSD
+ // GTEST_OS_OPENBSD - OpenBSD
+ // GTEST_OS_QNX - QNX
+ // GTEST_OS_SOLARIS - Sun Solaris
+@@ -607,6 +610,7 @@ typedef struct _RTL_CRITICAL_SECTION GTE
// To disable threading support in Google Test, add -DGTEST_HAS_PTHREAD=0
// to your compiler flags.
# define GTEST_HAS_PTHREAD (GTEST_OS_LINUX || GTEST_OS_MAC || GTEST_OS_HPUX \
-+ || GTEST_OS_GNU_KFREEBSD || GTEST_OS_DRAGONFLY || GTEST_OS_FREEBSD \
-+ || GTEST_OS_NETBSD || GTEST_OS_OPENBSD \
- || GTEST_OS_QNX)
++ || GTEST_OS_GNU_KFREEBSD || GTEST_OS_DRAGONFLY || GTEST_OS_NETBSD || GTEST_OS_OPENBSD \
+ || GTEST_OS_QNX || GTEST_OS_FREEBSD || GTEST_OS_NACL)
#endif // GTEST_HAS_PTHREAD
-@@ -791,7 +805,8 @@ using ::std::tuple_size;
- (GTEST_OS_MAC && !GTEST_OS_IOS) || GTEST_OS_IOS_SIMULATOR || \
+@@ -800,6 +804,7 @@ using ::std::tuple_size;
+ (GTEST_OS_MAC && !GTEST_OS_IOS) || \
(GTEST_OS_WINDOWS_DESKTOP && _MSC_VER >= 1400) || \
GTEST_OS_WINDOWS_MINGW || GTEST_OS_AIX || GTEST_OS_HPUX || \
-- GTEST_OS_OPENBSD || GTEST_OS_QNX)
-+ GTEST_OS_GNU_KFREEBSD || GTEST_OS_DRAGONFLY || GTEST_OS_FREEBSD || \
-+ GTEST_OS_NETBSD || GTEST_OS_OPENBSD || GTEST_OS_QNX)
++ GTEST_OS_GNU_KFREEBSD || GTEST_OS_DRAGONFLY || GTEST_OS_NETBSD || \
+ GTEST_OS_OPENBSD || GTEST_OS_QNX || GTEST_OS_FREEBSD)
# define GTEST_HAS_DEATH_TEST 1
- # include <vector> // NOLINT
#endif
-@@ -824,7 +839,8 @@ using ::std::tuple_size;
+@@ -832,7 +837,8 @@ using ::std::tuple_size;
(GTEST_OS_WINDOWS || GTEST_OS_CYGWIN || GTEST_OS_SYMBIAN || GTEST_OS_AIX)
// Determines whether test results can be streamed to a socket.
@@ -57,11 +69,9 @@ Index: include/gtest/internal/gtest-port.h
# define GTEST_CAN_STREAM_RESULTS_ 1
#endif
-Index: src/gtest-port.cc
-===================================================================
---- src/gtest-port.cc (revision 692)
-+++ src/gtest-port.cc (working copy)
-@@ -51,6 +51,14 @@
+--- src/gtest-port.cc.orig 2016-11-03 20:36:28 UTC
++++ src/gtest-port.cc
+@@ -52,6 +52,14 @@
# include <mach/vm_map.h>
#endif // GTEST_OS_MAC
@@ -76,7 +86,7 @@ Index: src/gtest-port.cc
#if GTEST_OS_QNX
# include <devctl.h>
# include <fcntl.h>
-@@ -104,6 +112,80 @@ size_t GetThreadCount() {
+@@ -131,6 +139,80 @@ size_t GetThreadCount() {
}
}
@@ -157,47 +167,32 @@ Index: src/gtest-port.cc
#elif GTEST_OS_QNX
// Returns the number of threads running in the process, or 0 to indicate that
-Index: src/gtest.cc
-===================================================================
---- src/gtest.cc (revision 692)
-+++ src/gtest.cc (working copy)
-@@ -126,7 +126,7 @@
+--- src/gtest.cc.orig 2016-11-03 20:36:28 UTC
++++ src/gtest.cc
+@@ -127,7 +127,7 @@
#endif
#if GTEST_CAN_STREAM_RESULTS_
-# include <arpa/inet.h> // NOLINT
-+# include <sys/socket.h>
++# include <sys/socket.h> // NOLINT
# include <netdb.h> // NOLINT
- #endif
-
-Index: test/gtest-port_test.cc
-===================================================================
---- test/gtest-port_test.cc (revision 692)
-+++ test/gtest-port_test.cc (working copy)
-@@ -304,7 +304,8 @@ TEST(FormatCompilerIndependentFileLocationTest, Fo
+ # include <sys/socket.h> // NOLINT
+ # include <sys/types.h> // NOLINT
+--- test/gtest-port_test.cc.orig 2016-11-03 20:36:28 UTC
++++ test/gtest-port_test.cc
+@@ -304,7 +304,8 @@ TEST(FormatCompilerIndependentFileLocati
EXPECT_EQ("unknown file", FormatCompilerIndependentFileLocation(NULL, -1));
}
--#if GTEST_OS_MAC || GTEST_OS_QNX
-+#if GTEST_OS_MAC || GTEST_OS_QNX || GTEST_OS_DRAGONFLY || GTEST_OS_FREEBSD || \
-+ GTEST_OS_GNU_KFREEBSD || GTEST_OS_NETBSD || GTEST_OS_OPENBSD
+-#if GTEST_OS_LINUX || GTEST_OS_MAC || GTEST_OS_QNX
++#if GTEST_OS_LINUX || GTEST_OS_MAC || GTEST_OS_QNX || GTEST_OS_DRAGONFLY || \
++ GTEST_OS_FREEBSD || GTEST_OS_GNU_KFREEBSD || GTEST_OS_NETBSD || GTEST_OS_OPENBSD
void* ThreadFunc(void* data) {
- pthread_mutex_t* mutex = static_cast<pthread_mutex_t*>(data);
- pthread_mutex_lock(mutex);
-@@ -355,7 +356,7 @@ TEST(GetThreadCountTest, ReturnsCorrectValue) {
- TEST(GetThreadCountTest, ReturnsZeroWhenUnableToCountThreads) {
- EXPECT_EQ(0U, GetThreadCount());
- }
--#endif // GTEST_OS_MAC || GTEST_OS_QNX
-+#endif // GTEST_OS_MAC || GTEST_OS_QNX || GTEST_OS_*BSD
-
- TEST(GtestCheckDeathTest, DiesWithCorrectOutputOnFailure) {
- const bool a_false_condition = false;
-Index: test/gtest_unittest.cc
-===================================================================
---- test/gtest_unittest.cc (revision 692)
-+++ test/gtest_unittest.cc (working copy)
-@@ -117,6 +117,7 @@ TEST_F(StreamingListenerTest, OnTestIterationEnd)
+ internal::Mutex* mutex = static_cast<internal::Mutex*>(data);
+ mutex->Lock();
+--- test/gtest_unittest.cc.orig 2016-11-03 20:36:28 UTC
++++ test/gtest_unittest.cc
+@@ -118,6 +118,7 @@ TEST_F(StreamingListenerTest, OnTestIter
EXPECT_EQ("event=TestIterationEnd&passed=1&elapsed_time=0ms\n", *output());
}
@@ -205,7 +200,7 @@ Index: test/gtest_unittest.cc
TEST_F(StreamingListenerTest, OnTestCaseStart) {
*output() = "";
streamer_.OnTestCaseStart(TestCase("FooTest", "Bar", NULL, NULL));
-@@ -128,6 +129,7 @@ TEST_F(StreamingListenerTest, OnTestCaseEnd) {
+@@ -129,6 +130,7 @@ TEST_F(StreamingListenerTest, OnTestCase
streamer_.OnTestCaseEnd(TestCase("FooTest", "Bar", NULL, NULL));
EXPECT_EQ("event=TestCaseEnd&passed=1&elapsed_time=0ms\n", *output());
}
diff --git a/devel/googletest/pkg-plist b/devel/googletest/pkg-plist
index 5f059b780dda..72761e87c221 100644
--- a/devel/googletest/pkg-plist
+++ b/devel/googletest/pkg-plist
@@ -9,12 +9,16 @@ include/gtest/gtest-typed-test.h
include/gtest/gtest.h
include/gtest/gtest_pred_impl.h
include/gtest/gtest_prod.h
+include/gtest/internal/custom/gtest-port.h
+include/gtest/internal/custom/gtest-printers.h
+include/gtest/internal/custom/gtest.h
include/gtest/internal/gtest-death-test-internal.h
include/gtest/internal/gtest-filepath.h
include/gtest/internal/gtest-internal.h
include/gtest/internal/gtest-linked_ptr.h
include/gtest/internal/gtest-param-util-generated.h
include/gtest/internal/gtest-param-util.h
+include/gtest/internal/gtest-port-arch.h
include/gtest/internal/gtest-port.h
include/gtest/internal/gtest-string.h
include/gtest/internal/gtest-tuple.h
diff --git a/science/orthanc-dicomweb/Makefile b/science/orthanc-dicomweb/Makefile
index a766c5201f6e..ebdf663ced25 100644
--- a/science/orthanc-dicomweb/Makefile
+++ b/science/orthanc-dicomweb/Makefile
@@ -3,6 +3,7 @@
PORTNAME= orthanc-dicomweb
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= science net
MASTER_SITES= http://orthanc-server.com/downloads/get.php?path=/plugin-dicom-web/
DISTNAME= OrthancDicomWeb-${PORTVERSION}
diff --git a/science/orthanc-webviewer/Makefile b/science/orthanc-webviewer/Makefile
index 559d912b2280..06bf6a168d3c 100644
--- a/science/orthanc-webviewer/Makefile
+++ b/science/orthanc-webviewer/Makefile
@@ -3,6 +3,7 @@
PORTNAME= orthanc-webviewer
PORTVERSION= 2.2
+PORTREVISION= 1
CATEGORIES= science graphics
MASTER_SITES= http://orthanc-server.com/downloads/get.php?path=/plugin-webviewer/:main \
http://www.montefiore.ulg.ac.be/~jodogne/Orthanc/ThirdPartyDownloads/WebViewer/:thirdparty
diff --git a/science/orthanc/Makefile b/science/orthanc/Makefile
index c2ef110d07d0..a61fd4548c18 100644
--- a/science/orthanc/Makefile
+++ b/science/orthanc/Makefile
@@ -3,6 +3,7 @@
PORTNAME= orthanc
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= science graphics net www
MASTER_SITES= http://orthanc-server.com/downloads/get.php?path=/orthanc/:main \
http://www.montefiore.ulg.ac.be/~jodogne/Orthanc/ThirdPartyDownloads/:mongoose
diff --git a/security/certificate-transparency/Makefile b/security/certificate-transparency/Makefile
index a0cf39c3dac1..1bba4e187086 100644
--- a/security/certificate-transparency/Makefile
+++ b/security/certificate-transparency/Makefile
@@ -3,7 +3,7 @@
PORTNAME= certificate-transparency
PORTVERSION= 20161015
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security
MAINTAINER= ports@FreeBSD.org