aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordirk <dirk@FreeBSD.org>2001-01-21 22:22:06 +0800
committerdirk <dirk@FreeBSD.org>2001-01-21 22:22:06 +0800
commit1bffe4be2caf84d48bab38544367d26fa33078fc (patch)
treefaaccdd92f36d12493621fc621c38cc7ee401a02
parenta9463108ede34c0d41ca173c96c757b776135965 (diff)
downloadfreebsd-ports-gnome-1bffe4be2caf84d48bab38544367d26fa33078fc.tar.gz
freebsd-ports-gnome-1bffe4be2caf84d48bab38544367d26fa33078fc.tar.zst
freebsd-ports-gnome-1bffe4be2caf84d48bab38544367d26fa33078fc.zip
Remove automatic finding of AP_LIBEXEC because it didn't work and
all apache ports use the same libexec location, now. Submitted by: Michael Lestinsky <michael@choin.net>
-rw-r--r--www/mod_php3/Makefile8
-rw-r--r--www/mod_php4/Makefile8
-rw-r--r--www/mod_php5/Makefile8
3 files changed, 3 insertions, 21 deletions
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index ad2bd50f6f48..0d6eefc08358 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -27,10 +27,8 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
PHP_DISTDIR= distributions
-APXS= ${PREFIX}/sbin/apxs
-
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-apxs=${APXS} \
+CONFIGURE_ARGS= --with-apxs=${PREFIX}/sbin/apxs \
--enable-versioning \
--with-system-regex \
--with-config-file-path=${PREFIX}/etc \
@@ -42,11 +40,7 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
TOUCH="${TOUCH}" \
MKDIR="${MKDIR}"
-.if exists(${APXS})
-AP_LIBEXEC!= ${APXS} -q LIBEXEC
-.else
AP_LIBEXEC= ${PREFIX}/libexec/apache
-.endif
PHPDOCDIR= ${PREFIX}/share/doc/php3
PLIST_SUB= PHPDOCDIR=${PHPDOCDIR:S/^${PREFIX}\///} \
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index f897c201e3d0..e1a490b4158f 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -26,10 +26,8 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
PHP_DISTDIR= distributions
-APXS= ${PREFIX}/sbin/apxs
-
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --with-apxs=${APXS} \
+CONFIGURE_ARGS= --with-apxs=${PREFIX}/sbin/apxs \
--enable-versioning \
--with-system-regex \
--with-config-file-path=${PREFIX}/etc \
@@ -44,11 +42,7 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
MKDIR="${MKDIR}" \
CAT="${CAT}"
-.if exists(${APXS})
-AP_LIBEXEC!= ${APXS} -q LIBEXEC
-.else
AP_LIBEXEC= ${PREFIX}/libexec/apache
-.endif
PHPDOCDIR= ${PREFIX}/share/doc/php
PLIST_SUB= PHPDOCDIR=${PHPDOCDIR:S/^${PREFIX}\///} \
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index f897c201e3d0..e1a490b4158f 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -26,10 +26,8 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
PHP_DISTDIR= distributions
-APXS= ${PREFIX}/sbin/apxs
-
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --with-apxs=${APXS} \
+CONFIGURE_ARGS= --with-apxs=${PREFIX}/sbin/apxs \
--enable-versioning \
--with-system-regex \
--with-config-file-path=${PREFIX}/etc \
@@ -44,11 +42,7 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
MKDIR="${MKDIR}" \
CAT="${CAT}"
-.if exists(${APXS})
-AP_LIBEXEC!= ${APXS} -q LIBEXEC
-.else
AP_LIBEXEC= ${PREFIX}/libexec/apache
-.endif
PHPDOCDIR= ${PREFIX}/share/doc/php
PLIST_SUB= PHPDOCDIR=${PHPDOCDIR:S/^${PREFIX}\///} \