aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-05-31 10:29:58 +0800
committerknu <knu@FreeBSD.org>2001-05-31 10:29:58 +0800
commit1c08de30eed394fb97054e2f22f8aced8b8cda65 (patch)
tree8e58190a0019d1ae6aea7894648ca9c24c393cbc
parentec3c97c3470c733d880c60b8d80d33c6a5200210 (diff)
downloadfreebsd-ports-gnome-1c08de30eed394fb97054e2f22f8aced8b8cda65.tar.gz
freebsd-ports-gnome-1c08de30eed394fb97054e2f22f8aced8b8cda65.tar.zst
freebsd-ports-gnome-1c08de30eed394fb97054e2f22f8aced8b8cda65.zip
Add a patch to unbreak the build. (already submitted to the vim6 author)
Reported by: Ollivier Robert <roberto@eurocontrol.fr>
-rw-r--r--editors/vim6+ruby/Makefile2
-rw-r--r--editors/vim6+ruby/files/patch-configure22
2 files changed, 24 insertions, 0 deletions
diff --git a/editors/vim6+ruby/Makefile b/editors/vim6+ruby/Makefile
index 84df3f38b4b3..d10190050267 100644
--- a/editors/vim6+ruby/Makefile
+++ b/editors/vim6+ruby/Makefile
@@ -16,6 +16,8 @@ MAINTAINER= knu@FreeBSD.org
COMMENT= ${.CURDIR}/pkg-comment
+EXTRA_PATCHES= ${.CURDIR}/files/patch-*
+
USE_RUBY= yes
MAKE_ARGS= CONF_OPT_RUBY="--enable-rubyinterp" RUBY="${RUBY}"
diff --git a/editors/vim6+ruby/files/patch-configure b/editors/vim6+ruby/files/patch-configure
new file mode 100644
index 000000000000..1a14d3c871b6
--- /dev/null
+++ b/editors/vim6+ruby/files/patch-configure
@@ -0,0 +1,22 @@
+--- configure.in.orig Fri May 4 19:00:29 2001
++++ configure.in Thu May 31 02:01:12 2001
+@@ -460,7 +460,7 @@
+ AC_MSG_CHECKING(Ruby version)
+ if $vi_cv_path_ruby -e 'VERSION >= "1.6.0" or exit 1' >/dev/null 2>/dev/null; then
+ AC_MSG_RESULT(OK)
+- rubyhdrdir=`$vi_cv_path_ruby -r mkmf -e 'print $hdrdir'`
++ rubyhdrdir=`$vi_cv_path_ruby -r rbconfig -e 'print Config::CONFIG[["archdir"]]'`
+ RUBY_CFLAGS="-I$rubyhdrdir"
+ rubylibs=`$vi_cv_path_ruby -r rbconfig -e 'print Config::CONFIG[["LIBS"]]'`
+ if test "X$rubylibs" != "X"; then
+--- auto/configure.orig Fri May 4 19:50:56 2001
++++ auto/configure Thu May 31 03:55:33 2001
+@@ -1789,7 +1789,7 @@
+ echo "configure:1790: checking Ruby version" >&5
+ if $vi_cv_path_ruby -e 'VERSION >= "1.6.0" or exit 1' >/dev/null 2>/dev/null; then
+ echo "$ac_t""OK" 1>&6
+- rubyhdrdir=`$vi_cv_path_ruby -r mkmf -e 'print $hdrdir'`
++ rubyhdrdir=`$vi_cv_path_ruby -r rbconfig -e 'print Config::CONFIG["archdir"]'`
+ RUBY_CFLAGS="-I$rubyhdrdir"
+ rubylibs=`$vi_cv_path_ruby -r rbconfig -e 'print Config::CONFIG["LIBS"]'`
+ if test "X$rubylibs" != "X"; then