aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2004-12-27 22:33:19 +0800
committerroam <roam@FreeBSD.org>2004-12-27 22:33:19 +0800
commit1c85679ec16da6315c3604a6846dc9bbc845911d (patch)
treeb58d361b833240d2582a6f54f6da938b5aa27b82
parentefebddf6611c6e1f1e1c340f6cd99a4704aa25a0 (diff)
downloadfreebsd-ports-gnome-1c85679ec16da6315c3604a6846dc9bbc845911d.tar.gz
freebsd-ports-gnome-1c85679ec16da6315c3604a6846dc9bbc845911d.tar.zst
freebsd-ports-gnome-1c85679ec16da6315c3604a6846dc9bbc845911d.zip
Update to stunnel-4.06. In addition to the PR:
- enable the new IPv6 functionality when WITH_IPV6 is defined; - at last move over to libtool-1.5 and get rid of the .la file; - update the WITH_STUNNEL_SSL_ENGINE message to also mention FreeBSD 6.x; - remove the obsolete sock_ioctlsocket() definition from patch-aa; - fix a couple of getnameinfo(3)-related buglets; - fix a poll(2)-related buglet: it seems FreeBSD insists (correctly) that INFTIM passed to poll(2) should be -1, not just any negative value. PR: 75519 (somewhat) Submitted by: Dan Langille <dan@langille.org>
-rw-r--r--security/stunnel/Makefile11
-rw-r--r--security/stunnel/distinfo4
-rw-r--r--security/stunnel/files/patch-Makefile.in20
-rw-r--r--security/stunnel/files/patch-aa10
-rw-r--r--security/stunnel/files/patch-src::network.c39
-rw-r--r--security/stunnel/files/ssl-noengine.patch18
-rw-r--r--security/stunnel/pkg-plist2
7 files changed, 68 insertions, 36 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index 0db9946c0da3..c11091df467b 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= stunnel
-PORTVERSION= 4.05
-PORTREVISION= 1
+PORTVERSION= 4.06
CATEGORIES= security
MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
ftp://stunnel.mirt.net/stunnel/OBSOLETE/ \
@@ -18,7 +17,7 @@ COMMENT= SSL encryption wrapper for standard network daemons
USE_OPENSSL= YES
USE_REINPLACE= YES
-USE_INC_LIBTOOL_VER= 13
+USE_LIBTOOL_VER= 15
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -31,6 +30,10 @@ MAN8= stunnel.8 stunnel.fr.8 stunnel.pl.8
PEM_DIR?= ${PREFIX}/etc
+.if defined(WITH_IPV6)
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
post-patch:
# place files under /var/tmp so that this can be run by an unprivileged user
# user stunnel and group stunnel
@@ -76,7 +79,7 @@ EXTRA_PATCHES= ${FILESDIR}/ssl-noengine.patch
pre-patch:
@${ECHO} "*************************************************************************"
@${ECHO} "Note: you have to explicitly define WITH_STUNNEL_SSL_ENGINE to activate"
- @${ECHO} "the OpenSSL ENGINE code on FreeBSD 5.x."
+ @${ECHO} "the OpenSSL ENGINE code on FreeBSD 5.x or 6.x."
@${ECHO} "There are known reliability issues with stunnel and the OpenSSL ENGINE"
@${ECHO} "code, so you are advised not to enable it."
@${ECHO} "*************************************************************************"
diff --git a/security/stunnel/distinfo b/security/stunnel/distinfo
index 6e8663323626..19053f47a817 100644
--- a/security/stunnel/distinfo
+++ b/security/stunnel/distinfo
@@ -1,2 +1,2 @@
-MD5 (stunnel-4.05.tar.gz) = e28a03cf694a43a7f144ec3d5c064456
-SIZE (stunnel-4.05.tar.gz) = 341191
+MD5 (stunnel-4.06.tar.gz) = bac37fe3ecb61a0481188694e0823220
+SIZE (stunnel-4.06.tar.gz) = 484200
diff --git a/security/stunnel/files/patch-Makefile.in b/security/stunnel/files/patch-Makefile.in
index c51a82757401..ecf842d628d1 100644
--- a/security/stunnel/files/patch-Makefile.in
+++ b/security/stunnel/files/patch-Makefile.in
@@ -1,19 +1,19 @@
---- tools/Makefile.in.orig Fri Aug 30 19:59:52 2002
-+++ tools/Makefile.in Sun Oct 27 16:59:27 2002
-@@ -83,7 +83,7 @@
-
+--- tools/Makefile.in.orig Mon Dec 27 13:52:12 2004
++++ tools/Makefile.in Mon Dec 27 13:52:25 2004
+@@ -163,7 +163,7 @@
+ stunnel.spec stunnel.mak stunnel.cnf
confdir = $(sysconfdir)/stunnel
-conf_DATA = stunnel.conf-sample stunnel.pem
+conf_DATA = stunnel.conf-sample
-
docdir = $(datadir)/doc/stunnel
examplesdir = $(docdir)/examples
-@@ -186,7 +186,6 @@
-
- install-data-am: install-confDATA install-examplesDATA
+ examples_DATA = ca.html ca.pl importCA.html importCA.sh script.sh \
+@@ -337,7 +337,6 @@
+ install-data-am: install-confDATA install-data-local \
+ install-examplesDATA
@$(NORMAL_INSTALL)
- $(MAKE) $(AM_MAKEFLAGS) install-data-hook
- install-data: install-data-am
- install-am: all-am
+ install-exec-am:
+
diff --git a/security/stunnel/files/patch-aa b/security/stunnel/files/patch-aa
deleted file mode 100644
index 4040d81f01a8..000000000000
--- a/security/stunnel/files/patch-aa
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/common.h.orig Sat Aug 31 08:16:32 2002
-+++ src/common.h Sat Aug 31 08:16:35 2002
-@@ -140,6 +140,7 @@
- #define writesocket(s,b,n) write((s),(b),(n))
- #define closesocket(s) close(s)
- #define ioctlsocket(a,b,c) ioctl((a),(b),(c))
-+#define sock_ioctlsocket(a,b,c) ioctl((a),(b),(c))
-
- /* Unix-specific headers */
- #include <syslog.h>
diff --git a/security/stunnel/files/patch-src::network.c b/security/stunnel/files/patch-src::network.c
new file mode 100644
index 000000000000..eac8748a1206
--- /dev/null
+++ b/security/stunnel/files/patch-src::network.c
@@ -0,0 +1,39 @@
+--- src/network.c.orig Mon Dec 27 15:30:04 2004
++++ src/network.c Mon Dec 27 15:30:07 2004
+@@ -125,7 +125,7 @@
+ int retval;
+
+ do { /* skip "Interrupted system call" errors */
+- retval=poll(fds->ufds, fds->nfds, 1000*timeout);
++ retval=poll(fds->ufds, fds->nfds, timeout < 0? INFTIM: 1000*timeout);
+ /* no timeout -> main loop */
+ if(timeout<0 && retval>0 && s_poll_canread(fds, signal_pipe[0]))
+ signal_pipe_empty();
+@@ -416,8 +416,10 @@
+ return "Temporary failure in name resolution (EAI_AGAIN)";
+ case EAI_FAIL:
+ return "Non-recoverable failure in name resolution (EAI_FAIL)";
++#ifdef EAI_NODATA
+ case EAI_NODATA:
+ return "No address associated with nodename (EAI_NODATA)";
++#endif
+ case EAI_FAMILY:
+ return "ai_family not supported (EAI_FAMILY)";
+ case EAI_SOCKTYPE:
+@@ -562,10 +564,13 @@
+ /* getnameinfo() version */
+ char *s_ntop(char *text, SOCKADDR_UNION *addr) {
+ char host[20], port[6];
++ int err;
+
+- if(getnameinfo(&addr->sa, addr_len(*addr),
+- host, 20, port, 6, NI_NUMERICHOST|NI_NUMERICSERV)) {
+- sockerror("getnameinfo");
++ err = getnameinfo(&addr->sa, addr_len(*addr),
++ host, 20, port, 6, NI_NUMERICHOST|NI_NUMERICSERV);
++ if (err) {
++ s_log(LOG_ERR, "Error resolving the specified address: %s",
++ s_gai_strerror(err));
+ strcpy(text, "unresolvable IP");
+ return text;
+ }
diff --git a/security/stunnel/files/ssl-noengine.patch b/security/stunnel/files/ssl-noengine.patch
index e2a444b12ef0..13fda4281e24 100644
--- a/security/stunnel/files/ssl-noengine.patch
+++ b/security/stunnel/files/ssl-noengine.patch
@@ -1,11 +1,11 @@
---- src/ssl.c.orig Thu Sep 2 18:02:59 2004
-+++ src/ssl.c Thu Sep 2 18:03:26 2004
-@@ -70,7 +70,7 @@
- void context_init(void) { /* init SSL */
- int i;
+--- src/ssl.c.orig Mon Dec 27 13:47:16 2004
++++ src/ssl.c Mon Dec 27 13:50:36 2004
+@@ -116,6 +116,8 @@
+ static void init_engine(void) {
+ ENGINE *e;
--#if SSLEAY_VERSION_NUMBER >= 0x00907000L
-+#if 0
- /* Load all bundled ENGINEs into memory and make them visible */
++ s_log(LOG_ERR, "This version of stunnel was compiled WITHOUT support for OpenSSL hardware engines! If you need this functionality, rebuild the FreeBSD port with the WITH_STUNNEL_SSL_ENGINE option set to 'yes'; contact Peter Pentchev <roam@FreeBSD.org> for details.");
++ exit(1);
ENGINE_load_builtin_engines();
- /* Register all of them for every algorithm they collectively implement */
+ if(!strcasecmp(options.engine, "auto")) {
+ s_log(LOG_DEBUG, "Enabling auto engine support");
diff --git a/security/stunnel/pkg-plist b/security/stunnel/pkg-plist
index d8a231043626..dc1e0639b529 100644
--- a/security/stunnel/pkg-plist
+++ b/security/stunnel/pkg-plist
@@ -1,9 +1,9 @@
etc/rc.d/stunnel.sh.sample
etc/stunnel/stunnel.conf-sample
lib/libstunnel.so
-lib/libstunnel.la
lib/libstunnel.a
sbin/stunnel
+sbin/stunnel3
%%PORTDOCS%%%%DOCSDIR%%/stunnel.html
%%PORTDOCS%%%%DOCSDIR%%/stunnel.fr.html
%%PORTDOCS%%%%DOCSDIR%%/stunnel.pl.html