aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2011-07-01 09:19:27 +0800
committermandree <mandree@FreeBSD.org>2011-07-01 09:19:27 +0800
commit1cb0274ec0ec8633051fc8366b260759172ef08e (patch)
tree2714c45de45db34e853b790f56e92b5873cdfa03
parent52981b6ee33668543414b6a5a854462a5bb97d68 (diff)
downloadfreebsd-ports-gnome-1cb0274ec0ec8633051fc8366b260759172ef08e.tar.gz
freebsd-ports-gnome-1cb0274ec0ec8633051fc8366b260759172ef08e.tar.zst
freebsd-ports-gnome-1cb0274ec0ec8633051fc8366b260759172ef08e.zip
clang-with-ports fix: Declare USE_CSTD=gnu89.
Split out CPPFLAGS from CONFIGURE_ENV.
-rw-r--r--net/librsync/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/librsync/Makefile b/net/librsync/Makefile
index ea34d384df95..933708506f00 100644
--- a/net/librsync/Makefile
+++ b/net/librsync/Makefile
@@ -19,9 +19,10 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_AUTOTOOLS= libtool
USE_GMAKE= yes
+USE_CSTD= gnu89
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --enable-shared --disable-trace
USE_LDCONFIG= yes