aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2017-01-02 22:53:15 +0800
committerhrs <hrs@FreeBSD.org>2017-01-02 22:53:15 +0800
commit1d250296622618abc1b81d32381c37c27421fa27 (patch)
treebbdc579fa3fa841992ef23641dd593d12f40ce51
parente512d4d39c7acf50c62bb0dfa2789821ea6b610b (diff)
downloadfreebsd-ports-gnome-1d250296622618abc1b81d32381c37c27421fa27.tar.gz
freebsd-ports-gnome-1d250296622618abc1b81d32381c37c27421fa27.tar.zst
freebsd-ports-gnome-1d250296622618abc1b81d32381c37c27421fa27.zip
Update to 3.9.8.
-rw-r--r--net/mrouted/Makefile6
-rw-r--r--net/mrouted/distinfo5
-rw-r--r--net/mrouted/files/patch-Makefile8
-rw-r--r--net/mrouted/files/patch-mtrace.c24
4 files changed, 10 insertions, 33 deletions
diff --git a/net/mrouted/Makefile b/net/mrouted/Makefile
index 5c14b917eed4..b9bd0e637d73 100644
--- a/net/mrouted/Makefile
+++ b/net/mrouted/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= mrouted
-PORTVERSION= 3.9.7
-PORTREVISION= 1
+PORTVERSION= 3.9.8
CATEGORIES= net
MAINTAINER= hrs@FreeBSD.org
@@ -13,8 +12,8 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
-USE_RC_SUBR= mrouted
GH_ACCOUNT= troglobit
+USE_RC_SUBR= mrouted
HAS_CONFIGURE= yes
MAKE_ARGS= sysconfdir="${PREFIX}/etc" \
mandir="${MAN8PREFIX}/man/man8"
@@ -23,6 +22,7 @@ PLIST_FILES= sbin/map-mbone sbin/mrouted sbin/mrinfo sbin/mtrace \
etc/mrouted.conf man/man8/map-mbone.8.gz \
man/man8/mrinfo.8.gz man/man8/mrouted.8.gz \
man/man8/mtrace.8.gz
+
OPTIONS_DEFINE= DOCS
DOCS_MAKE_ARGS= datadir="${DOCSDIR}" doc=yes
diff --git a/net/mrouted/distinfo b/net/mrouted/distinfo
index 427a44e86896..c8923e933e1a 100644
--- a/net/mrouted/distinfo
+++ b/net/mrouted/distinfo
@@ -1,2 +1,3 @@
-SHA256 (troglobit-mrouted-3.9.7_GH0.tar.gz) = 181908f7025c5a2dee2e50d86888780469eaa9e1bd42d3eca9dfed8274aecd3d
-SIZE (troglobit-mrouted-3.9.7_GH0.tar.gz) = 142560
+TIMESTAMP = 1483368179
+SHA256 (troglobit-mrouted-3.9.8_GH0.tar.gz) = 179636d211a82d0140a3488c6b65e634b4838da23e50d8cdee15ef03fe9b46af
+SIZE (troglobit-mrouted-3.9.8_GH0.tar.gz) = 143529
diff --git a/net/mrouted/files/patch-Makefile b/net/mrouted/files/patch-Makefile
index 944fe567a3cc..3a1e221e158c 100644
--- a/net/mrouted/files/patch-Makefile
+++ b/net/mrouted/files/patch-Makefile
@@ -1,4 +1,4 @@
---- Makefile.orig 2014-12-28 14:23:52 UTC
+--- Makefile.orig 2017-01-01 19:28:19 UTC
+++ Makefile
@@ -16,8 +16,8 @@ CC ?= $(CROSS)gcc
@@ -15,8 +15,8 @@
## Common
CFLAGS += $(MCAST_INCLUDE) $(INCLUDES) $(DEFS) $(USERCOMPILE)
--CFLAGS += -O2 -W -Wall -Werror
-+#CFLAGS += -O2 -W -Wall -Werror
+-CFLAGS += -O2 -W -Wall -Wextra
++#CFLAGS += -O2 -W -Wall -Wextra
#CFLAGS += -O -g
LDLIBS = $(EXTRA_LIBS)
LDFLAGS += -Wl,-Map,$@.map
@@ -25,7 +25,7 @@
SRCS = $(OBJS:.o=.c)
-MANS = $(addsuffix .8,$(EXECS))
-DISTFILES = README AUTHORS LICENSE ChangeLog
-+MANS = ${EXECS:S/$/.8/}
++MANS = $(EXECS:S/$/.8/)
+DISTFILES = README AUTHORS ChangeLog
LINT = splint
diff --git a/net/mrouted/files/patch-mtrace.c b/net/mrouted/files/patch-mtrace.c
deleted file mode 100644
index 0dd7e2d78b1c..000000000000
--- a/net/mrouted/files/patch-mtrace.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- mtrace.c.orig 2014-12-28 14:23:52 UTC
-+++ mtrace.c
-@@ -903,6 +903,12 @@ void stat_line(struct tr_resp *r, struct
- }
- }
-
-+static uint32_t
-+udiff(uint32_t u, uint32_t v)
-+{
-+ return (u >= v ? u - v : v - u);
-+}
-+
- /*
- * A fixup to check if any pktcnt has been reset, and to fix the
- * byteorder bugs in mrouted 3.6 on little-endian machines.
-@@ -920,7 +926,7 @@ void fixup_stats(struct resp_buf *base,
- /* Check for byte-swappers */
- while (--rno >= 0) {
- --n; --p; --b; --s;
-- if (*s || abs(ntohl(n->tr_vifout) - ntohl(p->tr_vifout)) > 100000) {
-+ if (*s || udiff(ntohl(n->tr_vifout), ntohl(p->tr_vifout)) > 100000) {
- /* This host sends byteswapped reports; swap 'em */
- if (!*s) {
- *s = 1;