aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-04-30 09:57:58 +0800
committerwen <wen@FreeBSD.org>2010-04-30 09:57:58 +0800
commit1d48a02c63a9f2084f93dd1ce52b3b9a8b9b71d4 (patch)
treefcce1d03b07e89946b2d3fc1a705727617574de1
parent15e377ec823c859cad1a7759a8d371829b484f81 (diff)
downloadfreebsd-ports-gnome-1d48a02c63a9f2084f93dd1ce52b3b9a8b9b71d4.tar.gz
freebsd-ports-gnome-1d48a02c63a9f2084f93dd1ce52b3b9a8b9b71d4.tar.zst
freebsd-ports-gnome-1d48a02c63a9f2084f93dd1ce52b3b9a8b9b71d4.zip
CPAN::Meta - The distribution metadata for a CPAN dist
Software distributions released to the CPAN include a META.json or, for older distributions, META.yml, which describes the distribution, its contents, and the requirements for building and installing the distribution. The data structure stored in the META.json file is described in CPAN::Meta::Spec. CPAN::Meta provides a simple class to represent this distribution metadata (or distmeta), along with some helpful methods for interrogating that data. WWW: http://search.cpan.org/dist/CPAN-Meta/ PR: ports/145882 Submitted by: Ju Pengfei <jupengfei@gmail.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-CPAN-Meta/Makefile34
-rw-r--r--devel/p5-CPAN-Meta/distinfo3
-rw-r--r--devel/p5-CPAN-Meta/pkg-descr11
-rw-r--r--devel/p5-CPAN-Meta/pkg-plist13
5 files changed, 62 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a3e16321a59d..0a3576465d73 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1140,6 +1140,7 @@
SUBDIR += p5-CPAN-Checksums
SUBDIR += p5-CPAN-DistnameInfo
SUBDIR += p5-CPAN-Inject
+ SUBDIR += p5-CPAN-Meta
SUBDIR += p5-CPAN-Mini
SUBDIR += p5-CPAN-SQLite
SUBDIR += p5-CPAN-YACSmoke
diff --git a/devel/p5-CPAN-Meta/Makefile b/devel/p5-CPAN-Meta/Makefile
new file mode 100644
index 000000000000..dbb2a15b5a9e
--- /dev/null
+++ b/devel/p5-CPAN-Meta/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-CPAN-Meta
+# Date created: April 20 2010
+# Whom: jupengfei <jupengfei@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CPAN-Meta
+PORTVERSION= 2.101091
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jupengfei@gmail.com
+COMMENT= The distribution metadata for a CPAN dist
+
+BUILD_DEPENDS= p5-autodie>0:${PORTSDIR}/devel/p5-autodie \
+ p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-Parse-CPAN-Meta>0:${PORTSDIR}/devel/p5-Parse-CPAN-Meta \
+ p5-Test-Simple>0:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Version-Requirements>0:${PORTSDIR}/devel/p5-Version-Requirements
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= CPAN::Meta.3 \
+ CPAN::Meta::Converter.3 \
+ CPAN::Meta::Feature.3 \
+ CPAN::Meta::History.3 \
+ CPAN::Meta::Prereqs.3 \
+ CPAN::Meta::Spec.3 \
+ CPAN::Meta::Validator.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-CPAN-Meta/distinfo b/devel/p5-CPAN-Meta/distinfo
new file mode 100644
index 000000000000..79818e989a57
--- /dev/null
+++ b/devel/p5-CPAN-Meta/distinfo
@@ -0,0 +1,3 @@
+MD5 (CPAN-Meta-2.101091.tar.gz) = 555295c96c539411da2682043b4b18b8
+SHA256 (CPAN-Meta-2.101091.tar.gz) = 43d1c654f238165187e7769b26e324a1b70cbfc4675b70ebb229e46bd3be2185
+SIZE (CPAN-Meta-2.101091.tar.gz) = 51336
diff --git a/devel/p5-CPAN-Meta/pkg-descr b/devel/p5-CPAN-Meta/pkg-descr
new file mode 100644
index 000000000000..a5f67670b057
--- /dev/null
+++ b/devel/p5-CPAN-Meta/pkg-descr
@@ -0,0 +1,11 @@
+Software distributions released to the CPAN include a META.json or,
+for older distributions, META.yml, which describes the distribution,
+its contents, and the requirements for building and installing the
+distribution. The data structure stored in the META.json file is
+described in CPAN::Meta::Spec.
+
+CPAN::Meta provides a simple class to represent this distribution
+metadata (or distmeta), along with some helpful methods for
+interrogating that data.
+
+WWW: http://search.cpan.org/dist/CPAN-Meta/
diff --git a/devel/p5-CPAN-Meta/pkg-plist b/devel/p5-CPAN-Meta/pkg-plist
new file mode 100644
index 000000000000..b9610dc3b112
--- /dev/null
+++ b/devel/p5-CPAN-Meta/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/CPAN/Meta.pm
+%%SITE_PERL%%/CPAN/Meta/Converter.pm
+%%SITE_PERL%%/CPAN/Meta/Feature.pm
+%%SITE_PERL%%/CPAN/Meta/History.pm
+%%SITE_PERL%%/CPAN/Meta/Prereqs.pm
+%%SITE_PERL%%/CPAN/Meta/Spec.pm
+%%SITE_PERL%%/CPAN/Meta/Validator.pm
+%%SITE_PERL%%/mach/auto/CPAN/Meta/.packlist
+
+@dirrm %%SITE_PERL%%/CPAN/Meta
+@dirrmtry %%SITE_PERL%%/CPAN
+@dirrm %%SITE_PERL%%/mach/auto/CPAN/Meta
+@dirrmtry %%SITE_PERL%%/mach/auto/CPAN