aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2018-05-22 00:02:09 +0800
committermiwi <miwi@FreeBSD.org>2018-05-22 00:02:09 +0800
commit1d5428ee3e48226f0b5927970452a0938f0c3a70 (patch)
treeda0d5fd55f4bc326ee0928ff6860b3691d221b34
parentdb62f3f2ffe17edbebd49fae1bb138dbfd524174 (diff)
downloadfreebsd-ports-gnome-1d5428ee3e48226f0b5927970452a0938f0c3a70.tar.gz
freebsd-ports-gnome-1d5428ee3e48226f0b5927970452a0938f0c3a70.tar.zst
freebsd-ports-gnome-1d5428ee3e48226f0b5927970452a0938f0c3a70.zip
- Update to 1.3.2
PR: 228136 Submitted by: freebsd_ports@k-worx.org Approved by: maintainer Sponsored by: iXsystems Inc.
-rw-r--r--www/py-django-filer/Makefile16
-rw-r--r--www/py-django-filer/distinfo5
-rw-r--r--www/py-django-filer/pkg-descr1
-rw-r--r--www/py-django-filer/pkg-message35
4 files changed, 34 insertions, 23 deletions
diff --git a/www/py-django-filer/Makefile b/www/py-django-filer/Makefile
index 1a6c1868276a..dfe7a547eda3 100644
--- a/www/py-django-filer/Makefile
+++ b/www/py-django-filer/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= django-filer
-PORTVERSION= 0.8.6
-PORTREVISION= 3
+PORTVERSION= 1.3.2
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,11 +10,18 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= xenophon+fbsdports@irtnog.org
COMMENT= File and Image Management Application for django
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django18>=0:www/py-django18@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}django-easy-thumbnails>=0:graphics/py-django-easy-thumbnails@${FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${FLAVOR}
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django111>=0:www/py-django111@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django-easy-thumbnails>=2:graphics/py-django-easy-thumbnails@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django-mptt>=0.6:www/py-django-mptt@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django_polymorphic>=0.7:www/py-django_polymorphic@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}unidecode>=0:converters/py-unidecode@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=2.3.0:graphics/py-pillow@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist distutils
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/www/py-django-filer/distinfo b/www/py-django-filer/distinfo
index a820f067eacd..533c66d6098d 100644
--- a/www/py-django-filer/distinfo
+++ b/www/py-django-filer/distinfo
@@ -1,2 +1,3 @@
-SHA256 (django-filer-0.8.6.tar.gz) = 8be32f3fd5530dbd5436ef4e46cb6da5a51f2b4fd6db3a7b880ef9246b55f103
-SIZE (django-filer-0.8.6.tar.gz) = 674775
+TIMESTAMP = 1525970787
+SHA256 (django-filer-1.3.2.tar.gz) = 192b8039d167d1fc71423f65dd0d9b67a296f4336a942dba95bcadc1fb734d81
+SIZE (django-filer-1.3.2.tar.gz) = 1267010
diff --git a/www/py-django-filer/pkg-descr b/www/py-django-filer/pkg-descr
index 52ab27f6f6d5..9db876fbb384 100644
--- a/www/py-django-filer/pkg-descr
+++ b/www/py-django-filer/pkg-descr
@@ -1,5 +1,4 @@
django-filer is a file management application for django. It handles
uploading and organizing files and images in contrib.admin.
-WWW: https://pypi.org/project/django-filer/
WWW: https://github.com/stefanfoulis/django-filer
diff --git a/www/py-django-filer/pkg-message b/www/py-django-filer/pkg-message
index 145e4126ce58..765484d2b4e1 100644
--- a/www/py-django-filer/pkg-message
+++ b/www/py-django-filer/pkg-message
@@ -1,20 +1,25 @@
-**********************************************************************
+================================================================================
-Add "filer" to your project's INSTALLED_APPS setting and run syncdb
-(or migrate if you're using South).
+Add "filer" and related apps to your INSTALLED_APPS setting and run
+manage.py migrate:
-You might consider using django-filer with the django CMS plugin and
-its components instead of cms.plugins.file, cms.plugins.picture,
-cms.plugins.teaser and cms.plugins.video core plugins. In this case
-you should not add them to INSTALLED_APPS but add those instead:
+INSTALLED_APPS = [
+ ...
+ 'easy_thumbnails',
+ 'filer',
+ 'mptt',
+ ...
+]
- 'filer'
- 'cmsplugin_filer_file'
- 'cmsplugin_filer_folder'
- 'cmsplugin_filer_image'
- 'cmsplugin_filer_teaser'
- 'cmsplugin_filer_video'
+Note that easy_thumbnails also has database tables and needs a
+manage.py migrate.
-(Note that this also requires the installation of cmsplugin-filer.)
+For easy_thumbnails to support retina displays (recent MacBooks, iOS) add to
+settings.py:
-**********************************************************************
+THUMBNAIL_HIGH_RESOLUTION = True
+
+If you forget this, you may not see thumbnails for your uploaded files. Adding
+this line and refreshing the admin page will create the missing thumbnails.
+
+================================================================================