aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2009-06-02 05:56:00 +0800
committeritetcu <itetcu@FreeBSD.org>2009-06-02 05:56:00 +0800
commit1d76824f088b60e5cd93d6e0f57e7ce8349d0a21 (patch)
tree2127f4c4c215a8639bd47c4dad8903147aad0e3b
parentc1059fc9219596923e99c623e2b2199cd60556ca (diff)
downloadfreebsd-ports-gnome-1d76824f088b60e5cd93d6e0f57e7ce8349d0a21.tar.gz
freebsd-ports-gnome-1d76824f088b60e5cd93d6e0f57e7ce8349d0a21.tar.zst
freebsd-ports-gnome-1d76824f088b60e5cd93d6e0f57e7ce8349d0a21.zip
Fix with custom LOCALBASE. Not the right way, but fixed.
Prompted by: QATty
-rw-r--r--chinese/xsim/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/chinese/xsim/Makefile b/chinese/xsim/Makefile
index 9749e2a9a751..0c37b9ae7b46 100644
--- a/chinese/xsim/Makefile
+++ b/chinese/xsim/Makefile
@@ -18,7 +18,9 @@ COMMENT= A simple and fast GBK Chinese XIM server
USE_XORG= x11
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-cn-locale=eucCN
+CONFIGURE_ARGS= --with-cn-locale=eucCN \
+ --with-bdb-includes=${BDB_INCLUDE_DIR} \
+ --with-bdb-libraries=${BDB_LIB_DIR}
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message xsim.sh
USE_BDB= 40+
@@ -40,7 +42,7 @@ post-patch:
@${FIND} ${WRKSRC} ! -type d \
-exec ${GREP} -q _CPP_BITS_IOSBASE_H '{}' \; \
-exec ${REINPLACE_CMD} 's/#ifdef _CPP_BITS_IOSBASE_H/#if defined(_IOS_BASE_H) || defined(_CPP_BITS_IOSBASE_H)/g' '{}' \;
- @${REINPLACE_CMD} "s/-O2/${CFLAGS}/g" ${WRKSRC}/configure
+ ${REINPLACE_CMD} "s/-O2/${CFLAGS}/g; s,/usr/local,${LOCALBASE},; s|s,@bdblib@,\$$bdblib,|s,@bdblib@,${BDB_LIB_CXX_NAME},|" ${WRKSRC}/configure
post-install:
${INSTALL_DATA} ${WRKDIR}/xsim.sh ${PREFIX}/bin/xsim