aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2012-10-12 06:36:17 +0800
committertota <tota@FreeBSD.org>2012-10-12 06:36:17 +0800
commit1d832e4f029442b99660d26a4508085b641944cf (patch)
tree1aa6313642f304253cb7e85c3d8234470ceca898
parent0c88d5633c19b115538a9f95f23fb885f99f6a78 (diff)
downloadfreebsd-ports-gnome-1d832e4f029442b99660d26a4508085b641944cf.tar.gz
freebsd-ports-gnome-1d832e4f029442b99660d26a4508085b641944cf.tar.zst
freebsd-ports-gnome-1d832e4f029442b99660d26a4508085b641944cf.zip
- Unbreak and mark IGNORE when RUBY_DEFAULT_VER is not 1.9
- Revive Created by line which was Whom line in Makefile header Feature safe: yes
-rw-r--r--net-im/mikutter/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-im/mikutter/Makefile b/net-im/mikutter/Makefile
index 1c9f9aa7e302..2aa8a3d7828a 100644
--- a/net-im/mikutter/Makefile
+++ b/net-im/mikutter/Makefile
@@ -1,3 +1,4 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
# $FreeBSD$
PORTNAME= mikutter
@@ -26,6 +27,7 @@ RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2 \
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_RUBY= yes
+RUBY_VER= 1.9
NO_BUILD= yes
CONFLICTS= mikutter-0.0.3.*
@@ -50,8 +52,8 @@ OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
.include <bsd.port.pre.mk>
-.if ${RUBY_VER} == 1.8
-BROKEN= does not build
+.if ${RUBY_DEFAULT_VER} != ${RUBY_VER}
+IGNORE= requires RUBY_DEFAULT_VER=${RUBY_VER}
.endif
.if ${PORT_OPTIONS:MHTTPCLIENT}