aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-28 17:53:15 +0800
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-28 17:53:15 +0800
commit1eb0bca80ec52c5b52d5051a95f00532651915e4 (patch)
treeff844ed0ad11125785c2df08fbaff093925a7d6f
parent378988c9ad0b34e0f431df6b3a2534c2df32c36a (diff)
downloadfreebsd-ports-gnome-1eb0bca80ec52c5b52d5051a95f00532651915e4.tar.gz
freebsd-ports-gnome-1eb0bca80ec52c5b52d5051a95f00532651915e4.tar.zst
freebsd-ports-gnome-1eb0bca80ec52c5b52d5051a95f00532651915e4.zip
Use PTHREAD_CFLAGS and PTHREAD_LIBS.
-rw-r--r--devel/ruby-sdl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/ruby-sdl/Makefile b/devel/ruby-sdl/Makefile
index 4f2e88e9e13c..7952500d5fe6 100644
--- a/devel/ruby-sdl/Makefile
+++ b/devel/ruby-sdl/Makefile
@@ -25,8 +25,8 @@ USE_RUBY= yes
USE_RUBY_EXTCONF= yes
CONFIGURE_ARGS= --with-sdl-config="sdl11-config" \
- --with-cflags="-pthread" \
- --with-ldflags="-lc_r"
+ --with-cflags="${PTHREAD_CFLAGS}" \
+ --with-ldflags="${PTHREAD_LIBS}"
INSTALL_TARGET= site-install
.include <bsd.port.pre.mk>