aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2009-12-02 03:23:45 +0800
committerdinoex <dinoex@FreeBSD.org>2009-12-02 03:23:45 +0800
commit1ec0effc718b23dfdb1100a0052247f97c2163ed (patch)
tree7512a08a833e7606caf483df7969c4f65bb8f7b6
parentebf629e055d6559143c28ffc83ffff9d56af1276 (diff)
downloadfreebsd-ports-gnome-1ec0effc718b23dfdb1100a0052247f97c2163ed.tar.gz
freebsd-ports-gnome-1ec0effc718b23dfdb1100a0052247f97c2163ed.tar.zst
freebsd-ports-gnome-1ec0effc718b23dfdb1100a0052247f97c2163ed.zip
- Fix build with GNUTLS
PR: 141014, 141039
-rw-r--r--print/cups-base/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 701066b8637b..60caf7b60e5b 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -8,7 +8,7 @@
PORTNAME= cups
PORTVERSION= 1.4.2
DISTVERSIONSUFFIX= -source
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= EASYSW/${PORTNAME}/${DISTVERSION}
PKGNAMESUFFIX= ${CUPS_SUFFIX}${PKGNAMESUFFIX2}
@@ -35,7 +35,8 @@ CONFIGURE_ARGS+= --localstatedir=/var \
--with-docdir=${DOCSDIR} \
--with-icondir=${PREFIX}/share/icons \
--with-menudir=${DESKTOPDIR} \
- --with-domainsocket=${CUPS_SOCKET}
+ --with-domainsocket=${CUPS_SOCKET} \
+ --enable-ssl
OPTIONS?= GNUTLS "Build with GNUTLS library" on \
PHP "Build PHP support" off \
@@ -98,8 +99,10 @@ PLIST_SUB+= OVERWRITE="@comment "
.endif
.if !defined(WITHOUT_GNUTLS)
-CONFIGURE_ARGS+= --enable-gnutls --disable-openssl
+CONFIGURE_ARGS+= --disable-openssl --enable-gnutls
+CONFIGURE_ENV+= PKGCONFIG="${LOCALBASE}/bin/pkg-config"
LIB_DEPENDS+= gnutls-openssl.40:${PORTSDIR}/security/gnutls
+BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
.else
CONFIGURE_ARGS+= --disable-gnutls --enable-openssl
.include "${PORTSDIR}/Mk/bsd.openssl.mk"