aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-08-30 11:56:36 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-08-30 11:56:36 +0800
commit1f2ceca5e55cdf3945e0ebcc8bb2080e2683bb87 (patch)
tree06ccf71278815646a20ca6853dbf82505129115b
parent6aec65beec1b826aba35625fe8b8269b31cd6c79 (diff)
downloadfreebsd-ports-gnome-1f2ceca5e55cdf3945e0ebcc8bb2080e2683bb87.tar.gz
freebsd-ports-gnome-1f2ceca5e55cdf3945e0ebcc8bb2080e2683bb87.tar.zst
freebsd-ports-gnome-1f2ceca5e55cdf3945e0ebcc8bb2080e2683bb87.zip
- Update *_DEPENDS
- Reword COMMENT - Strip shared library - Bump PORTREVISION for package change
-rw-r--r--devel/p5-Moose/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/devel/p5-Moose/Makefile b/devel/p5-Moose/Makefile
index fd946de741a8..6ac579581550 100644
--- a/devel/p5-Moose/Makefile
+++ b/devel/p5-Moose/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Moose
PORTVERSION= 2.1603
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
@@ -15,12 +16,12 @@ COMMENT= Complete modern object system for Perl 5
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-# Do not add devel/p5-Data-Visitor to TEST_DEPENDS to avoid cyclic dependency in tinderbox
+# Do not add p5-Data-Visitor to TEST_DEPENDS to avoid cyclic dependency
BUILD_DEPENDS= p5-Class-Load>=0.09:${PORTSDIR}/devel/p5-Class-Load \
p5-Class-Load-XS>=0.01:${PORTSDIR}/devel/p5-Class-Load-XS \
p5-Data-OptList>=0.107:${PORTSDIR}/devel/p5-Data-OptList \
p5-Devel-GlobalDestruction>=0:${PORTSDIR}/devel/p5-Devel-GlobalDestruction \
- p5-Devel-OverloadInfo>=0.002:${PORTSDIR}/devel/p5-Devel-OverloadInfo \
+ p5-Devel-OverloadInfo>=0.004:${PORTSDIR}/devel/p5-Devel-OverloadInfo \
p5-Devel-StackTrace>=1.33:${PORTSDIR}/devel/p5-Devel-StackTrace \
p5-Eval-Closure>=0.04:${PORTSDIR}/devel/p5-Eval-Closure \
p5-List-MoreUtils>=0.28:${PORTSDIR}/lang/p5-List-MoreUtils \
@@ -74,4 +75,7 @@ BUILD_DEPENDS+= p5-Scalar-List-Utils>=1.35:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS+= p5-Scalar-List-Utils>=1.35:${PORTSDIR}/lang/p5-Scalar-List-Utils
.endif
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Moose/Moose.so
+
.include <bsd.port.post.mk>