aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-12-15 00:38:26 +0800
committermat <mat@FreeBSD.org>2016-12-15 00:38:26 +0800
commit1fd1aa076de07cfe3fc738f8b56da67a99a48f78 (patch)
tree1a3cf06c1c6d44e24cb45069d557640c71b38f60
parent31e4ac5754fc60e66e50b94ece99da8cd0c90b08 (diff)
downloadfreebsd-ports-gnome-1fd1aa076de07cfe3fc738f8b56da67a99a48f78.tar.gz
freebsd-ports-gnome-1fd1aa076de07cfe3fc738f8b56da67a99a48f78.tar.zst
freebsd-ports-gnome-1fd1aa076de07cfe3fc738f8b56da67a99a48f78.zip
Fix building when libressl is not the default.
PR: 215150 Sponsored by: Absolight
-rw-r--r--net/openntpd/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/net/openntpd/Makefile b/net/openntpd/Makefile
index 6378604954f4..2a6ab1b5ff92 100644
--- a/net/openntpd/Makefile
+++ b/net/openntpd/Makefile
@@ -48,9 +48,11 @@ LDFLAGS+= -fstack-protector
LIBS+= -lssp_nonshared
. endif
+# Don't use COPYTREE_SHARE here as it hard links files, and the original files
+# are owned by root, which creates problems of its own.
pre-configure:
- @cd `${MAKE} -V STAGEDIR -C ${PORTSDIR}/security/libressl`${LOCALBASE} \
- && ${COPYTREE_SHARE} . ${WRKDIR}/libressl "! -name *.so*"
+ @cd `${MAKE} -V STAGEDIR -C ${PORTSDIR}/security/libressl`${PREFIX} \
+ && ${FIND} -E . ! -name *.so\* | ${CPIO} -dump ${WRKDIR}/libressl >/dev/null 2>&1
.endif # SSL_DEFAULT
.include <bsd.port.post.mk>