aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormich <mich@FreeBSD.org>2015-06-21 23:07:12 +0800
committermich <mich@FreeBSD.org>2015-06-21 23:07:12 +0800
commit20b4729b3e5f81d159d28243f80b10f840bf8348 (patch)
tree3b351d50b7e46d7585c49b83bb66a093b49722d9
parent218cc44daf7377ab1a93f6a602e05d79a1d9472a (diff)
downloadfreebsd-ports-gnome-20b4729b3e5f81d159d28243f80b10f840bf8348.tar.gz
freebsd-ports-gnome-20b4729b3e5f81d159d28243f80b10f840bf8348.tar.zst
freebsd-ports-gnome-20b4729b3e5f81d159d28243f80b10f840bf8348.zip
- update to 1.0.0
- project moved to github > Description of fields to fill in above: 76 columns --| > PR: If a GNATS PR is affected by the change. > Differential Revision: https://reviews.freebsd.org/D### (*full* phabric URL needed). > Submitted by: If someone else sent in the change. > Reviewed by: If someone else reviewed your modification. > Approved by: If you needed approval for this commit. > Obtained from: If the change is from a third party. > MFC after: N [day[s]|week[s]|month[s]]. Request a reminder email. > MFH: Ports tree branch name. Request approval for merge. > Relnotes: Set to 'yes' for mention in release notes. > Security: Vulnerability reference (one per line) or description. > Sponsored by: If the change was sponsored by an organization. > Empty fields above will be automatically removed. M Makefile M distinfo M pkg-plist
-rw-r--r--games/braincurses/Makefile18
-rw-r--r--games/braincurses/distinfo4
-rw-r--r--games/braincurses/pkg-plist2
3 files changed, 14 insertions, 10 deletions
diff --git a/games/braincurses/Makefile b/games/braincurses/Makefile
index be368c7539ee..094720a338d7 100644
--- a/games/braincurses/Makefile
+++ b/games/braincurses/Makefile
@@ -2,27 +2,31 @@
# $FreeBSD$
PORTNAME= braincurses
-PORTVERSION= 0.5a
+PORTVERSION= 1.0.0
CATEGORIES= games
-MASTER_SITES= http://freebsdcluster.org/~mich/software/
MAINTAINER= mich@FreeBSD.org
COMMENT= Clone of the Mastermind game
-LDFLAGS+= -lncurses
-WRKSRC= ${WRKDIR}/${PORTNAME}
+LICENSE= GPLv2
+
+USE_GITHUB= yes
+GH_ACCOUNT= bderrly
+GH_TAGNAME= 8f603c1
+
+LDFLAGS+= -L${LOCALBASE}/lib -lncurses
OPTIONS_DEFINE= DOCS
do-build:
cd ${WRKSRC} && \
- ${CXX} -c -o curses/windows.o curses/windows.cpp && \
+ ${CXX} -c -o windows/windows.o windows/windows.cpp && \
${CXX} ${CFLAGS} -c ${PORTNAME}.cpp && \
- ${CXX} ${CFLAGS} ${LDFLAGS} -o ${PORTNAME} curses/windows.o ${PORTNAME}.o
+ ${CXX} ${CFLAGS} ${LDFLAGS} -o ${PORTNAME} windows/windows.o ${PORTNAME}.o
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/README
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}/README.md
.include <bsd.port.mk>
diff --git a/games/braincurses/distinfo b/games/braincurses/distinfo
index 26dcc1dd2549..fba3f627cdb7 100644
--- a/games/braincurses/distinfo
+++ b/games/braincurses/distinfo
@@ -1,2 +1,2 @@
-SHA256 (braincurses-0.5a.tar.gz) = 495ecd6b94a72044101365d5b9d8aee50d7d326b4537ec57815715c1fa31ea8d
-SIZE (braincurses-0.5a.tar.gz) = 11911
+SHA256 (bderrly-braincurses-1.0.0-8f603c1_GH0.tar.gz) = e9c5f48a312414067ad459d6e6c09372da772c7a0ada3971775899fdbd25fdb5
+SIZE (bderrly-braincurses-1.0.0-8f603c1_GH0.tar.gz) = 11730
diff --git a/games/braincurses/pkg-plist b/games/braincurses/pkg-plist
index 6f22ffae95d5..7d28dbc6f15a 100644
--- a/games/braincurses/pkg-plist
+++ b/games/braincurses/pkg-plist
@@ -1,2 +1,2 @@
bin/braincurses
-%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.md