aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-09-04 02:41:37 +0800
committerknu <knu@FreeBSD.org>2001-09-04 02:41:37 +0800
commit20cefa9585bca169bef97b5b0a721b5051d2d47c (patch)
tree4768c4e0cb4777a5fe110cb7ba41fdbd10da0a7a
parentbddfeef7f600d326dc9080591875cce5fd8b9bd5 (diff)
downloadfreebsd-ports-gnome-20cefa9585bca169bef97b5b0a721b5051d2d47c.tar.gz
freebsd-ports-gnome-20cefa9585bca169bef97b5b0a721b5051d2d47c.tar.zst
freebsd-ports-gnome-20cefa9585bca169bef97b5b0a721b5051d2d47c.zip
Add flvw. The FLVW (Fast Light Virtual Widgets) require the use of
the FLTK (Fast Light ToolKit) library. They are designed to handle large amounts of data. As such they are definitely not the smallset of FLTK widgets, but they are designed to use memory conservatively. PR: ports/29860 Submitted by: Cyrille Lefevre <clefevre@citeweb.net>
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/flvw/Makefile48
-rw-r--r--x11-toolkits/flvw/distinfo1
-rw-r--r--x11-toolkits/flvw/files/patch-makeinclude.in26
-rw-r--r--x11-toolkits/flvw/files/patch-src-Makefile60
-rw-r--r--x11-toolkits/flvw/pkg-comment1
-rw-r--r--x11-toolkits/flvw/pkg-descr6
-rw-r--r--x11-toolkits/flvw/pkg-plist42
8 files changed, 185 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index e1cd1806b56e..41ee95f9f9d5 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -15,6 +15,7 @@
SUBDIR += engradient
SUBDIR += fltk
SUBDIR += fltk-xunicode
+ SUBDIR += flvw
SUBDIR += fox
SUBDIR += fox-xunicode
SUBDIR += gal
diff --git a/x11-toolkits/flvw/Makefile b/x11-toolkits/flvw/Makefile
new file mode 100644
index 000000000000..52e1d84cc8e6
--- /dev/null
+++ b/x11-toolkits/flvw/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: flvw
+# Date created: 17 August 2001
+# Whom: Cyrille Lefevre <clefevre@citeweb.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= flvw
+PORTVERSION= 20000224
+CATEGORIES= x11-toolkits
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= clefevre@citeweb.net
+
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+
+WRKSRC= ${WRKDIR}/${PORTNAME}/1.0
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAKE_ARGS= DIRS=src
+
+DOC_FILES= documentation/html/*.html
+DOC_SUBDIR= share/doc/${PKGBASE}
+INC_FILES= Flv_CStyle.H Flv_Data_Source.H Flv_List.H Flv_Style.H \
+ Flv_Table.H Flve_Check_Button.H Flve_Combo.H Flve_Input.H
+INC_SUBDIR= include/FL
+
+INSTALLS_SHLIB= yes
+
+post-install: symlink-inc install-doc
+
+symlink-inc:
+.for file in ${INC_FILES}
+ @${LN} -fs ${file} ${PREFIX}/${INC_SUBDIR}/${file:R}.${file:E:L}
+.endfor
+
+install-doc:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/${DOC_SUBDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/${DOC_SUBDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/flvw/distinfo b/x11-toolkits/flvw/distinfo
new file mode 100644
index 000000000000..60c588c87822
--- /dev/null
+++ b/x11-toolkits/flvw/distinfo
@@ -0,0 +1 @@
+MD5 (flvw-20000224.tgz) = 0412103fcb01ff2c0cdb699b37af385e
diff --git a/x11-toolkits/flvw/files/patch-makeinclude.in b/x11-toolkits/flvw/files/patch-makeinclude.in
new file mode 100644
index 000000000000..6799bc8a48a6
--- /dev/null
+++ b/x11-toolkits/flvw/files/patch-makeinclude.in
@@ -0,0 +1,26 @@
+--- makeinclude.in.orig Sat Jan 22 14:18:28 2000
++++ makeinclude.in Sat Aug 18 09:12:34 2001
+@@ -56,7 +56,7 @@
+ # Rules...
+ #
+
+-.SUFFIXES: .c .cxx .h .o
++.SUFFIXES: .c .cxx .h .o .lo
+
+ .c.o:
+ @echo Compiling $<...
+@@ -65,6 +65,14 @@
+ .cxx.o:
+ @echo Compiling $<...
+ @$(CXX) $(CXXFLAGS) -I. -c $<
++
++.c.lo:
++ @echo Compiling $<...
++ @$(CC) $(CFLAGS) -c -o $@ $<
++
++.cxx.lo:
++ @echo Compiling $<...
++ @$(CXX) $(CXXFLAGS) -I. -c -o $@ $<
+
+ #
+ # End of makeinclude
diff --git a/x11-toolkits/flvw/files/patch-src-Makefile b/x11-toolkits/flvw/files/patch-src-Makefile
new file mode 100644
index 000000000000..a5ec5980ba2f
--- /dev/null
+++ b/x11-toolkits/flvw/files/patch-src-Makefile
@@ -0,0 +1,60 @@
+--- src/Makefile.orig Sat Jan 22 14:30:26 2000
++++ src/Makefile Sat Aug 18 09:09:18 2001
+@@ -13,7 +13,7 @@
+ # Make all targets...
+ #
+
+-all: libflvw.a
++all: ../lib/libflvw.a ../lib/libflvw.so.1
+
+ #
+ # Remove object and target files...
+@@ -24,31 +24,40 @@
+ @$(RM) -f *.o core *~ ../FL/*~ ../FL/*.bak
+
+ distclean: clean
+- @$(RM) -f ../lib/libflvw.a makedepend
++ @$(RM) -f ../lib/libflvw.a ../lib/libflvw.so.1 makedepend
+
+-install: libflvw.a
++install: all
+ @echo "Installing libraries..."
+ @-mkdir -p $(libdir)
+- @rm -f $(libdir)/$(LIBNAME)
+- @-cp $(LIBRARY).a $(libdir)
+- @-chmod 644 $(libdir)/$(LIBNAME).a
+- @echo "Installing include files..."
++ @rm -f $(libdir)/libflvw.a $(libdir)/libflvw.so*
++ @-cp ../lib/libflvw.a ../lib/libflvw.so.1 $(libdir)
++ @-ln -s libflvw.so.1 $(libdir)/libflvw.so
++ @-chmod 644 $(libdir)/libflvw.a $(libdir)/libflvw.so.1
++ @echo "Installing headers..."
+ @-mkdir -p $(includedir)/FL
+- @-cp -r ../FL/* $(includedir)/FL/
++ @-cp ../FL/*.H $(includedir)/FL/
+
+ #
+ # Make the flvw widget library.
+ #
+
+ FLVW_OBJS = Flv_Style.o Flv_List.o Flv_Table.o Flv_CStyle.o Flve_Input.o Flve_Check_Button.o
++FLVW_SHOBJS= $(FLVW_OBJS:.o=.lo)
+ FLVW_HDRS: FL/Flv_Style.H FL/Flv_List.H FL/Flv_Table.H FL/Flv_CStyle.H FL/Flve_Input.H FL/Flve_Check_Button.H
+
+-libflvw.a: $(FLVW_OBJS) $(FLVW_HDRS)
++../lib/libflvw.a: $(FLVW_OBJS)
+ @echo Building library $@...
+ @$(RM) -f ../lib/libflvw.a
+ @$(AR) $(ARFLAGS) ../lib/libflvw.a $(FLVW_OBJS)
+ @$(RANLIB) ../lib/libflvw.a
+
++../lib/libflvw.so.1: $(FLVW_SHOBJS)
++ @echo Building library $@...
++ @$(RM) -f ../lib/libflvw.so.1
++ @$(CXX) $(CXXFLAGS) -shared -Wl,-soname,libflvw.so.1 -o ../lib/libflvw.so.1 $(FLVW_SHOBJS)
++
++$(FLVW_OBJS): $(FLVW_HDRS)
++$(FLVW_SHOBJS): $(FLVW_HDRS)
+
+ #
+ # End of Makefile.
diff --git a/x11-toolkits/flvw/pkg-comment b/x11-toolkits/flvw/pkg-comment
new file mode 100644
index 000000000000..13f353f9b782
--- /dev/null
+++ b/x11-toolkits/flvw/pkg-comment
@@ -0,0 +1 @@
+Virtual Widgets for the Fast Light ToolKit
diff --git a/x11-toolkits/flvw/pkg-descr b/x11-toolkits/flvw/pkg-descr
new file mode 100644
index 000000000000..f572b587dbbf
--- /dev/null
+++ b/x11-toolkits/flvw/pkg-descr
@@ -0,0 +1,6 @@
+The FLVW (Fast Light Virtual Widgets) require the use of the FLTK
+(Fast Light ToolKit) library. They are designed to handle large
+amounts of data. As such they are definitely not the smallest of
+FLTK widgets, but they are designed to use memory conservatively.
+
+WWW: http://www.fltk.org/
diff --git a/x11-toolkits/flvw/pkg-plist b/x11-toolkits/flvw/pkg-plist
new file mode 100644
index 000000000000..da4d46886c53
--- /dev/null
+++ b/x11-toolkits/flvw/pkg-plist
@@ -0,0 +1,42 @@
+@comment $FreeBSD$
+include/FL/Flv_CStyle.H
+@exec ln -fs %f %B/Flv_CStyle.h
+@unexec rm -f %B/Flv_CStyle.h
+include/FL/Flv_Data_Source.H
+@exec ln -fs %f %B/Flv_Data_Source.h
+@unexec rm -f %B/Flv_Data_Source.h
+include/FL/Flv_List.H
+@exec ln -fs %f %B/Flv_List.h
+@unexec rm -f %B/Flv_List.h
+include/FL/Flv_Style.H
+@exec ln -fs %f %B/Flv_Style.h
+@unexec rm -f %B/Flv_Style.h
+include/FL/Flv_Table.H
+@exec ln -fs %f %B/Flv_Table.h
+@unexec rm -f %B/Flv_Table.h
+include/FL/Flve_Check_Button.H
+@exec ln -fs %f %B/Flve_Check_Button.h
+@unexec rm -f %B/Flve_Check_Button.h
+include/FL/Flve_Combo.H
+@exec ln -fs %f %B/Flve_Combo.h
+@unexec rm -f %B/Flve_Combo.h
+include/FL/Flve_Input.H
+@exec ln -fs %f %B/Flve_Input.h
+@unexec rm -f %B/Flve_Input.h
+lib/libflvw.a
+lib/libflvw.so.1
+@exec ln -fs %f %B/libflvw.so
+@unexec rm -f %B/libflvw.so
+%%PORTDOCS%%share/doc/flvw/basics.html
+%%PORTDOCS%%share/doc/flvw/callbacks.html
+%%PORTDOCS%%share/doc/flvw/classref.html
+%%PORTDOCS%%share/doc/flvw/flv_ctable.html
+%%PORTDOCS%%share/doc/flvw/flv_list.html
+%%PORTDOCS%%share/doc/flvw/flv_style.html
+%%PORTDOCS%%share/doc/flvw/flv_style_list.html
+%%PORTDOCS%%share/doc/flvw/flv_table.html
+%%PORTDOCS%%share/doc/flvw/index.html
+%%PORTDOCS%%share/doc/flvw/intro.html
+%%PORTDOCS%%share/doc/flvw/scroll_bar.html
+%%PORTDOCS%%share/doc/flvw/stylebasics.html
+%%PORTDOCS%%share/doc/flvw/widget_features.html