aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2020-01-19 19:08:45 +0800
committersunpoet <sunpoet@FreeBSD.org>2020-01-19 19:08:45 +0800
commit212dabb1b6eee0a9e2679f875f118ed6e9c7895f (patch)
tree9bd0155c2f24b88cfc761151f0757cd3716fc6c4
parent65dec571821e565e765ed5a37ebad6f0a7307e43 (diff)
downloadfreebsd-ports-gnome-212dabb1b6eee0a9e2679f875f118ed6e9c7895f.tar.gz
freebsd-ports-gnome-212dabb1b6eee0a9e2679f875f118ed6e9c7895f.tar.zst
freebsd-ports-gnome-212dabb1b6eee0a9e2679f875f118ed6e9c7895f.zip
Add p5-File-Find-Object-Rule 0.0311
File::Find::Object::Rule is a friendlier interface to File::Find::Object . It allows you to build rules which specify the desired files and directories. WWW: https://metacpan.org/release/File-Find-Object-Rule
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-Find-Object-Rule/Makefile28
-rw-r--r--devel/p5-File-Find-Object-Rule/distinfo3
-rw-r--r--devel/p5-File-Find-Object-Rule/pkg-descr4
-rw-r--r--devel/p5-File-Find-Object-Rule/pkg-plist8
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6a1b8d341a87..58ddbed8433c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2354,6 +2354,7 @@
SUBDIR += p5-File-FcntlLock
SUBDIR += p5-File-Find-Closures
SUBDIR += p5-File-Find-Object
+ SUBDIR += p5-File-Find-Object-Rule
SUBDIR += p5-File-Find-Rule
SUBDIR += p5-File-Find-Rule-Filesys-Virtual
SUBDIR += p5-File-Find-Rule-Perl
diff --git a/devel/p5-File-Find-Object-Rule/Makefile b/devel/p5-File-Find-Object-Rule/Makefile
new file mode 100644
index 000000000000..5c5a6943ddd1
--- /dev/null
+++ b/devel/p5-File-Find-Object-Rule/Makefile
@@ -0,0 +1,28 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= File-Find-Object-Rule
+PORTVERSION= 0.0311
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Alternative interface to File::Find::Object
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE_ART10= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Class-XSAccessor>=0:devel/p5-Class-XSAccessor \
+ p5-File-Find-Object>=0:devel/p5-File-Find-Object \
+ p5-Number-Compare>=0:math/p5-Number-Compare \
+ p5-Text-Glob>=0:textproc/p5-Text-Glob
+
+USES= perl5
+USE_PERL5= modbuild
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Find-Object-Rule/distinfo b/devel/p5-File-Find-Object-Rule/distinfo
new file mode 100644
index 000000000000..2b8f31a2b0d1
--- /dev/null
+++ b/devel/p5-File-Find-Object-Rule/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1579412809
+SHA256 (File-Find-Object-Rule-0.0311.tar.gz) = 038a92e4380920448d5627ec98fc9990dbc3223eb93bb554c9b09eef4a735f3e
+SIZE (File-Find-Object-Rule-0.0311.tar.gz) = 38072
diff --git a/devel/p5-File-Find-Object-Rule/pkg-descr b/devel/p5-File-Find-Object-Rule/pkg-descr
new file mode 100644
index 000000000000..77723d1a612a
--- /dev/null
+++ b/devel/p5-File-Find-Object-Rule/pkg-descr
@@ -0,0 +1,4 @@
+File::Find::Object::Rule is a friendlier interface to File::Find::Object . It
+allows you to build rules which specify the desired files and directories.
+
+WWW: https://metacpan.org/release/File-Find-Object-Rule
diff --git a/devel/p5-File-Find-Object-Rule/pkg-plist b/devel/p5-File-Find-Object-Rule/pkg-plist
new file mode 100644
index 000000000000..ac40bf043c93
--- /dev/null
+++ b/devel/p5-File-Find-Object-Rule/pkg-plist
@@ -0,0 +1,8 @@
+bin/findorule
+%%SITE_PERL%%/File/Find/Object/Rule.pm
+%%SITE_PERL%%/File/Find/Object/Rule/Extending.pod
+%%SITE_PERL%%/File/Find/Object/Rule/Procedural.pod
+%%PERL5_MAN1%%/findorule.1.gz
+%%PERL5_MAN3%%/File::Find::Object::Rule.3.gz
+%%PERL5_MAN3%%/File::Find::Object::Rule::Extending.3.gz
+%%PERL5_MAN3%%/File::Find::Object::Rule::Procedural.3.gz