aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-06-04 01:24:39 +0800
committermiwi <miwi@FreeBSD.org>2008-06-04 01:24:39 +0800
commit21844bdbee25219dab72c0027291bb97650a5e71 (patch)
tree8b48db4368512cb8d941615807cf3bbd97f0ecc5
parent3c82c465db87fe01c92ebc5854a8b96dc104cb47 (diff)
downloadfreebsd-ports-gnome-21844bdbee25219dab72c0027291bb97650a5e71.tar.gz
freebsd-ports-gnome-21844bdbee25219dab72c0027291bb97650a5e71.tar.zst
freebsd-ports-gnome-21844bdbee25219dab72c0027291bb97650a5e71.zip
Intense 2D space shooter like Space-Invaders, but not quite. It
uses OpenGL and includes particle effects. The objective is to shoot the aliens before they reach the bottom of the screen. WWW: http://dusted.dk/?view=linux-game-simplevaders PR: ports/124233 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
-rw-r--r--games/Makefile1
-rw-r--r--games/simplevaders/Makefile37
-rw-r--r--games/simplevaders/distinfo3
-rw-r--r--games/simplevaders/pkg-descr7
-rw-r--r--games/simplevaders/pkg-plist12
5 files changed, 60 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 9d64bf5d06e1..cdb64c028156 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -720,6 +720,7 @@
SUBDIR += sfbol
SUBDIR += shaaft
SUBDIR += shootingstar
+ SUBDIR += simplevaders
SUBDIR += six
SUBDIR += sjeng
SUBDIR += sl
diff --git a/games/simplevaders/Makefile b/games/simplevaders/Makefile
new file mode 100644
index 000000000000..9927542cecb1
--- /dev/null
+++ b/games/simplevaders/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: simplevaders
+# Date created: 21 Apr 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= simplevaders
+PORTVERSION= 0.8
+CATEGORIES= games
+MASTER_SITES= http://dusted.dk/download/ \
+ http://www.amdmi3.ru/distfiles/
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= A Space-Invaders like 2D space shooter
+
+USE_BZIP2= yes
+USE_SDL= sdl mixer image ttf
+USE_GL= gl glu
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|data/|${DATADIR}/|' ${WRKSRC}/main.cpp
+ @${RM} ${WRKSRC}/data/*\~
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} main.cpp -o ${PORTNAME} \
+ `${SDL_CONFIG} --cflags --libs` -lSDL_ttf -lSDL_mixer \
+ -lSDL_image -lGL -lGLU
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/simplevaders/distinfo b/games/simplevaders/distinfo
new file mode 100644
index 000000000000..884ae35af580
--- /dev/null
+++ b/games/simplevaders/distinfo
@@ -0,0 +1,3 @@
+MD5 (simplevaders-0.8.tar.bz2) = f3454361ab40dc66d16a702ceb7c1e6d
+SHA256 (simplevaders-0.8.tar.bz2) = dc39e8f1ae0ee51edf6836321705b8f8fb086cfce5a8d55b71a3960aad794da4
+SIZE (simplevaders-0.8.tar.bz2) = 415625
diff --git a/games/simplevaders/pkg-descr b/games/simplevaders/pkg-descr
new file mode 100644
index 000000000000..56c0bf9c9036
--- /dev/null
+++ b/games/simplevaders/pkg-descr
@@ -0,0 +1,7 @@
+Intense 2D space shooter like Space-Invaders, but not quite. It
+uses OpenGL and includes particle effects.
+
+The objective is to shoot the aliens before they reach the bottom
+of the screen.
+
+WWW: http://dusted.dk/?view=linux-game-simplevaders
diff --git a/games/simplevaders/pkg-plist b/games/simplevaders/pkg-plist
new file mode 100644
index 000000000000..8c9d3d597570
--- /dev/null
+++ b/games/simplevaders/pkg-plist
@@ -0,0 +1,12 @@
+bin/simplevaders
+%%DATADIR%%/cred.png
+%%DATADIR%%/files.txt
+%%DATADIR%%/flare.png
+%%DATADIR%%/font.ttf
+%%DATADIR%%/gameover.png
+%%DATADIR%%/gameover.wav
+%%DATADIR%%/intro.png
+%%DATADIR%%/nmedie.wav
+%%DATADIR%%/playerbullet.wav
+%%DATADIR%%/playerhit.wav
+@dirrm %%DATADIR%%