aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2003-08-10 05:03:18 +0800
committerknu <knu@FreeBSD.org>2003-08-10 05:03:18 +0800
commit21ed50274765ff010f4bc6eda8f34d02e7e606a7 (patch)
treee282acd1a74af2f88b7a219ddb83a19c40dd02a0
parent26bab83f4c8c21433be836797b3c4707965337f5 (diff)
downloadfreebsd-ports-gnome-21ed50274765ff010f4bc6eda8f34d02e7e606a7.tar.gz
freebsd-ports-gnome-21ed50274765ff010f4bc6eda8f34d02e7e606a7.tar.zst
freebsd-ports-gnome-21ed50274765ff010f4bc6eda8f34d02e7e606a7.zip
Add ruby-gnomevfs, Ruby binding for GnomeVFS.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-gnomevfs/Makefile44
-rw-r--r--devel/ruby-gnomevfs/pkg-descr3
-rw-r--r--devel/ruby-gnomevfs/pkg-plist9
4 files changed, 57 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ebd6f483dccc..ce2cb8df7163 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -890,6 +890,7 @@
SUBDIR += ruby-gemfinder
SUBDIR += ruby-gettext
SUBDIR += ruby-glib2
+ SUBDIR += ruby-gnomevfs
SUBDIR += ruby-gnustep
SUBDIR += ruby-inline
SUBDIR += ruby-intl
diff --git a/devel/ruby-gnomevfs/Makefile b/devel/ruby-gnomevfs/Makefile
new file mode 100644
index 000000000000..0cdbc1853f46
--- /dev/null
+++ b/devel/ruby-gnomevfs/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: Ruby/GnomeVFS
+# Date created: 10 August 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomevfs
+PORTVERSION= ${RUBY_GNOME_PORTVERSION}
+CATEGORIES= devel ruby gnome
+MASTER_SITES= ${RUBY_GNOME_MASTER_SITES}
+MASTER_SITE_SUBDIR= ${RUBY_GNOME_MASTER_SITE_SUBDIR}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${RUBY_GNOME_DISTNAME}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= Ruby binding for GnomeVFS
+
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/glib2.so:${PORTSDIR}/devel/ruby-glib2
+LIB_DEPENDS= gnomevfs-2.0:${PORTSDIR}/devel/gnomevfs2
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+.include "${.CURDIR}/../../x11/ruby-gnome2/Makefile.common"
+
+WRKSRC= ${RUBY_GNOME_WRKSRC}/${PORTNAME}
+INSTALL_TARGET= site-install
+
+DOCS= ChangeLog \
+ README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/tests/* ${RUBY_MODEXAMPLESDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-gnomevfs/pkg-descr b/devel/ruby-gnomevfs/pkg-descr
new file mode 100644
index 000000000000..81c33800e9c0
--- /dev/null
+++ b/devel/ruby-gnomevfs/pkg-descr
@@ -0,0 +1,3 @@
+Ruby/GnomeVFS is a Ruby binding for GnomeVFS>
+
+WWW: http://ruby-gnome2.sourceforge.jp/
diff --git a/devel/ruby-gnomevfs/pkg-plist b/devel/ruby-gnomevfs/pkg-plist
new file mode 100644
index 000000000000..a59ccee9c033
--- /dev/null
+++ b/devel/ruby-gnomevfs/pkg-plist
@@ -0,0 +1,9 @@
+%%RUBY_SITEARCHLIBDIR%%/gnomevfs.so
+%%RUBY_SITELIBDIR%%/gnomevfs.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test1.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test2.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/test3.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%