aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoichiro Iwao <meta@FreeBSD.org>2019-08-14 11:26:09 +0800
committerKoichiro Iwao <meta@FreeBSD.org>2019-08-14 11:26:09 +0800
commit222e095f2a98156ce6f8f061acbe63ac9306a9b1 (patch)
tree03e0541dbd8613da504c623b3522cd1a5aa7467f
parent3c12a89ea7fc83824f8245d57eb20825efb591eb (diff)
downloadfreebsd-ports-gnome-222e095f2a98156ce6f8f061acbe63ac9306a9b1.tar.gz
freebsd-ports-gnome-222e095f2a98156ce6f8f061acbe63ac9306a9b1.tar.zst
freebsd-ports-gnome-222e095f2a98156ce6f8f061acbe63ac9306a9b1.zip
Implement new virtual category: net-vpn for VPN related ports
based on discussion at ports@ [1]. As VPN softwares are put in different physical category net and security. This is a little bit confusing. Let's give them new virtual category net-vpn. [1] https://lists.freebsd.org/pipermail/freebsd-ports/2019-April/115915.html PR: 239395 Submitted by: myself Approved by: portmgr (mat) Differential Revision: https://reviews.freebsd.org/D21174
-rw-r--r--Mk/Scripts/desktop-categories.sh1
-rw-r--r--Mk/bsd.port.mk2
-rw-r--r--net/mlvpn/Makefile2
-rw-r--r--net/ocserv/Makefile2
-rw-r--r--net/poptop/Makefile2
-rw-r--r--net/pptpclient/Makefile2
-rw-r--r--net/py-sshuttle/Makefile2
-rw-r--r--net/wireguard-go/Makefile2
-rw-r--r--net/wireguard/Makefile2
-rw-r--r--security/fiked/Makefile2
-rw-r--r--security/govpn/Makefile2
-rw-r--r--security/ike-scan/Makefile2
-rw-r--r--security/n2n/Makefile2
-rw-r--r--security/openconnect-gui/Makefile2
-rw-r--r--security/openconnect/Makefile2
-rw-r--r--security/openfortivpn/Makefile2
-rw-r--r--security/openvpn-admin/Makefile2
-rw-r--r--security/openvpn-auth-ldap/Makefile2
-rw-r--r--security/openvpn-auth-radius/Makefile2
-rw-r--r--security/openvpn-auth-script/Makefile2
-rw-r--r--security/openvpn-devel/Makefile2
-rw-r--r--security/openvpn/Makefile2
-rw-r--r--security/softether-devel/Makefile2
-rw-r--r--security/softether/Makefile2
-rw-r--r--security/softether5/Makefile2
-rw-r--r--security/strongswan/Makefile2
-rw-r--r--security/tinc-devel/Makefile2
-rw-r--r--security/tinc/Makefile2
-rw-r--r--security/vpnc/Makefile2
-rw-r--r--sysutils/vpnc-scripts/Makefile2
30 files changed, 30 insertions, 29 deletions
diff --git a/Mk/Scripts/desktop-categories.sh b/Mk/Scripts/desktop-categories.sh
index 7d5414b7ed12..0edbf4a991ee 100644
--- a/Mk/Scripts/desktop-categories.sh
+++ b/Mk/Scripts/desktop-categories.sh
@@ -55,6 +55,7 @@ for native_category in ${dp_CATEGORIES}; do
net-im) c="Network InstantMessaging" ;;
net-mgmt) c="Network" ;;
net-p2p) c="Network P2P" ;;
+ net-vpn) c="Network VPN" ;;
news) c="Network News" ;;
palm) c="Office PDA" ;;
parallel) c="ParallelComputing" ;;
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 8c01f2ce510e..6bcdefdecb4b 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2533,7 +2533,7 @@ VALID_CATEGORIES+= accessibility afterstep arabic archivers astro audio \
deskutils devel docs dns editors elisp emulators enlightenment finance french ftp \
games geography german gnome gnustep graphics hamradio haskell hebrew hungarian \
ipv6 irc japanese java kde ${_KDE_CATEGORIES_SUPPORTED} kld korean lang linux lisp \
- mail mate math mbone misc multimedia net net-im net-mgmt net-p2p news \
+ mail mate math mbone misc multimedia net net-im net-mgmt net-p2p net-vpn news \
palm parallel pear perl5 plan9 polish portuguese ports-mgmt \
print python ruby rubygems russian \
scheme science security shells spanish sysutils \
diff --git a/net/mlvpn/Makefile b/net/mlvpn/Makefile
index 145e2afe1588..ab8e6bf0de87 100644
--- a/net/mlvpn/Makefile
+++ b/net/mlvpn/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mlvpn
PORTVERSION= 2.3.1
PORTREVISION= 2
-CATEGORIES= net
+CATEGORIES= net net-vpn
MAINTAINER= olivier@FreeBSD.org
COMMENT= Multi-link VPN
diff --git a/net/ocserv/Makefile b/net/ocserv/Makefile
index 2495ccc0b8c2..94335fcd1987 100644
--- a/net/ocserv/Makefile
+++ b/net/ocserv/Makefile
@@ -4,7 +4,7 @@
PORTNAME= ocserv
PORTVERSION= 0.12.4
PORTREVISION= 1
-CATEGORIES= net security
+CATEGORIES= net net-vpn security
MASTER_SITES= ftp://ftp.infradead.org/pub/ocserv/
MAINTAINER= cpm@FreeBSD.org
diff --git a/net/poptop/Makefile b/net/poptop/Makefile
index 226be5a1dc2f..9f560992b480 100644
--- a/net/poptop/Makefile
+++ b/net/poptop/Makefile
@@ -4,7 +4,7 @@
PORTNAME= poptop
PORTVERSION= 1.4.0
PORTREVISION= 1
-CATEGORIES= net
+CATEGORIES= net net-vpn
MASTER_SITES= SF/${PORTNAME}/pptpd/pptpd-${PORTVERSION} \
SAMBA/ppp:pppd
DISTFILES= pptpd-${PORTVERSION}${EXTRACT_SUFX} \
diff --git a/net/pptpclient/Makefile b/net/pptpclient/Makefile
index 7a33952f4bde..d2749b1e9d87 100644
--- a/net/pptpclient/Makefile
+++ b/net/pptpclient/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pptpclient
DISTVERSION= 1.10.0
-CATEGORIES= net
+CATEGORIES= net net-vpn
MASTER_SITES= SF/${PORTNAME}/pptp/pptp-${PORTVERSION}
DISTNAME= pptp-${PORTVERSION}
diff --git a/net/py-sshuttle/Makefile b/net/py-sshuttle/Makefile
index 6619c37bed0a..99b0190fa8fb 100644
--- a/net/py-sshuttle/Makefile
+++ b/net/py-sshuttle/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sshuttle
PORTVERSION= 0.78.5
-CATEGORIES= net python
+CATEGORIES= net python net-vpn
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/net/wireguard-go/Makefile b/net/wireguard-go/Makefile
index df777c3bfe16..549d9903203e 100644
--- a/net/wireguard-go/Makefile
+++ b/net/wireguard-go/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wireguard-go
PORTVERSION= 0.0.20190805
-CATEGORIES= net
+CATEGORIES= net net-vpn
MASTER_SITES= https://git.zx2c4.com/wireguard-go/snapshot/
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
diff --git a/net/wireguard/Makefile b/net/wireguard/Makefile
index 7dc3e9de47d8..dcff1c46c85c 100644
--- a/net/wireguard/Makefile
+++ b/net/wireguard/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wireguard
PORTVERSION= 0.0.20190702
-CATEGORIES= net
+CATEGORIES= net net-vpn
MASTER_SITES= https://git.zx2c4.com/WireGuard/snapshot/
DISTNAME= WireGuard-${PORTVERSION}
diff --git a/security/fiked/Makefile b/security/fiked/Makefile
index 1ae7a7e3c0fe..213ff9bb8879 100644
--- a/security/fiked/Makefile
+++ b/security/fiked/Makefile
@@ -4,7 +4,7 @@
PORTNAME= fiked
PORTVERSION= 0.0.5
PORTREVISION= 7
-CATEGORIES= security
+CATEGORIES= security net-vpn
MASTER_SITES= https://mirror.roe.ch/rel/fiked/
MAINTAINER= ports@FreeBSD.org
diff --git a/security/govpn/Makefile b/security/govpn/Makefile
index ac685cb6d795..cbd498097c6d 100644
--- a/security/govpn/Makefile
+++ b/security/govpn/Makefile
@@ -4,7 +4,7 @@
PORTNAME= govpn
DISTVERSION= 7.5
PORTREVISION= 1
-CATEGORIES= security
+CATEGORIES= security net-vpn
MASTER_SITES= http://www.govpn.info/download/
MAINTAINER= stargrave@stargrave.org
diff --git a/security/ike-scan/Makefile b/security/ike-scan/Makefile
index a3cf973ce76e..f36a762a7c7a 100644
--- a/security/ike-scan/Makefile
+++ b/security/ike-scan/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ike-scan
PORTVERSION= 1.9
-CATEGORIES= security
+CATEGORIES= security net-vpn
MASTER_SITES= http://www.nta-monitor.com/tools/ike-scan/download/
MAINTAINER= ports@FreeBSD.org
diff --git a/security/n2n/Makefile b/security/n2n/Makefile
index 71cdfdd454b9..8802a436b359 100644
--- a/security/n2n/Makefile
+++ b/security/n2n/Makefile
@@ -3,7 +3,7 @@
PORTNAME= n2n
PORTVERSION= 2.4
-CATEGORIES= security net
+CATEGORIES= security net net-vpn
MAINTAINER= farrokhi@FreeBSD.org
COMMENT= Layer Two Peer-to-peer VPN
diff --git a/security/openconnect-gui/Makefile b/security/openconnect-gui/Makefile
index ea61480464b1..3dab80132fec 100644
--- a/security/openconnect-gui/Makefile
+++ b/security/openconnect-gui/Makefile
@@ -5,7 +5,7 @@ PORTNAME= openconnect-gui
PORTVERSION= 1.4.1
DISTVERSIONPREFIX=v
PORTREVISION= 3
-CATEGORIES= security
+CATEGORIES= security net-vpn
MAINTAINER= pkubaj@anongoth.pl
COMMENT= Graphical OpenConnect client
diff --git a/security/openconnect/Makefile b/security/openconnect/Makefile
index 8b3d6c20acbd..d61a44889c38 100644
--- a/security/openconnect/Makefile
+++ b/security/openconnect/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openconnect
PORTVERSION= 8.03
-CATEGORIES= security
+CATEGORIES= security net-vpn
MASTER_SITES= ftp://ftp.infradead.org/pub/openconnect/ \
ZI
diff --git a/security/openfortivpn/Makefile b/security/openfortivpn/Makefile
index c47b9179ca4e..2080e949cc21 100644
--- a/security/openfortivpn/Makefile
+++ b/security/openfortivpn/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openfortivpn
PORTVERSION= 1.10.0
DISTVERSIONPREFIX=v
-CATEGORIES= security
+CATEGORIES= security net-vpn
MAINTAINER= lifanov@FreeBSD.org
COMMENT= Client for PPP+SSL VPN tunnel services
diff --git a/security/openvpn-admin/Makefile b/security/openvpn-admin/Makefile
index c0f65cfb1ffd..dee0e94516c0 100644
--- a/security/openvpn-admin/Makefile
+++ b/security/openvpn-admin/Makefile
@@ -5,7 +5,7 @@ PORTNAME= openvpn-admin
PORTVERSION= 1.9.4
DISTVERSIONSUFFIX= -2
PORTREVISION= 6
-CATEGORIES= security gnome
+CATEGORIES= security gnome net-vpn
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/release-${PORTVERSION}
MAINTAINER= egypcio@FreeBSD.org
diff --git a/security/openvpn-auth-ldap/Makefile b/security/openvpn-auth-ldap/Makefile
index 5771886f1143..63cc93127270 100644
--- a/security/openvpn-auth-ldap/Makefile
+++ b/security/openvpn-auth-ldap/Makefile
@@ -4,7 +4,7 @@
PORTNAME= openvpn-auth-ldap
PORTVERSION= 2.0.4.0.s1379
PORTREVISION= 3
-CATEGORIES= security
+CATEGORIES= security net-vpn
MASTER_SITES= LOCAL/mandree # figure out proper GitHub commit and use that.
# https://github.com/threerings/openvpn-auth-ldap/
DISTNAME= auth-ldap-${PORTVERSION}
diff --git a/security/openvpn-auth-radius/Makefile b/security/openvpn-auth-radius/Makefile
index f0a629983a06..b9561bffc846 100644
--- a/security/openvpn-auth-radius/Makefile
+++ b/security/openvpn-auth-radius/Makefile
@@ -4,7 +4,7 @@
PORTNAME= openvpn-auth-radius
PORTVERSION= 2.1
PORTREVISION= 4
-CATEGORIES= security
+CATEGORIES= security net-vpn
MASTER_SITES= http://www.nongnu.org/radiusplugin/ \
http://svn-cache.ipcopaddons.org/
DISTNAME= radiusplugin_v${PORTVERSION}
diff --git a/security/openvpn-auth-script/Makefile b/security/openvpn-auth-script/Makefile
index 2a9af7a091db..b8a2826a3e96 100644
--- a/security/openvpn-auth-script/Makefile
+++ b/security/openvpn-auth-script/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openvpn-auth-script
DISTVERSION= 1.0.0.3
-CATEGORIES= security net
+CATEGORIES= security net net-vpn
MAINTAINER= pdemon@gmail.com
COMMENT= Generic script-based deferred auth plugin for OpenVPN
diff --git a/security/openvpn-devel/Makefile b/security/openvpn-devel/Makefile
index c30321805e18..bc89487807cd 100644
--- a/security/openvpn-devel/Makefile
+++ b/security/openvpn-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openvpn
DISTVERSION= 201907
-CATEGORIES= security net
+CATEGORIES= security net net-vpn
MASTER_SITES= https://secure-computing.net/files/openvpn/ \
ftp://ftp2.secure-computing.net/pub/FreeBSD/openvpn-devel/
PKGNAMESUFFIX= -devel
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index 0601cf6002e7..ec769d35869b 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -4,7 +4,7 @@
PORTNAME= openvpn
DISTVERSION= 2.4.7
PORTREVISION?= 0
-CATEGORIES= security net
+CATEGORIES= security net net-vpn
MASTER_SITES= https://swupdate.openvpn.org/community/releases/ \
https://build.openvpn.net/downloads/releases/
diff --git a/security/softether-devel/Makefile b/security/softether-devel/Makefile
index b6ab6dffc120..e97d120bdfc3 100644
--- a/security/softether-devel/Makefile
+++ b/security/softether-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= softether
DISTVERSION= 4.30-9700-beta
#PORTREVISION= 0
-CATEGORIES= security
+CATEGORIES= security net-vpn
MASTER_SITES= https://www.softether-download.com/files/softether/v${DISTVERSION}-2019.07.13-tree/Source_Code/
PKGNAMESUFFIX= -devel
DISTNAME= ${PORTNAME}-src-v${DISTVERSION}
diff --git a/security/softether/Makefile b/security/softether/Makefile
index 01976529cc57..e830ba0ed189 100644
--- a/security/softether/Makefile
+++ b/security/softether/Makefile
@@ -3,7 +3,7 @@
PORTNAME= softether
DISTVERSION= 4.29-9680
PORTREVISION= 2
-CATEGORIES= security
+CATEGORIES= security net-vpn
MASTER_SITES= https://www.softether-download.com/files/softether/v${DISTVERSION}-rtm-2019.02.28-tree/Source_Code/
DISTNAME= ${PORTNAME}-src-v${DISTVERSION}-rtm
diff --git a/security/softether5/Makefile b/security/softether5/Makefile
index 87acf69b06d3..b12967fd81f6 100644
--- a/security/softether5/Makefile
+++ b/security/softether5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= softether
DISTVERSION= 5.01.9671
#PORTREVISION= 0
-CATEGORIES= security
+CATEGORIES= security net-vpn
PKGNAMESUFFIX= 5
MAINTAINER= meta@FreeBSD.org
diff --git a/security/strongswan/Makefile b/security/strongswan/Makefile
index 49a1c4ee2eb3..3fa432215371 100644
--- a/security/strongswan/Makefile
+++ b/security/strongswan/Makefile
@@ -3,7 +3,7 @@
PORTNAME= strongswan
PORTVERSION= 5.8.0
-CATEGORIES= security
+CATEGORIES= security net-vpn
MASTER_SITES= http://download.strongswan.org/ \
http://download2.strongswan.org/
diff --git a/security/tinc-devel/Makefile b/security/tinc-devel/Makefile
index d8620d26255d..b16a8e7a7606 100644
--- a/security/tinc-devel/Makefile
+++ b/security/tinc-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tinc
PORTVERSION= 1.1pre17
PORTREVISION= 3
-CATEGORIES= security
+CATEGORIES= security net-vpn
MASTER_SITES= https://www.tinc-vpn.org/packages/ \
http://www.tinc-vpn.org/packages/
PKGNAMESUFFIX= -devel
diff --git a/security/tinc/Makefile b/security/tinc/Makefile
index 1c3fd6e1c7b0..34a228133c91 100644
--- a/security/tinc/Makefile
+++ b/security/tinc/Makefile
@@ -4,7 +4,7 @@
PORTNAME= tinc
PORTVERSION= 1.0.35
PORTREVISION= 1
-CATEGORIES= security
+CATEGORIES= security net-vpn
MASTER_SITES= https://www.tinc-vpn.org/packages/ \
http://www.tinc-vpn.org/packages/
diff --git a/security/vpnc/Makefile b/security/vpnc/Makefile
index 74dd61f0883c..dab233cca145 100644
--- a/security/vpnc/Makefile
+++ b/security/vpnc/Makefile
@@ -4,7 +4,7 @@
PORTNAME= vpnc
PORTVERSION= 0.5.3
PORTREVISION= 13
-CATEGORIES= security
+CATEGORIES= security net-vpn
MASTER_SITES= http://www.unix-ag.uni-kl.de/~massar/vpnc/ \
LOCAL/ehaupt
diff --git a/sysutils/vpnc-scripts/Makefile b/sysutils/vpnc-scripts/Makefile
index 277b095f918c..bd110bcf4680 100644
--- a/sysutils/vpnc-scripts/Makefile
+++ b/sysutils/vpnc-scripts/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vpnc-scripts
PORTVERSION= 20190611
-CATEGORIES= sysutils
+CATEGORIES= sysutils net-vpn
MASTER_SITES= ftp://ftp.infradead.org/pub/${PORTNAME}/ \
ZI