aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2004-11-05 14:09:52 +0800
committerkuriyama <kuriyama@FreeBSD.org>2004-11-05 14:09:52 +0800
commit232575e09c0d16a1ad2b5e2f05d65146a51eac82 (patch)
tree1fc441aab44809a8ea1445027e96e3906d5977bb
parent05cb299370f0960cc66366f90b5f981411091ff2 (diff)
downloadfreebsd-ports-gnome-232575e09c0d16a1ad2b5e2f05d65146a51eac82.tar.gz
freebsd-ports-gnome-232575e09c0d16a1ad2b5e2f05d65146a51eac82.tar.zst
freebsd-ports-gnome-232575e09c0d16a1ad2b5e2f05d65146a51eac82.zip
Upgrade to 0.81.
Requested by: nork
-rw-r--r--japanese/p5-PDFJ/Makefile2
-rw-r--r--japanese/p5-PDFJ/distinfo4
-rw-r--r--japanese/p5-PDFJ/files/patch-PDFJ.pm62
-rw-r--r--japanese/p5-PDFJ/pkg-plist2
4 files changed, 8 insertions, 62 deletions
diff --git a/japanese/p5-PDFJ/Makefile b/japanese/p5-PDFJ/Makefile
index 01ecbbb31460..f2a64201f238 100644
--- a/japanese/p5-PDFJ/Makefile
+++ b/japanese/p5-PDFJ/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= PDFJ
-PORTVERSION= 0.71
+PORTVERSION= 0.81
CATEGORIES= japanese perl5
MASTER_SITES= http://hp1.jonex.ne.jp/%7Enakajima.yasushi/archives/
diff --git a/japanese/p5-PDFJ/distinfo b/japanese/p5-PDFJ/distinfo
index d9292b91e58b..2307cf0fa11d 100644
--- a/japanese/p5-PDFJ/distinfo
+++ b/japanese/p5-PDFJ/distinfo
@@ -1,2 +1,2 @@
-MD5 (PDFJ-0.71.zip) = 4de974317e91297af70152bf3878efd6
-SIZE (PDFJ-0.71.zip) = 677672
+MD5 (PDFJ-0.81.zip) = cf679512ecd828840ee4a754fada6fc7
+SIZE (PDFJ-0.81.zip) = 1503771
diff --git a/japanese/p5-PDFJ/files/patch-PDFJ.pm b/japanese/p5-PDFJ/files/patch-PDFJ.pm
index f881034daa36..8fd167cc91e0 100644
--- a/japanese/p5-PDFJ/files/patch-PDFJ.pm
+++ b/japanese/p5-PDFJ/files/patch-PDFJ.pm
@@ -1,36 +1,6 @@
---- PDFJ.pm.orig Mon Nov 3 17:20:56 2003
-+++ PDFJ.pm Mon Nov 3 17:55:17 2003
-@@ -1801,9 +1801,9 @@
- }
- my $self;
- if( @args == 1 ) {
-- if( !ref($args[0]) ) {
-+ if( $args[0] and !ref($args[0]) ) {
- $self = PDFJ::Util::strstyle2hashref($args[0]);
-- } elsif( ref($args[0]) eq 'HASH' || ref($args[0]) eq $class ) {
-+ } elsif( $args[0] and (ref($args[0]) eq 'HASH' || ref($args[0]) eq $class) ) {
- %$self = %{$args[0]};
- } else {
- croak "illegal $class->new() argument";
-@@ -1811,7 +1811,7 @@
- } else {
- %$self = @args;
- }
-- if( %$self == 1 && $self->{style} ) {
-+ if( keys %$self == 1 && $self->{style} ) {
- $self = $class->new($self->{style});
- }
- for my $key(keys %$self) {
-@@ -1843,7 +1843,7 @@
- } else {
- %args = @args;
- }
-- if( %args == 1 && $args{style} ) {
-+ if( keys %args == 1 && $args{style} ) {
- $clone = $self->clone($args{style});
- } else {
- $clone = $self->new(%$self);
-@@ -3234,7 +3234,7 @@
+--- PDFJ.pm.orig Thu Oct 28 18:02:55 2004
++++ PDFJ.pm Fri Nov 5 14:59:35 2004
+@@ -3750,7 +3750,7 @@
my($self, $str) = @_;
my $style = $self->style;
my $result = [];
@@ -39,29 +9,3 @@
for( my $j = 0; $j <= $#c; $j++ ) {
my $c = $c[$j];
if( $c ge "\x81" && $c le "\x9f" || $c ge "\xe0" && $c le "\xfc" ) {
-@@ -4166,7 +4166,6 @@
- sub new1 {
- my($class, $value)
- = PDFJ::Util::methodargs([qw(value)], @_);
-- my $class = shift;
- my $self;
- if( ref($value) eq 'ARRAY' ) {
- $self = bless { type => 'rgb', value => $value }, $class;
-@@ -4487,7 +4486,7 @@
- my($self, $x, $y, $w, $h, $style)
- = PDFJ::Util::methodargs([qw(x y w h style)], @_);
- $style = PDFJ::ShapeStyle->new($style)
-- if !ref($style) || ref($style) eq 'HASH';
-+ if ($style and (!ref($style) || ref($style) eq 'HASH'));
- my @stylepdf;
- @stylepdf = $style->pdf if $style;
- my($x1, $y1, $x2, $y2) = ($x, $y, $x + $w, $y + $h);
-@@ -4528,7 +4527,7 @@
- = PDFJ::Util::methodargs([qw(x y w h spec style)], @_);
- $spec = "s" unless $spec;
- $style = PDFJ::ShapeStyle->new($style)
-- if !ref($style) || ref($style) eq 'HASH';
-+ if ($style and (!ref($style) || ref($style) eq 'HASH'));
- my @stylepdf;
- @stylepdf = $style->pdf if $style;
- my($r);
diff --git a/japanese/p5-PDFJ/pkg-plist b/japanese/p5-PDFJ/pkg-plist
index 2249e86bbb6e..facb1eb0077c 100644
--- a/japanese/p5-PDFJ/pkg-plist
+++ b/japanese/p5-PDFJ/pkg-plist
@@ -2,7 +2,9 @@
%%SITE_PERL%%/PDFJ/E2U.pm
%%SITE_PERL%%/PDFJ/Object.pm
%%SITE_PERL%%/PDFJ/S2U.pm
+%%SITE_PERL%%/PDFJ/Shape.pm
%%SITE_PERL%%/PDFJ/TTF.pm
+%%SITE_PERL%%/PDFJ/Type1.pm
%%SITE_PERL%%/PDFJ/U2C.pm
%%SITE_PERL%%/PDFJ/Unicode.pm
%%SITE_PERL%%/XPDFJ.pm