aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-10-14 02:03:49 +0800
committerjbeich <jbeich@FreeBSD.org>2015-10-14 02:03:49 +0800
commit23300143c51ca5bcf23792333cf8c5b7f4ac0047 (patch)
tree80a0a25fe93bdd6a7627447cf5a90812de2dc38d
parentd52408db4c20f2852fdefd0ae9f4ada904b1c12c (diff)
downloadfreebsd-ports-gnome-23300143c51ca5bcf23792333cf8c5b7f4ac0047.tar.gz
freebsd-ports-gnome-23300143c51ca5bcf23792333cf8c5b7f4ac0047.tar.zst
freebsd-ports-gnome-23300143c51ca5bcf23792333cf8c5b7f4ac0047.zip
devel/android-tools-fastboot: don't search for selinuxfs mountpoint
-rw-r--r--devel/android-tools-fastboot-devel/Makefile2
-rw-r--r--devel/android-tools-fastboot-devel/files/Makefile1
-rw-r--r--devel/android-tools-fastboot/Makefile2
-rw-r--r--devel/android-tools-fastboot/files/Makefile1
-rw-r--r--devel/android-tools-fastboot/files/patch-libselinux_src_init.c30
5 files changed, 32 insertions, 4 deletions
diff --git a/devel/android-tools-fastboot-devel/Makefile b/devel/android-tools-fastboot-devel/Makefile
index b31d46787830..3f33e65e2821 100644
--- a/devel/android-tools-fastboot-devel/Makefile
+++ b/devel/android-tools-fastboot-devel/Makefile
@@ -3,7 +3,7 @@
# Hint: git describe --abbrev=12 --match android-m-preview
DISTVERSION= m-preview-1212
DISTVERSIONSUFFIX= -g94c617ccbba4
-PORTREVISION= 0
+PORTREVISION= 1
PKGNAMESUFFIX= -devel
GH_TAGNAME= ${DISTVERSIONFULL:C/-[0-9].*//}-195-g7434d1f:extras \
diff --git a/devel/android-tools-fastboot-devel/files/Makefile b/devel/android-tools-fastboot-devel/files/Makefile
index 6a102de39bb5..21ef0f0fc276 100644
--- a/devel/android-tools-fastboot-devel/files/Makefile
+++ b/devel/android-tools-fastboot-devel/files/Makefile
@@ -51,7 +51,6 @@ SRCS+= label.c
SRCS+= label_android_property.c
SRCS+= label_file.c
SRCS+= label_support.c
-CPPFLAGS.init.c+= -DDARWIN # statfs
CPPFLAGS.label_file.c+= -D_WITH_GETLINE
# required by fastboot and ext4_utils
diff --git a/devel/android-tools-fastboot/Makefile b/devel/android-tools-fastboot/Makefile
index aecacf8647cf..e9aec4774dbc 100644
--- a/devel/android-tools-fastboot/Makefile
+++ b/devel/android-tools-fastboot/Makefile
@@ -3,7 +3,7 @@
PORTNAME= android-tools-fastboot
DISTVERSIONPREFIX= android-
DISTVERSION?= 6.0.0_r1
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= devel
MASTER_SITES= https://anonscm.debian.org/cgit/android-tools/android-tools.git/plain/debian/:bashcomp,manpage
DISTFILES= bash_completion.d/fastboot?id=2b8cfec:bashcomp \
diff --git a/devel/android-tools-fastboot/files/Makefile b/devel/android-tools-fastboot/files/Makefile
index afca2f944a14..d37c577a3aed 100644
--- a/devel/android-tools-fastboot/files/Makefile
+++ b/devel/android-tools-fastboot/files/Makefile
@@ -50,7 +50,6 @@ SRCS+= init.c
SRCS+= label.c
SRCS+= label_android_property.c
SRCS+= label_file.c
-CPPFLAGS.init.c+= -DDARWIN # statfs
# required by fastboot and ext4_utils
.PATH: ${.CURDIR}/../libsparse
diff --git a/devel/android-tools-fastboot/files/patch-libselinux_src_init.c b/devel/android-tools-fastboot/files/patch-libselinux_src_init.c
new file mode 100644
index 000000000000..1e7faa69287c
--- /dev/null
+++ b/devel/android-tools-fastboot/files/patch-libselinux_src_init.c
@@ -0,0 +1,30 @@
+--- libselinux/src/init.c.orig 2015-06-15 21:40:06 UTC
++++ libselinux/src/init.c
+@@ -7,10 +7,7 @@
+ #include <stdio.h>
+ #include <dlfcn.h>
+
+-#ifdef DARWIN
+-#include <sys/param.h>
+-#include <sys/mount.h>
+-#else
++#if defined(__linux__)
+ #include <sys/vfs.h>
+ #endif
+
+@@ -26,6 +23,7 @@ int selinux_page_size = 0;
+
+ static void init_selinuxmnt(void)
+ {
++#if defined(__linux__)
+ char buf[BUFSIZ], *p;
+ FILE *fp=NULL;
+ struct statfs sfbuf;
+@@ -94,6 +92,7 @@ static void init_selinuxmnt(void)
+ if (fp)
+ fclose(fp);
+ return;
++#endif
+ }
+
+ void fini_selinuxmnt(void)