aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2011-04-05 03:40:00 +0800
committerohauer <ohauer@FreeBSD.org>2011-04-05 03:40:00 +0800
commit233c8f3b0d687759433c4af18ca1c0ddac70f70b (patch)
tree6014429d132927789456ca0a12e658c852890bd9
parent9f052ba85bccabfbb935774ad152ff654727c6d0 (diff)
downloadfreebsd-ports-gnome-233c8f3b0d687759433c4af18ca1c0ddac70f70b.tar.gz
freebsd-ports-gnome-233c8f3b0d687759433c4af18ca1c0ddac70f70b.tar.zst
freebsd-ports-gnome-233c8f3b0d687759433c4af18ca1c0ddac70f70b.zip
- remove expired port security/barnyard
- remove barnyard from security/Makefile
-rw-r--r--security/Makefile1
-rw-r--r--security/barnyard/Makefile71
-rw-r--r--security/barnyard/distinfo3
-rw-r--r--security/barnyard/files/64-bit-barnyard.h12
-rw-r--r--security/barnyard/files/64-bit-event.h23
-rw-r--r--security/barnyard/files/64-bit-input-plugins-dp-alert.h12
-rw-r--r--security/barnyard/files/64-bit-util.c12
-rw-r--r--security/barnyard/files/64-bit-util.h12
-rw-r--r--security/barnyard/files/barnyard.sh.in55
-rw-r--r--security/barnyard/files/patch-configure.in9
-rw-r--r--security/barnyard/files/pkg-message.in15
-rw-r--r--security/barnyard/pkg-descr20
-rw-r--r--security/barnyard/pkg-plist9
13 files changed, 0 insertions, 254 deletions
diff --git a/security/Makefile b/security/Makefile
index a932bcdf2865..d4961eed239e 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -27,7 +27,6 @@
SUBDIR += authforce
SUBDIR += autossh
SUBDIR += avcheck
- SUBDIR += barnyard
SUBDIR += barnyard-sguil
SUBDIR += barnyard2
SUBDIR += base
diff --git a/security/barnyard/Makefile b/security/barnyard/Makefile
deleted file mode 100644
index 6233f01e0b4c..000000000000
--- a/security/barnyard/Makefile
+++ /dev/null
@@ -1,71 +0,0 @@
-# New ports collection makefile for: barnyard
-# Date created: 1 Feb 2005
-# Whom: pauls
-#
-# $FreeBSD$
-#
-
-PORTNAME= barnyard
-PORTVERSION= 0.2.0
-PORTREVISION= 8
-CATEGORIES= security
-MASTER_SITES= SF/barnyard/barnyard-0.2/${PORTVERSION}
-
-MAINTAINER= pauls@utdallas.edu
-COMMENT?= An output system for Snort
-
-RUN_DEPENDS+= ${LOCALBASE}/bin/snort:${PORTSDIR}/security/snort
-
-OPTIONS= MYSQL "Enable MySQL support" on \
- POSTGRESQL "Enable PostgreSQL support" off
-
-DEPRECATED= Use security/barnyard2 instead
-EXPIRATION= 2010-12-31
-
-USE_AUTOTOOLS= autoheader aclocal
-USE_RC_SUBR= barnyard.sh
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
-SLAVEDIRS= security/barnyard-sguil6
-SUB_FILES= pkg-message
-
-DOCS= AUTHORS COPYING LICENSE.QPL README
-PORTDOCS= BUGS ChangeLog FAQ INSTALL NEWS USAGE
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_MYSQL)
-USE_MYSQL= yes
-CONFIGURE_ARGS+= --enable-mysql \
- --with-mysql-includes=${LOCALBASE}/include/mysql \
- --with-mysql-libraries=${LOCALBASE}/lib/mysql
-.endif
-
-.if defined(WITH_POSTGRESQL)
-USE_PGSQL= yes
-CONFIGURE_ARGS+= --enable-postgres
-.endif
-
-.if ${ARCH} == "amd64" || ${ARCH} =="ia64" || ${ARCH} == "sparc64"
-EXTRA_PATCHES+= ${FILESDIR}/64-bit-barnyard.h \
- ${FILESDIR}/64-bit-input-plugins-dp-alert.h \
- ${FILESDIR}/64-bit-util.h \
- ${FILESDIR}/64-bit-event.h \
- ${FILESDIR}/64-bit-util.c
-.endif
-
-post-install:
-
-.for f in barnyard.conf
- ${INSTALL_DATA} ${WRKSRC}/etc/${f} ${PREFIX}/etc/${f}-sample
- [ -f ${PREFIX}/etc/${f} ] || \
- ${INSTALL_DATA} ${WRKSRC}/etc/${f} ${PREFIX}/etc/${f}
-.endfor
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
- cd ${WRKSRC}/docs && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.post.mk>
diff --git a/security/barnyard/distinfo b/security/barnyard/distinfo
deleted file mode 100644
index 9926347d35e8..000000000000
--- a/security/barnyard/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (barnyard-0.2.0.tar.gz) = be3283028cf414b52b220308ceb411e9
-SHA256 (barnyard-0.2.0.tar.gz) = 09e0f8e095e79cfe70ea069d13e7d02521a504a1f400a45556a634dccfd31a3a
-SIZE (barnyard-0.2.0.tar.gz) = 161543
diff --git a/security/barnyard/files/64-bit-barnyard.h b/security/barnyard/files/64-bit-barnyard.h
deleted file mode 100644
index 526ab6a3a405..000000000000
--- a/security/barnyard/files/64-bit-barnyard.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/barnyard.h 2004-05-01 12:43:29.000000000 -0400
-+++ src/barnyard.h 2007-08-11 23:22:53.000000000 -0400
-@@ -34,7 +34,8 @@
-
- typedef struct _SnortPktHeader
- {
-- struct timeval ts; /* packet timestamp */
-+ // struct timeval ts; /* packet timestamp */
-+ struct pcap_timeval ts; /* packet timestamp */
- u_int32_t caplen; /* packet capture length */
- u_int32_t pktlen; /* packet "real" length */
- } SnortPktHeader;
diff --git a/security/barnyard/files/64-bit-event.h b/security/barnyard/files/64-bit-event.h
deleted file mode 100644
index 1a0051fb2116..000000000000
--- a/security/barnyard/files/64-bit-event.h
+++ /dev/null
@@ -1,23 +0,0 @@
---- src/event.h 2003-05-02 22:44:12.000000000 -0400
-+++ src/event.h 2007-08-12 00:13:44.000000000 -0400
-@@ -19,6 +19,11 @@
- #include <sys/types.h>
- #include <sys/time.h>
-
-+struct pcap_timeval {
-+ u_int32_t tv_sec; /* seconds */
-+ u_int32_t tv_usec; /* microseconds */
-+};
-+
- typedef struct _Event
- {
- u_int32_t sig_generator; /* which part of snort generated the alert? */
-@@ -30,6 +35,7 @@
- u_int32_t event_reference; /* reference to other events that have gone off,
- * such as in the case of tagged packets...
- */
-- struct timeval ref_time; /* reference time for the event reference */
-+ // struct timeval ref_time; /* reference time for the event reference */
-+ struct pcap_timeval ref_time; /* reference time for the event reference */
- } Event;
- #endif /* __EVENT_H__ */
diff --git a/security/barnyard/files/64-bit-input-plugins-dp-alert.h b/security/barnyard/files/64-bit-input-plugins-dp-alert.h
deleted file mode 100644
index f80c7d6efd66..000000000000
--- a/security/barnyard/files/64-bit-input-plugins-dp-alert.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/input-plugins/dp_alert.h 2004-02-19 20:59:48.000000000 -0500
-+++ src/input-plugins/dp_alert.h 2007-08-11 23:24:25.000000000 -0400
-@@ -34,7 +34,8 @@
- typedef struct _UnifiedAlertRecord
- {
- Event event;
-- struct timeval ts; /* event timestamp */
-+ // struct timeval ts; /* event timestamp */
-+ struct pcap_timeval ts; /* event timestamp */
- u_int32_t sip; /* src ip */
- u_int32_t dip; /* dest ip */
- u_int16_t sp; /* src port */
diff --git a/security/barnyard/files/64-bit-util.c b/security/barnyard/files/64-bit-util.c
deleted file mode 100644
index 805c2f3f322e..000000000000
--- a/security/barnyard/files/64-bit-util.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/util.c 2004-03-06 17:30:15.000000000 -0500
-+++ src/util.c 2007-08-12 00:14:52.000000000 -0400
-@@ -514,7 +514,8 @@
-
- static char tmpbuf[256];
-
--int RenderTimeval(struct timeval *tv, char *timebuf, size_t len)
-+// int RenderTimeval(struct timeval *tv, char *timebuf, size_t len)
-+int RenderTimeval(struct pcap_timeval *tv, char *timebuf, size_t len)
- {
- struct tm *lt;
- time_t timet;
diff --git a/security/barnyard/files/64-bit-util.h b/security/barnyard/files/64-bit-util.h
deleted file mode 100644
index 8109ad11ca3f..000000000000
--- a/security/barnyard/files/64-bit-util.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/util.h 2004-03-06 19:23:50.000000000 -0500
-+++ src/util.h 2007-08-11 23:23:46.000000000 -0400
-@@ -39,7 +39,8 @@
- void ClearDumpBuf();
- void GoDaemon();
- size_t RenderTimestamp(time_t timet, char *timebuf, size_t len);
--int RenderTimeval(struct timeval *tv, char *timebuf, size_t len);
-+// int RenderTimeval(struct timeval *tv, char *timebuf, size_t len);
-+int RenderTimeval(struct pcap_timeval *tv, char *timebuf, size_t len);
- int CreatePidFile(char *filename);
- int String2Long(char *string, long *result);
- int String2ULong(char *string, unsigned long *result);
diff --git a/security/barnyard/files/barnyard.sh.in b/security/barnyard/files/barnyard.sh.in
deleted file mode 100644
index 270a05f45d46..000000000000
--- a/security/barnyard/files/barnyard.sh.in
+++ /dev/null
@@ -1,55 +0,0 @@
-#!/bin/sh
-#
-
-# PROVIDE: barnyard
-# REQUIRE: DAEMON
-# BEFORE: LOGIN
-# KEYWORD: shutdown
-
-# Add the following lines to /etc/rc.conf to enable barnyard:
-# barnyard_enable (bool): Set to YES to enable barnyard
-# Default: NO
-# barnyard_flags (str): Extra flags passed to barnyard
-# Default: -D
-# barnyard_conf (str): Barnyard configuration file
-# Default: %%PREFIX%%/etc/barnyard.conf
-#
-# Usage: barnyard [OPTIONS]... (continual mode)
-# or: barnyard -o [OPTIONS]... FILES... (batch mode)
-# Information Options:
-# -h Show this help information
-# -? Show this help information
-# -V Show version and exit
-# -R Display processed configuration and exit
-# General Configuration Options:
-# -c <file> Use configuration file <file>
-# -d <dir> Read spool files from <dir>
-# -L <dir> Write output files in <dir>
-# -v Increase the verbosity level by 1
-# -s <file> Read the sid-msg map from <file>
-# -g <file> Read the gen-msg map from <file>
-# -p <file> Read the classification map from <file>
-# Continual Processing Mode Options:
-# -a <dir> Archive processed files to <dir>
-# -f <base> Use <base> as the base unified filename
-# -n Only process new events
-# -w <file> Enable bookmarking using <file>
-# -D Run in daemon mode
-# -X <file> Use <file> as the pid file
-# Batch Processing Mode Options:
-# -o Enable batch processing mode
-
-. /etc/rc.subr
-
-name="barnyard"
-load_rc_config $name
-rcvar=`set_rcvar`
-# set some defaults
-: ${barnyard_enable="NO"}
-: ${barnyard_conf="%%PREFIX%%/etc/barnyard.conf"}
-: ${barnyard_flags="-D"}
-
-command="%%PREFIX%%/bin/barnyard"
-command_args="-c ${barnyard_conf}"
-
-run_rc_command "$1"
diff --git a/security/barnyard/files/patch-configure.in b/security/barnyard/files/patch-configure.in
deleted file mode 100644
index 4444b4960f8c..000000000000
--- a/security/barnyard/files/patch-configure.in
+++ /dev/null
@@ -1,9 +0,0 @@
---- configure.in Sat May 1 11:43:29 2004
-+++ configure.in.orig Wed Feb 9 11:47:44 2005
-@@ -282,5 +282,5 @@
- dnl check for the header
- LDFLAGS="${LDFLAGS} -L${MYSQL_LIB_DIR}"
-- LIBS="${LIBS} -lz -lssl -lmysqlclient"
-+ LIBS="${LIBS} -lmysqlclient -lcrypto"
- AC_CHECK_LIB(mysqlclient, mysql_real_connect, FOUND=yes, FOUND=no)
-
diff --git a/security/barnyard/files/pkg-message.in b/security/barnyard/files/pkg-message.in
deleted file mode 100644
index 608c4f92c0dd..000000000000
--- a/security/barnyard/files/pkg-message.in
+++ /dev/null
@@ -1,15 +0,0 @@
-************************************************************************
-
-Read the notes in the barnyard.conf file for how to configure
-%%PREFIX%%/etc/barnyard.conf after installation. For
-further assistance, search the archives of the barnyard-users mailing
-list at http://sourceforge.net/mailarchive/forum.php?forum=barnyard-users
-
-In order to enable barnyard to start on boot, you must edit /etc/rc.conf
-with the appropriate flags, etc. See the FreeBSD Handbook for syntax:
-http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/configtuning-rcng.html
-
-For the various options available, type % barnyard -h after install or read
-the options in the startup script - in %%PREFIX%%/etc/rc.d.
-
-************************************************************************
diff --git a/security/barnyard/pkg-descr b/security/barnyard/pkg-descr
deleted file mode 100644
index 7e86cc7a2201..000000000000
--- a/security/barnyard/pkg-descr
+++ /dev/null
@@ -1,20 +0,0 @@
-Barnyard is output spool reader for Snort! It decouples output overhead
-from the Snort network intrusion detection system and allows Snort to
-run at full speed. It accepts binary inputs from snort and outputs
-human readable files to disc or to a database. At present, barnyard
-is designed to accept binary inputs from snort and produce either human
-readable files for parsing by log parsers or feed data directly to a
-database (either mysql or postgresql at present.).
-
-Barnyard has 3 modes of operation:
-
-One-shot, continual, continual w/ checkpoint. In one-shot mode,
-barnyard will process the specified file and exit. In continual mode,
-barnyard will start with the specified file and continue to process
-new data (and new spool files) as it appears. Continual mode w/
-checkpointing will also use a checkpoint file (or waldo file in the
-snort world) to track where it is. In the event the barnyard process
-ends while a waldo file is in use, barnyard will resume processing at
-the last entry as listed in the waldo file.
-
-WWW: http://sourceforge.net/projects/barnyard
diff --git a/security/barnyard/pkg-plist b/security/barnyard/pkg-plist
deleted file mode 100644
index b0d3a7b3bc9e..000000000000
--- a/security/barnyard/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-bin/barnyard
-@unexec if [ -f %D/etc/barnyard.conf ] && cmp -s %D/etc/barnyard.conf %D/etc/barnyard.conf-sample; then rm -f %D/etc/barnyard.conf; fi
-etc/barnyard.conf-sample
-@exec if [ ! -f %D/etc/barnyard.conf ] ; then cp -p %D/%F %B/barnyard.conf; fi
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE.QPL
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%