aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-25 22:18:16 +0800
committertijl <tijl@FreeBSD.org>2014-09-25 22:18:16 +0800
commit24111c07872c7a69e978fc0094d626c395ae8e60 (patch)
treefb361ea3326d42d4d94abb0a3e2a4fe5dd13e66b
parent8899c5ec56319f17386f61c5ef35417c1e5cf024 (diff)
downloadfreebsd-ports-gnome-24111c07872c7a69e978fc0094d626c395ae8e60.tar.gz
freebsd-ports-gnome-24111c07872c7a69e978fc0094d626c395ae8e60.tar.zst
freebsd-ports-gnome-24111c07872c7a69e978fc0094d626c395ae8e60.zip
Patch Makefile.in instead of Makefile.am to avoid USE_AUTOTOOLS
-rw-r--r--benchmarks/dkftpbench/Makefile8
-rw-r--r--benchmarks/dkftpbench/files/patch-Makefile.am159
2 files changed, 6 insertions, 161 deletions
diff --git a/benchmarks/dkftpbench/Makefile b/benchmarks/dkftpbench/Makefile
index a8aaf1662e87..4d93ccf7fa39 100644
--- a/benchmarks/dkftpbench/Makefile
+++ b/benchmarks/dkftpbench/Makefile
@@ -13,8 +13,12 @@ COMMENT= FTP benchmark program
LICENSE= GPLv2
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= automake14 autoconf
-
PLIST_FILES= bin/dkftpbench
+post-patch:
+ @${REINPLACE_CMD} \
+ -e '/^noinst_PROGRAMS =/s/=.*/=/' \
+ -e '/^lib_LIBRARIES =/s/=.*/=/' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>
diff --git a/benchmarks/dkftpbench/files/patch-Makefile.am b/benchmarks/dkftpbench/files/patch-Makefile.am
deleted file mode 100644
index e522bfefaa2f..000000000000
--- a/benchmarks/dkftpbench/files/patch-Makefile.am
+++ /dev/null
@@ -1,159 +0,0 @@
---- Makefile.am.orig Wed Jul 31 00:10:30 2002
-+++ Makefile.am Fri Oct 22 08:46:31 2004
-@@ -8,36 +8,9 @@
- #----------------------------------------------------------------------
- # List everything we build; break list into three kinds of executables
-
--# Unattended unit tests
--TESTS = \
-- ftp_client_proto_test \
-- nbbio_test \
-- Poller_test \
-- Sked_test
--
--# Following tests are not yet unattended
--HAND_TESTS = \
-- robouser_test \
-- ftp_client_pipe_test
--
- # Real programs
- bin_PROGRAMS = dkftpbench
-
--noinst_PROGRAMS = $(TESTS) $(HAND_TESTS) dklimits Poller_bench profile
--
--lib_LIBRARIES = libPoller.a
--pkginclude_HEADERS = \
-- Poller.h \
-- Poller_devpoll.h \
-- Poller_poll.h \
-- Poller_select.h \
-- Poller_sigio.h \
-- Poller_sigfd.h \
-- Poller_kqueue.h
--
--# No info yet
--info_TEXINFOS =
--
- EXTRA_DIST = \
- inet_aton.c \
- bakeoff.html \
-@@ -87,16 +60,6 @@
- # For each thing we build, list its sources, and anything special about
- # how to build it
-
--libPoller_a_SOURCES = \
-- Poller.h \
-- Poller_sigfd.cc \
-- Poller_sigio.cc \
-- Poller_poll.cc \
-- Poller_select.cc \
-- Poller_devpoll.cc \
-- Poller_kqueue.cc \
-- Poller.cc
--
- dkftpbench_SOURCES = \
- CHECK.h \
- Poller.h \
-@@ -128,90 +91,6 @@
- Poller.cc \
- Sked.cc
-
--dklimits_SOURCES = \
-- dklimits.c
--
--ftp_client_proto_test_SOURCES = \
-- dprint.cc \
-- ftp_client_proto.cc \
-- ftp_client_proto_test.cc
--
--ftp_client_pipe_test_SOURCES = \
-- dprint.cc \
-- eclock.cc \
-- ftp_client_pipe.cc \
-- ftp_client_pipe_test.cc \
-- ftp_client_proto.cc \
-- Poller_poll.cc \
-- Poller.cc \
-- nbbio.cc \
-- Sked.cc
--
--nbbio_test_SOURCES = \
-- dprint.cc \
-- nbbio.cc \
-- nbbio_test.cc
--
--robouser_test_SOURCES = \
-- dprint.cc \
-- eclock.cc \
-- ftp_client_pipe.cc \
-- ftp_client_proto.cc \
-- nbbio.cc \
-- robouser.cc \
-- Platoon.cc \
-- robouser_test.cc \
-- CHECK.cc \
-- Poller_poll.cc \
-- Poller.cc \
-- Sked.cc
--
--Poller_bench_SOURCES = \
-- dprint.cc \
-- eclock.cc \
-- CHECK.cc \
-- Poller.h \
-- Poller.cc \
-- Poller_devpoll.cc \
-- Poller_devpoll.h \
-- Poller_poll.h \
-- Poller_poll.cc \
-- Poller_bench.cc \
-- Poller_select.h \
-- Poller_select.cc \
-- Poller_sigio.h \
-- Poller_sigio.cc \
-- Poller_sigfd.h \
-- Poller_sigfd.cc \
-- Poller_kqueue.h \
-- Poller_kqueue.cc
--
--Poller_test_SOURCES = \
-- dprint.cc \
-- CHECK.cc \
-- eclock.cc \
-- Poller.h \
-- Poller.cc \
-- Poller_sigfd.cc \
-- Poller_sigfd.h \
-- Poller_sigio.cc \
-- Poller_sigio.h \
-- Poller_devpoll.cc \
-- Poller_devpoll.h \
-- Poller_poll.h \
-- Poller_poll.cc \
-- Poller_test.cc \
-- Poller_select.h \
-- Poller_select.cc \
-- Poller_kqueue.h \
-- Poller_kqueue.cc
--
--Sked_test_SOURCES = \
-- dprint.cc \
-- eclock.cc \
-- Sked.cc \
-- Sked_test.cc
--
- #------- start of corba. Not fully autoconfisticated yet ---------
-
- CorbaPlatoon_srv.cc: CorbaPlatoon.idl
-@@ -242,11 +121,6 @@
- /bin/rm -f *.o CorbaPlatoon.hh CorbaPlatoon{_srv,Dyn_srv}.cc
-
- #---- end of corba --------------------------------------------------------
--
--#--------------------------------------------------------------------------
--# Program to do fine-grained profiling of Linux kernel. From the net...
--
--profile_SOURCES = profile.c
-
- #--------------------------------------------------------------------------
- # Extract documentation from sources.